Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Volume button on Task Bar shows only Volume Mixer but I can't switch audio devices

StareX
 Share

Go to solution Solved by StareX,

Alright alright, I fixed it.

 

I reverse engineered every possible change I could've done to me and my gf's computer and found a nice value that on a simple search on the web brought me to a nice regedit trick

 

To anyone who's battling this too, here's the solution:

 

Go into the regedit

Find this:

 

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion

 

Inside there, there should be a folder called MTCUVC

If your issue is like mine, the value should read out EnableMtcUvc = 0

It should be EnableMtcUvc = 1 (Click on it twice to change the decimal)

image.thumb.png.18b584316f6114d203da7a44dbcf55f1.png

 

 

This is also a method to bring back the old volume slider from old Windows versions, set the value to 0 if you don't want the modern look, or set it to 1 to set it back to the modern look.

 

 

 

As the title states, when I click on that icon

image.png.10b1f05bccedf54b0471db19177de95d.png

 

It will only bring up the Volume Mixer.

 

My sound works, drivers are updated.

 

Same phenomenon happens on my gf's computer..

 

What am I missing?

Security Analyst & Tech Enthusiast

Ask me anything.

Link to comment
Share on other sites

Link to post
Share on other sites

10 minutes ago, StareX said:

-snipped-

What you want to do is just click on the volume icon once, not right click and open volume mixer. 

image.png.657bd7a1decb19495660ee28b8749cc1.png

AMD FX™ 6300 @ 4.20 GHz | ASUS M5A97 R2.0 | MSI GTX 550Ti | 24GB Kingston DDR3 | Samsung 850 EVO 250GB WD Green 1.5TB | Antec 300 | ASUS Xonar DG | CoolerMaster Hyper 212 Evo | OCZ 600W | Windows 10 Pro

Sony MDR-V250 | GNT-500 | Logitech G610 Orion Brown | Logitech G402 | Samsung C27JG5 

Intel Core™ i7-7600U | Seagate 500GB HDD | 16GB DDR4 | Windows 10 Enterprise | HP EliteBook 850 G4

Intel Core™ i5-8520U | WD Blue M.2 250GB | 1TB Seagate FireCuda | 8GB DDR4 | Windows 11 Home | ASUS Vivobook 15 

Intel Core™ i7-3520M | GT 630M | 16 GB Corsair Vengeance DDR3 | Samsung 850 EVO 250GB | macOS Catalina  Lenovo IdeaPad P580

iPhone 12 Mini (iOS 14.8) | iPhone XR (iOS 14.8) |  iPad Mini (iOS 9.3.5) 

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, BlueChinchillaEatingDorito said:

What you want to do is just click on the volume icon once, not right click and open volume mixer. 

image.png.657bd7a1decb19495660ee28b8749cc1.png

 

I clicked it once, I'm pretty sure it worked before lol

Security Analyst & Tech Enthusiast

Ask me anything.

Link to comment
Share on other sites

Link to post
Share on other sites

4 minutes ago, StareX said:

 

I clicked it once, I'm pretty sure it worked before lol

So that doesn't work? 

AMD FX™ 6300 @ 4.20 GHz | ASUS M5A97 R2.0 | MSI GTX 550Ti | 24GB Kingston DDR3 | Samsung 850 EVO 250GB WD Green 1.5TB | Antec 300 | ASUS Xonar DG | CoolerMaster Hyper 212 Evo | OCZ 600W | Windows 10 Pro

Sony MDR-V250 | GNT-500 | Logitech G610 Orion Brown | Logitech G402 | Samsung C27JG5 

Intel Core™ i7-7600U | Seagate 500GB HDD | 16GB DDR4 | Windows 10 Enterprise | HP EliteBook 850 G4

Intel Core™ i5-8520U | WD Blue M.2 250GB | 1TB Seagate FireCuda | 8GB DDR4 | Windows 11 Home | ASUS Vivobook 15 

Intel Core™ i7-3520M | GT 630M | 16 GB Corsair Vengeance DDR3 | Samsung 850 EVO 250GB | macOS Catalina  Lenovo IdeaPad P580

iPhone 12 Mini (iOS 14.8) | iPhone XR (iOS 14.8) |  iPad Mini (iOS 9.3.5) 

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, BlueChinchillaEatingDorito said:

So that doesn't work? 

No. Is there a solution or any troubleshooting I could do to figure this out?

Security Analyst & Tech Enthusiast

Ask me anything.

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, StareX said:

No. Is there a solution or any troubleshooting I could do to figure this out?

A work around is right clicking volume and go to Open Sound Settings. You'll be able to switch output devices from there as well. 

image.png.85ecdce44c9307b562b4ab96c62d428d.png

AMD FX™ 6300 @ 4.20 GHz | ASUS M5A97 R2.0 | MSI GTX 550Ti | 24GB Kingston DDR3 | Samsung 850 EVO 250GB WD Green 1.5TB | Antec 300 | ASUS Xonar DG | CoolerMaster Hyper 212 Evo | OCZ 600W | Windows 10 Pro

Sony MDR-V250 | GNT-500 | Logitech G610 Orion Brown | Logitech G402 | Samsung C27JG5 

Intel Core™ i7-7600U | Seagate 500GB HDD | 16GB DDR4 | Windows 10 Enterprise | HP EliteBook 850 G4

Intel Core™ i5-8520U | WD Blue M.2 250GB | 1TB Seagate FireCuda | 8GB DDR4 | Windows 11 Home | ASUS Vivobook 15 

Intel Core™ i7-3520M | GT 630M | 16 GB Corsair Vengeance DDR3 | Samsung 850 EVO 250GB | macOS Catalina  Lenovo IdeaPad P580

iPhone 12 Mini (iOS 14.8) | iPhone XR (iOS 14.8) |  iPad Mini (iOS 9.3.5) 

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, BlueChinchillaEatingDorito said:

A work around is right clicking volume and go to Open Sound Settings. You'll be able to switch output devices from there as well. 

image.png.85ecdce44c9307b562b4ab96c62d428d.png

Fair enough, though I'm looking to solve this issue rather than putting a bandage over it.

 

I could also use the Sound control panel, but my gf and I would rather switch the audio on the fly cuz we have speakers :)

 

Security Analyst & Tech Enthusiast

Ask me anything.

Link to comment
Share on other sites

Link to post
Share on other sites

Everyone. Please allow me. I’ve wrestled Windows 10 enough.

 

You need to go to control panel, sound, then change the default audio output device.

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, Jet_ski said:

Everyone. Please allow me. I’ve wrestled Windows 10 enough.

 

You need to go to control panel, sound, then change the default audio output device.

Alright, I think you've misread.

 

 

The drop down menu that lists the playback devices is not shown, the sound WORKS, the audio itself is fine, the feature is turned OFF for some reason or not working.

 

:)

Security Analyst & Tech Enthusiast

Ask me anything.

Link to comment
Share on other sites

Link to post
Share on other sites

4 minutes ago, StareX said:

Fair enough, though I'm looking to solve this issue rather than putting a bandage over it.

 

I could also use the Sound control panel, but my gf and I would rather switch the audio on the fly cuz we have speakers :)

 

Does anything show up when you click on volume though? Can you provide a screenshot?

AMD FX™ 6300 @ 4.20 GHz | ASUS M5A97 R2.0 | MSI GTX 550Ti | 24GB Kingston DDR3 | Samsung 850 EVO 250GB WD Green 1.5TB | Antec 300 | ASUS Xonar DG | CoolerMaster Hyper 212 Evo | OCZ 600W | Windows 10 Pro

Sony MDR-V250 | GNT-500 | Logitech G610 Orion Brown | Logitech G402 | Samsung C27JG5 

Intel Core™ i7-7600U | Seagate 500GB HDD | 16GB DDR4 | Windows 10 Enterprise | HP EliteBook 850 G4

Intel Core™ i5-8520U | WD Blue M.2 250GB | 1TB Seagate FireCuda | 8GB DDR4 | Windows 11 Home | ASUS Vivobook 15 

Intel Core™ i7-3520M | GT 630M | 16 GB Corsair Vengeance DDR3 | Samsung 850 EVO 250GB | macOS Catalina  Lenovo IdeaPad P580

iPhone 12 Mini (iOS 14.8) | iPhone XR (iOS 14.8) |  iPad Mini (iOS 9.3.5) 

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, BlueChinchillaEatingDorito said:

Does anything show up when you click on volume though? Can you provide a screenshot?

Please read the first message of my thread.

And also the title states it shows the Volume Mixer :)

Security Analyst & Tech Enthusiast

Ask me anything.

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, StareX said:

Please read the first message of my thread.

And also the title states it shows the Volume Mixer :)

Wait... is that Windows 8/8.1? 

AMD FX™ 6300 @ 4.20 GHz | ASUS M5A97 R2.0 | MSI GTX 550Ti | 24GB Kingston DDR3 | Samsung 850 EVO 250GB WD Green 1.5TB | Antec 300 | ASUS Xonar DG | CoolerMaster Hyper 212 Evo | OCZ 600W | Windows 10 Pro

Sony MDR-V250 | GNT-500 | Logitech G610 Orion Brown | Logitech G402 | Samsung C27JG5 

Intel Core™ i7-7600U | Seagate 500GB HDD | 16GB DDR4 | Windows 10 Enterprise | HP EliteBook 850 G4

Intel Core™ i5-8520U | WD Blue M.2 250GB | 1TB Seagate FireCuda | 8GB DDR4 | Windows 11 Home | ASUS Vivobook 15 

Intel Core™ i7-3520M | GT 630M | 16 GB Corsair Vengeance DDR3 | Samsung 850 EVO 250GB | macOS Catalina  Lenovo IdeaPad P580

iPhone 12 Mini (iOS 14.8) | iPhone XR (iOS 14.8) |  iPad Mini (iOS 9.3.5) 

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, BlueChinchillaEatingDorito said:

Wait... is that Windows 8/8.1? 

Windows 10.

 

 

64bit.

 

 

I have a feeling you guys are trolling me :|

Security Analyst & Tech Enthusiast

Ask me anything.

Link to comment
Share on other sites

Link to post
Share on other sites

Couple of things.

 

1. What do you see in this Sound window in the screenshot? If your problem is the same as mine then you have to change the default output to the one you frequently connect and disconnect. By default on my PC, if I plug in headphones into the audio jack, the OS would not play audio in the headphones. So what I have to do is set the headphones as the default output then when the headphones are not plugged in, it’ll play audio on the main speakers.

 

2. I think the blue “Mixer” in your screenshot is a hyperlink to the mixer, you’re not actually in the mixer, click on it to open the mixer. (My older PC did that).

EFCB8D24-3648-4DC9-A4DA-1C04405A24F0.jpeg

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, Jet_ski said:

Couple of things.

 

1. What do you see in this Sound window in the screenshot? If your problem is the same as mine then you have to change the default output to the one you frequently connect and disconnect. By default on my PC, if I plug in headphones into the audio jack, the OS would not play audio in the headphones. So what I have to do is set the headphones as the default output then when the headphones are not plugged in, it’ll play audio on the main speakers.

 

2. I think the blue “Mixer” in your screenshot is a hyperlink to the mixer, you’re not actually in the mixer, click on it to open the mixer. (My older PC did that).

EFCB8D24-3648-4DC9-A4DA-1C04405A24F0.jpeg

 

I can see the Sound Control Panel menu, the audio works as well as my speakers.

 

2. Yeah, It's the speaker volume probably an old default Windows thing where I can change the volume, which works perfect.

 

Though I want that black drop-down menu that tells me my playback Devices on Windows 10.

Security Analyst & Tech Enthusiast

Ask me anything.

Link to comment
Share on other sites

Link to post
Share on other sites

Alright alright, I fixed it.

 

I reverse engineered every possible change I could've done to me and my gf's computer and found a nice value that on a simple search on the web brought me to a nice regedit trick

 

To anyone who's battling this too, here's the solution:

 

Go into the regedit

Find this:

 

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion

 

Inside there, there should be a folder called MTCUVC

If your issue is like mine, the value should read out EnableMtcUvc = 0

It should be EnableMtcUvc = 1 (Click on it twice to change the decimal)

image.thumb.png.18b584316f6114d203da7a44dbcf55f1.png

 

 

This is also a method to bring back the old volume slider from old Windows versions, set the value to 0 if you don't want the modern look, or set it to 1 to set it back to the modern look.

 

 

 

Security Analyst & Tech Enthusiast

Ask me anything.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×