Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

To all Kraken owners: How annoying is CAM software?

As the title suggests, how bad is the current version of the software? I already have iCue and G Hub installed, and don't really want to have another RGB software impede my system's performance.

CPU -AMD R5 2600X @ 4.15 GHz / RAM - 2x8Gb GSkill Ripjaws 3000 MHz/ MB- Asus Crosshair VII Hero X470/  GPU- MSI Gaming X GTX 1080/ CPU Cooler - Be Quiet! Dark Rock 3/ PSU - Seasonic G-series 550W/ Case - NZXT H440 (Black/Red)/ SSD - Crucial MX300 500GB/ Storage - WD Caviar Blue 1TB/ Keyboard - Corsair Vengeance K70 w/ Red switches/ Mouse - Logitech g900/ Display - 27" Benq GW2765 1440p display/ Audio - Sennheiser HD 558 and Logitech z323 speakers

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, IrshaadH said:

As the title suggests, how bad is the current version of the software? I already have iCue and G Hub installed, and don't really want to have another RGB software impede my system's performance.

CAM really is not that bad honestly. I like the interface a lot more than Aura, iCUE etc, as far as lighting control. I dont and will never use the overclocking controls in the software. I have the NZXT H500i case and 2 120mm NZXT aer RGB fans. Unfortunately, the way the system is set up now I am using the controller that came with the case for the strip lights as well as the HUE 2 controller included with the fans to control the fan lighting. Not ideal, I believe I can switch the strip lights over to the HUE 2 controller and eliminate the controller that came with the case completely, I just havent gotten around to it yet and it means I have to pull everything apart on the back panel and re-cable manage it (my fave.....)

 

Overall, I give the software a solid 7/10 for lighting and fan control. I plan on getting rid of my Corsair H115i AiO and replacing it with a Kraken, effectively eliminating iCUE from my list of lighting controls so that I too dont have 4+ lighting softwares running at once.

CPU: Ryzen 5 2600X GPU: Reference 5700XT (Asus) Motherboard: Asus ROG Strix X470-F RAM: G.Skill Trident Z RGB 3200C16 PSU: Corsair RM850X White

Cooling: Corsair H115i RGB Storage: 500GB WD SN750 M.2, 500GB Samsung 860 Evo SSD, 1TB Seagate Firecuda SSHD Case: NZXT H500i White

Keyboard: Asus ROG Strix Flare (MX Red) Mouse: Corsair Sabre RGB Monitor: HP Omen 25 144hz 

 

Link to comment
Share on other sites

Link to post
Share on other sites

Very annoying. Even had some issues with games crashing when it was running.

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, noxdeouroboros said:

Very annoying.

Are you having issues with the software? Or do you just not like how its laid out?

CPU: Ryzen 5 2600X GPU: Reference 5700XT (Asus) Motherboard: Asus ROG Strix X470-F RAM: G.Skill Trident Z RGB 3200C16 PSU: Corsair RM850X White

Cooling: Corsair H115i RGB Storage: 500GB WD SN750 M.2, 500GB Samsung 860 Evo SSD, 1TB Seagate Firecuda SSHD Case: NZXT H500i White

Keyboard: Asus ROG Strix Flare (MX Red) Mouse: Corsair Sabre RGB Monitor: HP Omen 25 144hz 

 

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, CPT_BEEMO said:

Are you having issues with the software? Or do you just not like how its laid out?

Both, but mostly there were many issues, had some issues with games crashing when it was running.

Link to comment
Share on other sites

Link to post
Share on other sites

I had that issue on a much much older version of CAM from March 2019. Once this new Beta version was released I think in late 2019, I too again had a few problems but most of my crashes or issues were drivers from the cursed 5700XT (Thanks AMD). CAM was updated only a few days ago and I have to say, so far so good. Looks really good in dark mode, Easy to control all the addressable lights, I again would just stay away from the overclocking features.

CPU: Ryzen 5 2600X GPU: Reference 5700XT (Asus) Motherboard: Asus ROG Strix X470-F RAM: G.Skill Trident Z RGB 3200C16 PSU: Corsair RM850X White

Cooling: Corsair H115i RGB Storage: 500GB WD SN750 M.2, 500GB Samsung 860 Evo SSD, 1TB Seagate Firecuda SSHD Case: NZXT H500i White

Keyboard: Asus ROG Strix Flare (MX Red) Mouse: Corsair Sabre RGB Monitor: HP Omen 25 144hz 

 

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, CPT_BEEMO said:

I had that issue on a much much older version of CAM from March 2019. Once this new Beta version was released I think in late 2019, I too again had a few problems but most of my crashes or issues were drivers from the cursed 5700XT (Thanks AMD). CAM was updated only a few days ago and I have to say, so far so good. Looks really good in dark mode, Easy to control all the addressable lights, I again would just stay away from the overclocking features.

I also use 5700xt, never had issues with it. I used the latest cam version, just uninstalled yesterday and the issues are gone.

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, noxdeouroboros said:

I also use 5700xt, never had issues with it. I used the latest cam version, just uninstalled yesterday and the issues are gone.

Lol see I did polar opposite. Installed newest AMD drivers, games crashed left right and center, screen going black, all that good stuff. went back to 19.12.2 drivers, no problem.

CPU: Ryzen 5 2600X GPU: Reference 5700XT (Asus) Motherboard: Asus ROG Strix X470-F RAM: G.Skill Trident Z RGB 3200C16 PSU: Corsair RM850X White

Cooling: Corsair H115i RGB Storage: 500GB WD SN750 M.2, 500GB Samsung 860 Evo SSD, 1TB Seagate Firecuda SSHD Case: NZXT H500i White

Keyboard: Asus ROG Strix Flare (MX Red) Mouse: Corsair Sabre RGB Monitor: HP Omen 25 144hz 

 

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, noxdeouroboros said:

I also use 5700xt, never had issues with it. I used the latest cam version, just uninstalled yesterday and the issues are gone.

Is it possible to use a Kraken cooler without installing CAM?

CPU -AMD R5 2600X @ 4.15 GHz / RAM - 2x8Gb GSkill Ripjaws 3000 MHz/ MB- Asus Crosshair VII Hero X470/  GPU- MSI Gaming X GTX 1080/ CPU Cooler - Be Quiet! Dark Rock 3/ PSU - Seasonic G-series 550W/ Case - NZXT H440 (Black/Red)/ SSD - Crucial MX300 500GB/ Storage - WD Caviar Blue 1TB/ Keyboard - Corsair Vengeance K70 w/ Red switches/ Mouse - Logitech g900/ Display - 27" Benq GW2765 1440p display/ Audio - Sennheiser HD 558 and Logitech z323 speakers

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, IrshaadH said:

Is it possible to use a Kraken cooler without installing CAM?

You sure can!

 

Whatever default light it powers up at which I believe would be white or purple it will stay on. You will also not have any sort of pump control in Windows. 

CPU: Ryzen 5 2600X GPU: Reference 5700XT (Asus) Motherboard: Asus ROG Strix X470-F RAM: G.Skill Trident Z RGB 3200C16 PSU: Corsair RM850X White

Cooling: Corsair H115i RGB Storage: 500GB WD SN750 M.2, 500GB Samsung 860 Evo SSD, 1TB Seagate Firecuda SSHD Case: NZXT H500i White

Keyboard: Asus ROG Strix Flare (MX Red) Mouse: Corsair Sabre RGB Monitor: HP Omen 25 144hz 

 

Link to comment
Share on other sites

Link to post
Share on other sites

4 minutes ago, IrshaadH said:

Is it possible to use a Kraken cooler without installing CAM?

Yes, I use it without CAM installed.

 

4 minutes ago, CPT_BEEMO said:

Lol see I did polar opposite. Installed newest AMD drivers, games crashed left right and center, screen going black, all that good stuff. went back to 19.12.2 drivers, no problem.

Lucky me then, no idea. There were bunch of people in this forum and online in general that had all kind of issues with the xt, not the case with me, no issues at all.

Link to comment
Share on other sites

Link to post
Share on other sites

3 minutes ago, CPT_BEEMO said:

You sure can!

 

Whatever default light it powers up at which I believe would be white or purple it will stay on. You will also not have any sort of pump control in Windows. 

 

2 minutes ago, noxdeouroboros said:

Yes, I use it without CAM installed.

 

Lucky me then, no idea. There were bunch of people in this forum and online in general that had all kind of issues with the xt, not the case with me, no issues at all.

Thanks for all your info guys, really appreciate it!

CPU -AMD R5 2600X @ 4.15 GHz / RAM - 2x8Gb GSkill Ripjaws 3000 MHz/ MB- Asus Crosshair VII Hero X470/  GPU- MSI Gaming X GTX 1080/ CPU Cooler - Be Quiet! Dark Rock 3/ PSU - Seasonic G-series 550W/ Case - NZXT H440 (Black/Red)/ SSD - Crucial MX300 500GB/ Storage - WD Caviar Blue 1TB/ Keyboard - Corsair Vengeance K70 w/ Red switches/ Mouse - Logitech g900/ Display - 27" Benq GW2765 1440p display/ Audio - Sennheiser HD 558 and Logitech z323 speakers

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×