Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Driver Problem with Avermedia GC573

Dataanti
 Share

Hello guys, I have an issue with a new driver that was supposed to fix an audio issue among other things with GC573 capture card but only made things worse. There are people who have this driver working without issues so I'm wondering if maybe some of you guys might be able to shed some light on whats happening.

The specifics of what is happening are as follows:

The drivers that worked in the past is version 2.2.64.70 However I am not sure what my old firmware on the capture card was. The new driver is version 2.2.64.82 and it updated the firmware on the capture card to 2019.12.05.
After this driver update, I began having audio issues, just lots of crackling, popping, and stuttering coming from the capture card. I thought I would just try rolling back the drivers to 2.2.64.70, however the driver install hangs at around 75%. When I end the task, the computer runs fine, however the capture card blinks red and refuses to do anything. I cant even uninstall the device via device manager. When rebooting or shutting down the PC, it hangs on the shut down screen forcing me to force shutdown the computer. And then the computer will not boot up, it gets stuck on the OEM loading screen with the white dots that move in a circle. To get the computer to work correctly again, I need to do a system restore. Once I have done a system restore, everything is all back to normal, I tried uninstalling the new broken driver and installing an even older driver, I did this several times with the same result on every driver I tried, However if I reinstall the broken 2.2.64.82 driver, it installs seemingly without an issue, capture card stops blinking red and works, however I still have the audio problem.

I think what is happening with the old drivers hanging on install, is that there might be some sort of conflict between the old drivers and the new firmware, either the old driver installer gets stuck trying to install and older firmware onto the card or something else, i'm not sure, I don't expect anyone to be able to help with that as only avermedia knows how their capture card and drivers work I am sure, I have contacted them about it but reading their subreddit, their is a few people with this problem in the past few weeks.

Because their is people running the new drivers and firmware just fine. I am hoping you guys might be able to help me out with getting the new drivers working correctly to fix the audio. Hopefully it's just some sort of conflict with windows that can be fixed by changing something in windows. All I have to go on is an error in the event viewer when I install the new drivers, I found the moment when installed the original drivers when the PC was a fresh install and this error was not here, It only occurred when installing or reinstalling the new driver.

 

- System

- Provider
[ Name] Microsoft-Windows-Kernel-PnP
[ Guid] {9c205a39-1250-487d-abd7-e831c6290539}
EventID 411
Version 0
Level 2
Task 0
Opcode 0
Keywords 0x4000000000000000

- TimeCreated
[ SystemTime] 2020-04-29T03:57:51.820054200Z
EventRecordID 625
Correlation

- Execution
[ ProcessID] 4
[ ThreadID] 1624
Channel Microsoft-Windows-Kernel-PnP/Configuration
Computer StreamPC

- Security
[ UserID] S-1-5-18

- EventData

DeviceInstanceId PCI\VEN_1461&DEV_0054&SUBSYS_57301461&REV_00\4&30466ac5&0&00E8
DriverName oem3.inf
ClassGuid {4d36e96c-e325-11ce-bfc1-08002be10318}
ServiceName AVXGC573Cap
LowerFilters
UpperFilters
Problem 0x15
Status 0x0


Anyone have any recommendations? 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×