Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

5700 XT fan unresponsive to MSI afterburner

Go to solution Solved by danhulud,

Ok, so I seem to have solved this....

 

There's an FAQ on the XFX website which makes mention of 5700 XT Thicc fans not spinning. It recommends using either driver 19.9.3 or 19.8.2. It makes mention that if you're using The 19.9.1 and 19.9.2 that can cause problems, even though I was using a a more modern driver the problem seems to have persisted. I DDUed my current drivers and installed 19.9.3 which seems to have corrected the problem, I have full control of the fans in Afterburner now, and can set them to any fan curve which seems to respond accordingly. I can also set them to spin at any % if I want too.

Hi all,

So as the title. My GPU is an XFX 5700 XT Thicc III, and when I try alter the fan curve in MSI Afterburner nothing is happening. I've had a google and it seems like this is a more widespread issue with 5700 XTs; however I cannot find a solution apart from a BIOS update which I'd rather not do, as I don't want to accidentally brick the card. So is there any solutions? If I have to change software to something else then that would be fine, but ideally I'd like to sitck with Afterburner.

Finally, everything is new and fully updated (apart from maybe the BIOS)

 

Specs are:

Ryzen 5 2600
MSI B450M-A Pro Max
16GB Corsair Vengance LPX 3000mhz (2x 8GB)
XFX 5700 XT Thicc III
Win10 Home

and we will live such tragedy in perpetuity.

Link to comment
Share on other sites

Link to post
Share on other sites

“Fan” could be taken a couple ways.  Both fans or just one of them?   Low probability, but if it’s only one fan out of the two it could point to fan hardware problems.  Bios still more likely even if only one fan though.

Life is like a bowl of chocolates: there are all these little crinkly paper cups everywhere.

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, Bombastinator said:

“Fan” could be taken a couple ways.  Both fans or just one of them?   Low probability, but if it’s only one fan out of the two it could point to fan hardware problems.  Bios still more likely even if only one fan though.

All three fans ramp up when I'm in a game, so they definitely work; it just seems as though I have no control over them in Afterburner

and we will live such tragedy in perpetuity.

Link to comment
Share on other sites

Link to post
Share on other sites

11 minutes ago, danhulud said:

All three fans ramp up when I'm in a game, so they definitely work; it just seems as though I have no control over them in Afterburner

 

Did you set a custom fan curve?

If so, can you upload a picture of that here?

 

Afterburner might be conflicting with Radeon Settings / Wattman.

When you go to install the Radeon software, click on Custom Install and only install the drivers / the software pieces that you need.

Intel Z390 Rig ( *NEW* Primary )

Intel X99 Rig (Officially Decommissioned, Dead CPU returned to Intel)

  • i7-8086K @ 5.1 GHz (still tweaking) -- i7-6800K
  • Gigabyte Z390 Aorus Master -- ASUS X99 Deluxe
  • Sapphire NITRO+ RX 5700 XT Special Edition -- 2x Sapphire NITRO R9-Fury in Crossfire
  • 32GB G.Skill TridentZ DDR4-3000 CL14 (16GB TridentZ RGB + 16GB Red/Black TridentZ)
  • SanDisk 480 GB SSD + 1TB Samsung 860 EVO + 1TB Intel 660p NVMe
  • EVGA SuperNOVA 850W P2 + Red/White CableMod Cables
  • Phanteks Enthoo Luxe Tempered Glass Edition
  • Ekwb Custom loop
  • Logitech G502 Proteus Spectrum + Corsair K70 (Red LED, anodized black, Cheery MX Browns)

Intel Z97 Rig (Secondary)

  • Intel i5-4690K 4.8 GHz
  • ASUS ROG Maximus VII Hero Z97
  • Sapphire Vapor-X HD 7950 EVGA GTX 1070 SC Black Edition ACX 3.0
  • 20 GB (8GB X 2 + 4GB X 1) Corsair Vengeance DDR3 1600 MHz
  • Corsair A50 air cooler  NZXT X61
  • Crucial MX500 1TB SSD + SanDisk Ultra II 240GB SSD + WD Caviar Black 1TB HDD + Kingston V300 120GB SSD [non-gimped version]
  • Antec New TruePower 550W EVGA G2 650W + White CableMod cables
  • Cooler Master HAF 912 White NZXT S340 Elite w/ white LED stips

AMD 990FX Rig (Decommissioned)

  • FX-8350 @ 4.8 / 4.9 GHz (given up on the 5.0 / 5.1 GHz attempt)
  • ASUS ROG Crosshair V Formula 990FX
  • 12 GB (4 GB X 3) G.Skill RipJawsX DDR3 @ 1866 MHz
  • Sapphire Vapor-X HD 7970 + Sapphire Dual-X HD 7970 in Crossfire  Sapphire NITRO R9-Fury in Crossfire *NONE*
  • Thermaltake Frio w/ Cooler Master JetFlo's in push-pull
  • Samsung 850 EVO 500GB SSD + Kingston V300 120GB SSD + WD Caviar Black 1TB HDD
  • Corsair TX850 (ver.1)
  • Cooler Master HAF 932

 

<> Electrical Engineer , B.Eng <>

<> Electronics & Computer Engineering Technologist (Diploma + Advanced Diploma) <>

<> Electronics Engineering Technician for the Canadian Department of National Defence <>

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, -rascal- said:

 

Did you set a custom fan curve?

If so, can you upload a picture of that here?

 

Afterburner might be conflicting with Radeon Settings / Wattman.

When you go to install the Radeon software, click on Custom Install and only install the drivers / the software pieces that you need.

Yeah, I have a custom fan curve, I'll attach an image. I will state that even though in the main part of Afterburner it's showing a % of fan speed but the fans are not active, only in game, or at least in one game I've tried.

I have a terible short term memory but I think this morning I installed the drivers/Radeon Software, I'm certain Wattman didn't install at the same time. Infact I don't know what watman is, I assume it's the AMD equivelent of Afterburner?

Capture.PNG

and we will live such tragedy in perpetuity.

Link to comment
Share on other sites

Link to post
Share on other sites

Click where it says AuTO in the right part of the image.

 

| CPU: Core i7-8700K @ 4.89ghz - 1.21v  Motherboard: Asus ROG STRIX Z370-E GAMING  CPU Cooler: Corsair H100i V2 |
| GPU: MSI GTX 1080Ti Gaming X Trio 2ghz OC  RAM: 32GB T-Force Delta RGB 3066mhz |
| Displays: Acer Predator XB270HU 1440p Gsync 144hz IPS Gaming monitor | Oculus Rift S

Link to comment
Share on other sites

Link to post
Share on other sites

11 minutes ago, i_build_nanosuits said:

Click where it says AuTO in the right part of the image.

 

Clicking auto just lets me choose the fan speed % but doesn't alter the fan speed, they are still unresponsive.

and we will live such tragedy in perpetuity.

Link to comment
Share on other sites

Link to post
Share on other sites

Ok, so I seem to have solved this....

 

There's an FAQ on the XFX website which makes mention of 5700 XT Thicc fans not spinning. It recommends using either driver 19.9.3 or 19.8.2. It makes mention that if you're using The 19.9.1 and 19.9.2 that can cause problems, even though I was using a a more modern driver the problem seems to have persisted. I DDUed my current drivers and installed 19.9.3 which seems to have corrected the problem, I have full control of the fans in Afterburner now, and can set them to any fan curve which seems to respond accordingly. I can also set them to spin at any % if I want too.

Edited by danhulud
Missed out some words

and we will live such tragedy in perpetuity.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×