Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Hello everyone!

I'm trying to overclock my i7-7700K on Gigabyte Z270 Gaming K3 motherboard. Every time I apply any changes in BIOS, the clocks change there and are being shown by it's monitor but when I boot into Windows, none of the monitoring programs nor the system show any changes (putting the CPU under load doesn't help too). I've tried various methods, tutorials, even the Gigabyte's overclocking guide, clearing CMOS, F7 and F9d versions of BIOS, double checked windows' power plan (is set to performance mode). Some changes show only when I change multipliers with programs such as XTU or Gigabyte EasyTune but I want to overclock it in BIOS. Also my Windows is a fresh install with all drivers updated.

Would appreciate any help since everything I've tried was pointless...

 

My specs: 
-mobo: Gigabyte GA-Z270-GAMING K3
-cpu: Intel Core i7-7700K
-cpu cooler: SilentiumPC Fera 3 120mm
-ram: G.SKILL 16GB 3000MHz Ripjaws V Red CL15 (2x8GB)
-ssd: Samsung 500GB M.2 PCIe NVMe 970 EVO Plus
-gpu: GIGABYTE AORUS GTX 1080 Ti XTREME Edition
-psu: Corsair CX750M 750W 80 Plus Bronze
-system: Win 10 Home (Build 18363.720) 

Link to post
Share on other sites

Hmm, I'd start with a new cmos battery. Can you at least check the voltage of your battery with a multimeter??

- If it ain't broken, don't fix it! - - Your post codes and beep codes in the drop down below -

Spoiler

 

 

Link to post
Share on other sites

Unfortunately I wasn't able to get a new battery. I checked the one I have and the multimeter shows exactly 3.2V.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Newegg

×