Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

PC turns on weirdly

so my pc has been a little finnicky with turning on. it sometimes turns on like normal, when you press the power button, but this time the times it turns on normally is outnumbered by the amount of times it hasn't. the first time it didn't turn on i opened up and made sure everything in the mobo was secure (unplugged everything), 2nd time i redid the front io cables and usb 3.0 (unplugged of course), 3rd time i unplugged from the pc and plugged it back in and it was fine, 4th time was today where i unplugged it from the surge protector and plugged it back in and it turned on. this seems to happen when it is off for extended periods of time.. more than like 45 minutes. is it my power supply or psu?

Link to post
Share on other sites

You didn't explain what was abnormal about its boot

Community Standards || Tech News Posting Guidelines

---======================================================================---

CPU: R5 3600 || GPU: GTX 1080 || Memory: 16GB @ 3200 || Cooler: Noctua D15 || PSU: 750W EVGA G2 || Case: Define C

Link to post
Share on other sites

Yes, it very much sounds like a PSU issue and it sounds like it's going to fail for good VERY SOON. The times I've experienced this type of failure, both from computer PSUs and the ones integrated into monitors, I got maybe a dozen more successful startups out of them before they finally died for good.

 

Link to post
Share on other sites
3 hours ago, Kedohawyr said:

Yes, it very much sounds like a PSU issue and it sounds like it's going to fail for good VERY SOON. The times I've experienced this type of failure, both from computer PSUs and the ones integrated into monitors, I got maybe a dozen more successful startups out of them before they finally died for good.

 

Define very soon. I plan to go back to microcenter this Thursday to get it replaced.

Link to post
Share on other sites
4 hours ago, Slottr said:

You didn't explain what was abnormal about its boot

I did though. The way the PC turns on is.. weird.

Link to post
Share on other sites
8 hours ago, Johnsilverknight said:

Define very soon. I plan to go back to microcenter this Thursday to get it replaced.

I've personally gone through this twice, once simply because of years of wear (about 44,000 hours of on time with daily power cycling) on the capacitors and once due to a power surge damaging them. In the first case I think I was able to get it to come back to life with repeated attempts for 6 days before it finally died completely. In the second case I was able to get it to power on exactly once before it was gone.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×