Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Ram limited to 2400mhz when ram and mobo clearly supports 2666mhz

ive got my pc for like 2 months now and ive been kinda bothered by my ram unable to clock at 2666mhz

im using the geil evo potenza 2666mhz 1x8 stick of ram and an asrock h310cm-dvs mobo(2 dimms)

i checked out the website of the motherboard and it says it supports up to 2666mhz ram

the ram also clearly 2666mhz (on the package and on the website)

 

i also tried playing with the bios settings but nothing works

also checked cpu z and it says its clocked at 2400 

 

is there any way to fix this,if not,i wont return the ram since its too much of a hassle for just 233mhz of a difference

 

thx in advance

Link to post
Share on other sites

Have you tried running XMP profiles? Can you manually set the speed of the ram?

Be sure to @Pickles - Lord of the Jar if you want me to see your reply!

Stopping by to praise the all mighty jar Lord pickles... * drinks from a chalice of holy pickle juice and tossed dill over shoulder* ~ @WarDance
3600x | NH-D15 Chromax Black | 32GB 3200MHz | GTX 1070 Hybrid (2100c/2241m) | Gigabyte X570 Aorus Elite | Seasonic X760w | Phanteks Evolv X | 500GB WD_Black SN750 | Sandisk Skyhawk 3.84TB SSD | 4TB HDD 

Link to post
Share on other sites

well anything above a 2400mhz clock is an OC maybe your mobo supports it but under OC mode. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×