Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Monitor now displaying "no signal"

Go to solution Solved by CharlesM2020,
6 minutes ago, soksncroks said:

It wakes up when plugged into DP, scans the sources then cant find a signal then turns itself off. but when plugged into HDMI there is no issues

 

When it is not displaying, and you can drag your mouse across it (not visibly, but the appropriate movement is there), go to your display settings. If you are able to see the monitor in your settings, set the refresh rate to 60hz and apply the settings. Set the refresh rate back to what it was and apply again. Let us know if your monitor displays anything during the process.

I have 3 monitors, 2 1080p 60hz monitors running on hdmi and DVI, and then i have one 1080p 144hz monitor running on display port. i awoke from a nap to notice once my pc woke from its sleep that the middle (display port 144hz) monitor was getting no signal. i had no issues up until this point and it came out of nowhere.i hooked my main monitor to HDMI and its working fine (although only a 120 hz). ive tried all 3 DP ports on my GPU and still getting nothing. ive also re-saeated my gpu.

EDIT: i forgot to mention that when i plug in the DP the monitor does wake up and scan the sources but never gets a signal.

 

SPECS

CPU RYZEN 7 2700X

RAM 8GB 2666 DDR4

GPU RX 470

AORUS B450 ELITE MOBO

Link to post
Share on other sites

Greetings soksncroks,

 

            I don't have personal experience of this, but it appears that your specific graphics card has been reported to have issues waking from sleep. It is reported that disabling Windows "Hybrid Sleep" power feature has resulted in some success resolving the issue. It could be possible that Windows installed an update that affected it, though I don't know your operating system configuration.

 

            As a side note, I see some information regarding cable adapters and the RX 470. It would aid in helping you to know if you are using any adapters, and if so, whether they are active or passive.

 

   

Link to post
Share on other sites
1 minute ago, CharlesM2020 said:

Greetings soksncroks,

 

            I don't have personal experience of this, but it appears that your specific graphics card has been reported to have issues waking from sleep. It is reported that disabling Windows "Hybrid Sleep" power feature has resulted in some success resolving the issue. It could be possible that Windows installed an update that affected it, though I don't know your operating system configuration.

 

            As a side note, I see some information regarding cable adapters and the RX 470. It would aid in helping you to know if you are using any adapters, and if so, whether they are active or passive.

 

   

Not using any adapters, would also like to add that my other 2 monitors (the ones running on hdmi and dvid) get a signal and turn on fine

Link to post
Share on other sites

Not sure if its the same issue, but my 144hz monitor does the same thing and I just needed to disconnect the displayport cable for a few mins

3700x, Asus B450i, 16GB Corsair Vengeance RGB, Gigabyte GTX 970 ITXDan A4-SFX, SX600-G, 120mm AIO.

Link to post
Share on other sites

Greetings soksncroks,

 

           It looks like it's a known issue specifically for DisplayPort, upon further reading. I'm making assumptions here, my assumptions are that the monitor itself works fine as does the cable, however the monitor doesn't display properly when you resume from sleep.

 

           I found some information about a very similar issue (and solution) on Windows 7. I don't know whether you are running Windows 7 or 10, or whether it makes a difference.

 

           Attempt both of the following, reverting back if it does not work.

                     1)  Go to the settings for that monitor and disable "DisplayData Channel Command Interface" (also called " DDC/CI").

                     2)  Ensure that DP Hot Plug Detection is set to Always Active

Link to post
Share on other sites
19 minutes ago, CharlesM2020 said:

Greetings soksncroks,

 

           It looks like it's a known issue specifically for DisplayPort, upon further reading. I'm making assumptions here, my assumptions are that the monitor itself works fine as does the cable, however the monitor doesn't display properly when you resume from sleep.

 

           I found some information about a very similar issue (and solution) on Windows 7. I don't know whether you are running Windows 7 or 10, or whether it makes a difference.

 

           Attempt both of the following, reverting back if it does not work.

                     1)  Go to the settings for that monitor and disable "DisplayData Channel Command Interface" (also called " DDC/CI").

                     2)  Ensure that DP Hot Plug Detection is set to Always Active

i tried both and still no fix.

Link to post
Share on other sites

Greetings soksncroks,

 

                Once you have returned those two settings back to the way they were, try looking into your Power Options for an option "PCI Express - Link State Power Management". Turn it off and attempt putting the monitor to sleep again. As before, revert back if it does not help.

 

                 Please also let us know what version of Windows you are using.

Link to post
Share on other sites
6 minutes ago, CharlesM2020 said:

Greetings soksncroks,

 

                Once you have returned those two settings back to the way they were, try looking into your Power Options for an option "PCI Express - Link State Power Management". Turn it off and attempt putting the monitor to sleep again. As before, revert back if it does not help.

 

                 Please also let us know what version of Windows you are using.

Still nothing, i am running windows 10. also it seems that windows knows a monitor is connected as i can see the other monitors adjust when its plugged in via DP also my mouse will go across (not visibly but i can tell because it doesnt skip the middle monitor and takes a good amount of mouse movement to get it across ) the screen that says no signal.

Link to post
Share on other sites

Greetings soksncroks,

 

           To clarify your original post, the monitor that does not wake from sleep when plugged into DisplayPort is your middle main monitor, and it wakes from sleep properly when plugged into HDMI?

 

             Try looking through the monitor's onscreen display for a "Deep Sleep" option. I don't know your model, so it may not have it. Disable the monitor's built-in deep sleep if you can, and try it again.

Link to post
Share on other sites
Just now, CharlesM2020 said:

Greetings soksncroks,

 

           To clarify your original post, the monitor that does not wake from sleep when plugged into DisplayPort is your middle main monitor, and it wakes from sleep properly when plugged into HDMI?

 

             Try looking through the monitor's onscreen display for a "Deep Sleep" option. I don't know your model, so it may not have it. Disable the monitor's built-in deep sleep if you can, and try it again.

It wakes up when plugged into DP, scans the sources then cant find a signal then turns itself off. but when plugged into HDMI there is no issues

 

Link to post
Share on other sites
6 minutes ago, soksncroks said:

It wakes up when plugged into DP, scans the sources then cant find a signal then turns itself off. but when plugged into HDMI there is no issues

 

When it is not displaying, and you can drag your mouse across it (not visibly, but the appropriate movement is there), go to your display settings. If you are able to see the monitor in your settings, set the refresh rate to 60hz and apply the settings. Set the refresh rate back to what it was and apply again. Let us know if your monitor displays anything during the process.

Link to post
Share on other sites

That worked! thanks so much for your help i really appreciate it! have a great rest of your day!

Link to post
Share on other sites
6 minutes ago, CharlesM2020 said:

When it is not displaying, and you can drag your mouse across it (not visibly, but the appropriate movement is there), go to your display settings. If you are able to see the monitor in your settings, set the refresh rate to 60hz and apply the settings. Set the refresh rate back to what it was and apply again. Let us know if your monitor displays anything during the process.

That worked! thanks so much for your help i really appreciate it! have a great rest of your day!

Link to post
Share on other sites
Just now, soksncroks said:

That worked! thanks so much for your help i really appreciate it! have a great rest of your day!

No worries. Glad to be of assistance. Have a wonderful day yourself. *Smile*

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×