Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Thermaltake's h200 RGB TG Issue

Hello everyone,

 

So I sort of have a non issue on my hands. So I recently just completed my first PC build, and everything seems to be running better than I expected for everything to come out. My issue is that I can get the ring around my power button to light up with RGB, but I can't get the front panel RGB strip to light up. I think I have everything plugged into the motherboard correctly now, as I just rearranged the Power LED cables and that got the Power button RGB issue solved, but that leaves a power LED slot open on my G Connector which I suspect indicates that I need to plug in 2 more wires to get the front panel RGB working.

 

I removed the front panel cover and found a SATA cable that is linked to a 4 pin male connector, so I don't think that can fit in the front panel connectors on my motherboard. That seems to be the only other wire I can find.

 

My question is: should I have a total of 4 Power LED cables (2 Positives, 2 Negatives) to get both the front panel RGB strip and Power buttons to light up? Again, this is such a non issue as everything seems to be running smoothly and I think RGB looks sorta tacky anyways, I'm just really curious to see what it looks like considering I spent $80 on the case. Any advice is much appreciated!

Link to post
Share on other sites

I'm starting to think I have a faulty tower, as I've reached the conclusion that there is no reason for the front panel RGB strip to not light up if the RGB circle around the power button seems to be working fine. Oh well, like I said, I feel like too much RGB and colors looks tacky anyways

 

Link to post
Share on other sites
  • 1 year later...
  • 2 weeks later...
On 1/13/2021 at 10:44 AM, Alan GE said:

Hey man! I appreciate the help. I forgot I posted this thread obviously as this wasposted a year ago when I built my PC. So long story short, I went about 2 months just believing that I had a DoA tower. Then one weekend morning, I mustered up enough energy to open up my tower and take out the power supply (as noted in that first thread you shared, the OPer states that the tower is pretty small making it a pain to get into the power supply unit and dealing with all the cable management stuff, hence why i didnt bother for a few months) I did some investigation and I tried plugging that cable attached to the front panel area to my power supply since I had no other guesses and voila! The front panel LED strip came on. I felt like such a moron, it was literally such an easy fix and there I was thinking I had a faulty tower for the first few months of having my PC 😑.

 

Welp, It's a relief knowing that I wasn't the only one having that issue! Thanks again for bringing this issue up, as I'm sure there are others out there with the same question. I know during the time of me building my PC I looked everywhere and couldn't find the solution myself. I guess I didn't search the forums hard enough! 

 

But indeed, for anyone still struggling with this issue.... make sure the cable that runs along the front panel of your tower is plugged into your PSU.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×