Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Only getting ~100 fps in CSGO, not sure why?

My computer specs are as follows

CPU: I5 9600k @ 3.70

GPU: NVIDIA RTX 2070 Gigabyte

RAM: 16gigs

SSD: 250G

HDD: 2T

Monitor: Acer XFA240 144hz 1080p

 

My temps are always running super low because of my noctua cpu cooler. 

I've just always run this game around that FPS, I have uncapped my fps and I have my launch options set to high and use all my threads.

I have my game settings on high and running at 1080p and i'm not sure why this is happening!

My friend is running a laptop with a 1070 in it at around 300-400fps on high. Any recommendations would be super helpful!

 

 

 

Link to post
Share on other sites

Who knows... CS:GO still runs on Source 1 to this date, it's a bloody mess with the latest hardware.

Personal Desktop":

CPU: Intel Core i7 8700 @4.45ghz |~| Cooling: Cooler Master Hyper 212X |~| MOBO: Gigabyte Z370M D3H mATX|~| RAM: 16gb DDR4 3333mhzCL16 G.Skill Trident Z |~| GPU: nVidia Founders Edition GTX 1080 Ti |~| PSU: Corsair TX650M 80Plus Gold |~| Boot:  SSD WD Green M.2 2280 240GB |~| Storage: 1x3TB HDD 7200rpm Seagate Barracuda + SanDisk Ultra 3D 1TB |~| Case: Fractal Design Meshify C Mini |~| Display: Toshiba UL7A 4K/60hz |~| OS: Windows 10 Pro.

Luna, the temporary Desktop:

CPU: Intel Core i7 10700KF @ 5.0Ghz (5.1Ghz 4-core) |~| Cooling: bq! Dark Rock 4 Pro |~| MOBO: Gigabyte Z490 UD |~| RAM: 32G Kingston HyperX @ 2666Mhz CL13 |~| GPU: ASUS noVideo RTX 2060SUPER Dual OC |~| PSU: Corsair HX1000 80+ Platinum |~| Windows Boot Drive: 2x 512GB (1TB total) Plextor SATA SSD (RAID0 volume) |~| Linux Boot Drive: 500GB Kingston A2000 |~| Storage: 4TB WD Black HDD |~| Case: Cooler Master Silencio S600 |~| Display 1 (leftmost): Eizo (unknown model) 1920x1080 IPS @ 60Hz|~| Display 2 (center): BenQ ZOWIE XL2540 1920x1080 TN @ 240Hz |~| Display 3 (rightmost): Wacom Cintiq Pro 24 3840x2160 IPS @ 60Hz 10-bit |~| OS: Windows 10 Pro (games / art) + Linux (distro: NixOS; programming and daily driver)
Link to post
Share on other sites

Also, due to the fact it's a REALLY old engine, chances are it doesn't have multi-core rendering or any of the new fancy CPU instruction tweaks so it's probably also limited by that.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×