Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

My new WIP Ryzen build:
YsTEVox.jpg
I6HyE5p.jpg
J3CV4dn.jpg
nmBpjQs.jpg
oOhKcNG.jpg
wTjAGR0.jpg

My German Machine: CPU: AMD 5950x cooled by a Custom Watercooling Loop| CASE: Phantek Evolv X | MOBO: X570 Gigabyte Auros Extreme RAM: 128GB DDR4 Patriot 3600mhz ram | GPU: Nvidia Rtx 2080 PSU: Corsair RM1000x SSD's: 1Tb WD SN850 & 2Tb Adata XPG SX8200 Pro | Monitors: 38" Acer X38P Predator| Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset
   

| Pics of my rig |

My Irish Machine: CPU: AMD Threadripper 1950x cooled by a Custom Watercooling Loop| CASE: Little Devil V10 | MOBO: Asus Zenith Extreme RAM: 32GB DDR4 G.Skill 3200mhz ram | GPU: Nvidia Gtx 1080 PSU: Corsair AX1200 with custom white sleeved Cables  SSD's: 500gb Samsung 970 Pro & 960GB Intel SSD | Monitors: Dual 32" 1440p monitors | Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset

 

| Pics of my rig |

 

Link to post
Share on other sites

The watercooling components add up to over 1k alone that I can't add to the link also (Bits power fittings are expensive).

I've edited my Build, this is it before:

This is it now as of the 07/02/2021:

 

My German Machine: CPU: AMD 5950x cooled by a Custom Watercooling Loop| CASE: Phantek Evolv X | MOBO: X570 Gigabyte Auros Extreme RAM: 128GB DDR4 Patriot 3600mhz ram | GPU: Nvidia Rtx 2080 PSU: Corsair RM1000x SSD's: 1Tb WD SN850 & 2Tb Adata XPG SX8200 Pro | Monitors: 38" Acer X38P Predator| Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset
   

| Pics of my rig |

My Irish Machine: CPU: AMD Threadripper 1950x cooled by a Custom Watercooling Loop| CASE: Little Devil V10 | MOBO: Asus Zenith Extreme RAM: 32GB DDR4 G.Skill 3200mhz ram | GPU: Nvidia Gtx 1080 PSU: Corsair AX1200 with custom white sleeved Cables  SSD's: 500gb Samsung 970 Pro & 960GB Intel SSD | Monitors: Dual 32" 1440p monitors | Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset

 

| Pics of my rig |

 

Link to post
Share on other sites
  • 1 year later...

Has anyone had their paint fade like this on a motherboard before? I have had the pc closed since use and only opened it to upgrade to a 5950x then found it like this.

Scan.co.uk are refusing the cover being repaired under warranty saying its wear and tear which I think is insane.

The paint seems to have faded because of the heat from the m.2 and chipset maybe. This is the only X570 without an fan.

Gigabyte are not responding to questions about it either which is a bit annoying.

My 3rd G903 has now failed with the dreaded double click issue and no luck on contacting Logitech in regards to replacement under warranty. If I knew they were going to fix this I'd just buy another in the meantime and send this off but thinking its time to go back to Corsair or the likes with good build quality.

I guess the outcome of this will decide whether I switch back to always using Asus/Logitech.

Motherboard.thumb.jpg.d02a75afd7a3b7fde54602b7018edbcb.jpg

My German Machine: CPU: AMD 5950x cooled by a Custom Watercooling Loop| CASE: Phantek Evolv X | MOBO: X570 Gigabyte Auros Extreme RAM: 128GB DDR4 Patriot 3600mhz ram | GPU: Nvidia Rtx 2080 PSU: Corsair RM1000x SSD's: 1Tb WD SN850 & 2Tb Adata XPG SX8200 Pro | Monitors: 38" Acer X38P Predator| Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset
   

| Pics of my rig |

My Irish Machine: CPU: AMD Threadripper 1950x cooled by a Custom Watercooling Loop| CASE: Little Devil V10 | MOBO: Asus Zenith Extreme RAM: 32GB DDR4 G.Skill 3200mhz ram | GPU: Nvidia Gtx 1080 PSU: Corsair AX1200 with custom white sleeved Cables  SSD's: 500gb Samsung 970 Pro & 960GB Intel SSD | Monitors: Dual 32" 1440p monitors | Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset

 

| Pics of my rig |

 

Link to post
Share on other sites
  • 1 month later...

I ended up smashing my 34" 34GK950F so I replaced it with a 38" Acer X38P.

I've replaced my 3950x with a 5950x and gave my son my 3950x.

I've also replaced my main drive 1TB 8200 pro with a WD SN850 1TB.

I've added a Elgato 4k60 pro mk2.

I'm looking to add 128gb 3600mhz ram in the near future also.

 

My German Machine: CPU: AMD 5950x cooled by a Custom Watercooling Loop| CASE: Phantek Evolv X | MOBO: X570 Gigabyte Auros Extreme RAM: 128GB DDR4 Patriot 3600mhz ram | GPU: Nvidia Rtx 2080 PSU: Corsair RM1000x SSD's: 1Tb WD SN850 & 2Tb Adata XPG SX8200 Pro | Monitors: 38" Acer X38P Predator| Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset
   

| Pics of my rig |

My Irish Machine: CPU: AMD Threadripper 1950x cooled by a Custom Watercooling Loop| CASE: Little Devil V10 | MOBO: Asus Zenith Extreme RAM: 32GB DDR4 G.Skill 3200mhz ram | GPU: Nvidia Gtx 1080 PSU: Corsair AX1200 with custom white sleeved Cables  SSD's: 500gb Samsung 970 Pro & 960GB Intel SSD | Monitors: Dual 32" 1440p monitors | Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset

 

| Pics of my rig |

 

Link to post
Share on other sites
On 12/16/2020 at 2:47 PM, GimmeGaming said:

Has anyone had their paint fade like this on a motherboard before?

Wow what happened there? You sure that hasn't had any chemicals in contact with it?

Intel i9 9900kf - Gigabyte Aorus Z390 Pro - Corsair Vengeance LPX 64GB (4x16 GB) DDR4 3200MHz C16 - Gigabyte Aorus GeForce RTX 2080 ti Xtreme 11G - Corsair 275R Airflow - Samsung 970 EVO Plus 1TB NVMe / Samsung 860 EVO 1TB SATA - Corsair RM750x 80 PLUS Gold 750W - Aorus FI27Q-P - Noctua NH-D15 (CPU) - 4 x NF-S12A PWM (3 intake, 1 exhaust) - Aorus K1 - Aorus M3 - Aorus AMP500 - Aorus H5 - Win 10 Pro

Link to post
Share on other sites
9 hours ago, A1200 said:

Wow what happened there? You sure that hasn't had any chemicals in contact with it?

 

Not from me, you can see finger prints on it from staff at the manufacturing place so its possible some were introduced during manufacturing that affected the quality of the paint but I would have expected they all wore gloves making parts. It could be as it was a one off piece of metal for a motherboard they wouldn't produce many of maybe they outsourced it and the outsourced company had lower manufacturing quality control.

I compared them to mine to make sure it didn't capture mine and it didn't match.

 

I was speaking to others on another forum and they said it usually happens when sunlight hits aluminum too much but mine was under a desk all the time. I didn't get any chemicals on it.

The other forum told me to contact Gigabyte UK instead of gigabyte for Europe and straight away their support is worlds apart. I have the part being posted to the UK this morning, luckily I have a return address they can send it to in the UK. I just hope it gets to them before RMA details expire as it could be delayed with uk customs as its coming from Germany. I paid 30 to send it so I'm hoping it will be quicker.

 

My German Machine: CPU: AMD 5950x cooled by a Custom Watercooling Loop| CASE: Phantek Evolv X | MOBO: X570 Gigabyte Auros Extreme RAM: 128GB DDR4 Patriot 3600mhz ram | GPU: Nvidia Rtx 2080 PSU: Corsair RM1000x SSD's: 1Tb WD SN850 & 2Tb Adata XPG SX8200 Pro | Monitors: 38" Acer X38P Predator| Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset
   

| Pics of my rig |

My Irish Machine: CPU: AMD Threadripper 1950x cooled by a Custom Watercooling Loop| CASE: Little Devil V10 | MOBO: Asus Zenith Extreme RAM: 32GB DDR4 G.Skill 3200mhz ram | GPU: Nvidia Gtx 1080 PSU: Corsair AX1200 with custom white sleeved Cables  SSD's: 500gb Samsung 970 Pro & 960GB Intel SSD | Monitors: Dual 32" 1440p monitors | Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset

 

| Pics of my rig |

 

Link to post
Share on other sites
31 minutes ago, GimmeGaming said:

 

Not from me, you can see finger prints on it from staff at the manufacturing place so its possible some were introduced during manufacturing that affected the quality of the paint but I would have expected they all wore gloves making parts. It could be as it was a one off piece of metal for a motherboard they wouldn't produce many of maybe they outsourced it and the outsourced company had lower manufacturing quality control.

I compared them to mine to make sure it didn't capture mine and it didn't match.

 

I was speaking to others on another forum and they said it usually happens when sunlight hits aluminum too much but mine was under a desk all the time. I didn't get any chemicals on it.

The other forum told me to contact Gigabyte UK instead of gigabyte for Europe and straight away their support is worlds apart. I have the part being posted to the UK this morning, luckily I have a return address they can send it to in the UK. I just hope it gets to them before RMA details expire as it could be delayed with uk customs as its coming from Germany. I paid 30 to send it so I'm hoping it will be quicker.

 

Great - fingers crossed for a good outcome! If you are registered on Aorus, please follow me, I will follow you back:

 

https://member.aorus.com/global/member/dashboard/a120068020 

Intel i9 9900kf - Gigabyte Aorus Z390 Pro - Corsair Vengeance LPX 64GB (4x16 GB) DDR4 3200MHz C16 - Gigabyte Aorus GeForce RTX 2080 ti Xtreme 11G - Corsair 275R Airflow - Samsung 970 EVO Plus 1TB NVMe / Samsung 860 EVO 1TB SATA - Corsair RM750x 80 PLUS Gold 750W - Aorus FI27Q-P - Noctua NH-D15 (CPU) - 4 x NF-S12A PWM (3 intake, 1 exhaust) - Aorus K1 - Aorus M3 - Aorus AMP500 - Aorus H5 - Win 10 Pro

Link to post
Share on other sites
55 minutes ago, A1200 said:

Great - fingers crossed for a good outcome! If you are registered on Aorus, please follow me, I will follow you back:

 

https://member.aorus.com/global/member/dashboard/a120068020 

I just signed up and followed you. I tried register my motherboard but it is looking for a check number as well as a serial number. I have the box off my board in my Ireland home and with Covid I won't be back their for quite some time I'm guessing. I'm in Germany in my German home at the moment. I'm just glad support didn't ask for that as that would be a pain. I've 4 Gigabyte Gpu's I should add on their when I'm back in Dublin.

My German Machine: CPU: AMD 5950x cooled by a Custom Watercooling Loop| CASE: Phantek Evolv X | MOBO: X570 Gigabyte Auros Extreme RAM: 128GB DDR4 Patriot 3600mhz ram | GPU: Nvidia Rtx 2080 PSU: Corsair RM1000x SSD's: 1Tb WD SN850 & 2Tb Adata XPG SX8200 Pro | Monitors: 38" Acer X38P Predator| Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset
   

| Pics of my rig |

My Irish Machine: CPU: AMD Threadripper 1950x cooled by a Custom Watercooling Loop| CASE: Little Devil V10 | MOBO: Asus Zenith Extreme RAM: 32GB DDR4 G.Skill 3200mhz ram | GPU: Nvidia Gtx 1080 PSU: Corsair AX1200 with custom white sleeved Cables  SSD's: 500gb Samsung 970 Pro & 960GB Intel SSD | Monitors: Dual 32" 1440p monitors | Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset

 

| Pics of my rig |

 

Link to post
Share on other sites

My 128gb of ram arrived to populate in this system just now also :).

My German Machine: CPU: AMD 5950x cooled by a Custom Watercooling Loop| CASE: Phantek Evolv X | MOBO: X570 Gigabyte Auros Extreme RAM: 128GB DDR4 Patriot 3600mhz ram | GPU: Nvidia Rtx 2080 PSU: Corsair RM1000x SSD's: 1Tb WD SN850 & 2Tb Adata XPG SX8200 Pro | Monitors: 38" Acer X38P Predator| Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset
   

| Pics of my rig |

My Irish Machine: CPU: AMD Threadripper 1950x cooled by a Custom Watercooling Loop| CASE: Little Devil V10 | MOBO: Asus Zenith Extreme RAM: 32GB DDR4 G.Skill 3200mhz ram | GPU: Nvidia Gtx 1080 PSU: Corsair AX1200 with custom white sleeved Cables  SSD's: 500gb Samsung 970 Pro & 960GB Intel SSD | Monitors: Dual 32" 1440p monitors | Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset

 

| Pics of my rig |

 

Link to post
Share on other sites
5 hours ago, GimmeGaming said:

I just signed up and followed you. I tried register my motherboard but it is looking for a check number as well as a serial number. I have the box off my board in my Ireland home and with Covid I won't be back their for quite some time I'm guessing. I'm in Germany in my German home at the moment. I'm just glad support didn't ask for that as that would be a pain. I've 4 Gigabyte Gpu's I should add on their when I'm back in Dublin.

Cheers bud I couldn't see any follower who I had not already followed (not sure what your profile name is). I didn't have a check number for my Aorus motherboard as I had dumped the box before I realised registering was a thing. I got in touch with customer service with the serial number off the board and a PDF of my proof of purchase and they sent me the check number. Lots of Aorus gear. Link. Would like to do a water cooled one later in the year, probably Aorus themed again.

Intel i9 9900kf - Gigabyte Aorus Z390 Pro - Corsair Vengeance LPX 64GB (4x16 GB) DDR4 3200MHz C16 - Gigabyte Aorus GeForce RTX 2080 ti Xtreme 11G - Corsair 275R Airflow - Samsung 970 EVO Plus 1TB NVMe / Samsung 860 EVO 1TB SATA - Corsair RM750x 80 PLUS Gold 750W - Aorus FI27Q-P - Noctua NH-D15 (CPU) - 4 x NF-S12A PWM (3 intake, 1 exhaust) - Aorus K1 - Aorus M3 - Aorus AMP500 - Aorus H5 - Win 10 Pro

Link to post
Share on other sites

I re-logged into the account and the follow didn't seem to accept. I ensured it did just now.

I'm looking at building a replacement for my Dublin rig but will hold off on deciding which manufacturer to go with before this issue is dealt with. If this doesn't get sorted I will go back to Asus (I've been using mostly Asus for years and bought loads of their stuff without any major issues and when issues came up they were solved asap). I gave Gigabyte a chance motherboard wise as they seemed to have surpassed Asus for once in looks and features.

Based on Germany Gigabyte support I was thinking of avoiding them forever but their UK support are like a different company so I will give them a chance.

 

My German Machine: CPU: AMD 5950x cooled by a Custom Watercooling Loop| CASE: Phantek Evolv X | MOBO: X570 Gigabyte Auros Extreme RAM: 128GB DDR4 Patriot 3600mhz ram | GPU: Nvidia Rtx 2080 PSU: Corsair RM1000x SSD's: 1Tb WD SN850 & 2Tb Adata XPG SX8200 Pro | Monitors: 38" Acer X38P Predator| Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset
   

| Pics of my rig |

My Irish Machine: CPU: AMD Threadripper 1950x cooled by a Custom Watercooling Loop| CASE: Little Devil V10 | MOBO: Asus Zenith Extreme RAM: 32GB DDR4 G.Skill 3200mhz ram | GPU: Nvidia Gtx 1080 PSU: Corsair AX1200 with custom white sleeved Cables  SSD's: 500gb Samsung 970 Pro & 960GB Intel SSD | Monitors: Dual 32" 1440p monitors | Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset

 

| Pics of my rig |

 

Link to post
Share on other sites
On 2/5/2021 at 12:33 AM, GimmeGaming said:

I re-logged into the account and the follow didn't seem to accept. I ensured it did just now.

I'm looking at building a replacement for my Dublin rig but will hold off on deciding which manufacturer to go with before this issue is dealt with. If this doesn't get sorted I will go back to Asus (I've been using mostly Asus for years and bought loads of their stuff without any major issues and when issues came up they were solved asap). I gave Gigabyte a chance motherboard wise as they seemed to have surpassed Asus for once in looks and features.

Based on Germany Gigabyte support I was thinking of avoiding them forever but their UK support are like a different company so I will give them a chance.

 

Followed you mate. Yeah hopefully Gigabyte will sort you out. We all get probs with all brands from time to time, its the support when you need it that counts.

Intel i9 9900kf - Gigabyte Aorus Z390 Pro - Corsair Vengeance LPX 64GB (4x16 GB) DDR4 3200MHz C16 - Gigabyte Aorus GeForce RTX 2080 ti Xtreme 11G - Corsair 275R Airflow - Samsung 970 EVO Plus 1TB NVMe / Samsung 860 EVO 1TB SATA - Corsair RM750x 80 PLUS Gold 750W - Aorus FI27Q-P - Noctua NH-D15 (CPU) - 4 x NF-S12A PWM (3 intake, 1 exhaust) - Aorus K1 - Aorus M3 - Aorus AMP500 - Aorus H5 - Win 10 Pro

Link to post
Share on other sites

5950X added to the system

5a4AzBE.jpg

Some extra fittings to tidy up the loop finally

fAyIvPQ.jpg

128GB 3600Mhz ram I've to remove the heatsinks off before I add them.

idjYzZi.jpg

My new 38" monitor to replace my broke LG 34" monitor

mhGyo6T.jpg

New SSD to replace my main drive

ATMf0aR.jpg

New Capture Card:

5g0AG4y.jpg

I put my old 1tb ssd into this and will fill it up with another 3 and put it in one of my servers.

s2b5qTg.jpg

 

My German Machine: CPU: AMD 5950x cooled by a Custom Watercooling Loop| CASE: Phantek Evolv X | MOBO: X570 Gigabyte Auros Extreme RAM: 128GB DDR4 Patriot 3600mhz ram | GPU: Nvidia Rtx 2080 PSU: Corsair RM1000x SSD's: 1Tb WD SN850 & 2Tb Adata XPG SX8200 Pro | Monitors: 38" Acer X38P Predator| Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset
   

| Pics of my rig |

My Irish Machine: CPU: AMD Threadripper 1950x cooled by a Custom Watercooling Loop| CASE: Little Devil V10 | MOBO: Asus Zenith Extreme RAM: 32GB DDR4 G.Skill 3200mhz ram | GPU: Nvidia Gtx 1080 PSU: Corsair AX1200 with custom white sleeved Cables  SSD's: 500gb Samsung 970 Pro & 960GB Intel SSD | Monitors: Dual 32" 1440p monitors | Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset

 

| Pics of my rig |

 

Link to post
Share on other sites
11 hours ago, A1200 said:

Followed you mate. Yeah hopefully Gigabyte will sort you out. We all get probs with all brands from time to time, its the support when you need it that counts.

Yea fingers crossed as it will be a pain to buy a new motherboard just because of that one piece especially with shitty stock levels at the moment.

My German Machine: CPU: AMD 5950x cooled by a Custom Watercooling Loop| CASE: Phantek Evolv X | MOBO: X570 Gigabyte Auros Extreme RAM: 128GB DDR4 Patriot 3600mhz ram | GPU: Nvidia Rtx 2080 PSU: Corsair RM1000x SSD's: 1Tb WD SN850 & 2Tb Adata XPG SX8200 Pro | Monitors: 38" Acer X38P Predator| Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset
   

| Pics of my rig |

My Irish Machine: CPU: AMD Threadripper 1950x cooled by a Custom Watercooling Loop| CASE: Little Devil V10 | MOBO: Asus Zenith Extreme RAM: 32GB DDR4 G.Skill 3200mhz ram | GPU: Nvidia Gtx 1080 PSU: Corsair AX1200 with custom white sleeved Cables  SSD's: 500gb Samsung 970 Pro & 960GB Intel SSD | Monitors: Dual 32" 1440p monitors | Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset

 

| Pics of my rig |

 

Link to post
Share on other sites
On 2/6/2021 at 12:03 PM, A1200 said:

Followed you mate. Yeah hopefully Gigabyte will sort you out. We all get probs with all brands from time to time, its the support when you need it that counts.

I sent them the part, it arrived with them yesterday in the UK. I got a message today to say the new part is in my UK address and got a pic of a nice shiny new part :). They missed out on my son's new motherboard but because the UK support restored my faith in them I will make sure to pick up the next threadripper board from them when the new cpu's come out. 🙂

 

 

My German Machine: CPU: AMD 5950x cooled by a Custom Watercooling Loop| CASE: Phantek Evolv X | MOBO: X570 Gigabyte Auros Extreme RAM: 128GB DDR4 Patriot 3600mhz ram | GPU: Nvidia Rtx 2080 PSU: Corsair RM1000x SSD's: 1Tb WD SN850 & 2Tb Adata XPG SX8200 Pro | Monitors: 38" Acer X38P Predator| Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset
   

| Pics of my rig |

My Irish Machine: CPU: AMD Threadripper 1950x cooled by a Custom Watercooling Loop| CASE: Little Devil V10 | MOBO: Asus Zenith Extreme RAM: 32GB DDR4 G.Skill 3200mhz ram | GPU: Nvidia Gtx 1080 PSU: Corsair AX1200 with custom white sleeved Cables  SSD's: 500gb Samsung 970 Pro & 960GB Intel SSD | Monitors: Dual 32" 1440p monitors | Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset

 

| Pics of my rig |

 

Link to post
Share on other sites
1 hour ago, GimmeGaming said:

I sent them the part, it arrived with them yesterday in the UK. I got a message today to say the new part is in my UK address and got a pic of a nice shiny new part :). They missed out on my son's new motherboard but because the UK support restored my faith in them I will make sure to pick up the next threadripper board from them when the new cpu's come out. 🙂

 

 

Fantastic! Pleased for you dude. Hardware is so cool!

Intel i9 9900kf - Gigabyte Aorus Z390 Pro - Corsair Vengeance LPX 64GB (4x16 GB) DDR4 3200MHz C16 - Gigabyte Aorus GeForce RTX 2080 ti Xtreme 11G - Corsair 275R Airflow - Samsung 970 EVO Plus 1TB NVMe / Samsung 860 EVO 1TB SATA - Corsair RM750x 80 PLUS Gold 750W - Aorus FI27Q-P - Noctua NH-D15 (CPU) - 4 x NF-S12A PWM (3 intake, 1 exhaust) - Aorus K1 - Aorus M3 - Aorus AMP500 - Aorus H5 - Win 10 Pro

Link to post
Share on other sites

Some more parts ready for when I get the heatsink back, I will do a refresh on the system and add the 128gb ram:

1V2VPX3.jpg

 

MDmcq31.jpg

My German Machine: CPU: AMD 5950x cooled by a Custom Watercooling Loop| CASE: Phantek Evolv X | MOBO: X570 Gigabyte Auros Extreme RAM: 128GB DDR4 Patriot 3600mhz ram | GPU: Nvidia Rtx 2080 PSU: Corsair RM1000x SSD's: 1Tb WD SN850 & 2Tb Adata XPG SX8200 Pro | Monitors: 38" Acer X38P Predator| Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset
   

| Pics of my rig |

My Irish Machine: CPU: AMD Threadripper 1950x cooled by a Custom Watercooling Loop| CASE: Little Devil V10 | MOBO: Asus Zenith Extreme RAM: 32GB DDR4 G.Skill 3200mhz ram | GPU: Nvidia Gtx 1080 PSU: Corsair AX1200 with custom white sleeved Cables  SSD's: 500gb Samsung 970 Pro & 960GB Intel SSD | Monitors: Dual 32" 1440p monitors | Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset

 

| Pics of my rig |

 

Link to post
Share on other sites
My German Machine: CPU: AMD 5950x cooled by a Custom Watercooling Loop| CASE: Phantek Evolv X | MOBO: X570 Gigabyte Auros Extreme RAM: 128GB DDR4 Patriot 3600mhz ram | GPU: Nvidia Rtx 2080 PSU: Corsair RM1000x SSD's: 1Tb WD SN850 & 2Tb Adata XPG SX8200 Pro | Monitors: 38" Acer X38P Predator| Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset
   

| Pics of my rig |

My Irish Machine: CPU: AMD Threadripper 1950x cooled by a Custom Watercooling Loop| CASE: Little Devil V10 | MOBO: Asus Zenith Extreme RAM: 32GB DDR4 G.Skill 3200mhz ram | GPU: Nvidia Gtx 1080 PSU: Corsair AX1200 with custom white sleeved Cables  SSD's: 500gb Samsung 970 Pro & 960GB Intel SSD | Monitors: Dual 32" 1440p monitors | Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset

 

| Pics of my rig |

 

Link to post
Share on other sites

Fitted the new Cpu waterblock, changed the loop order, added the ram but removed 64gb of it trying to get it to run 3600mhz, Gave up when couldn't get it over 3200.

Added the Elgato capture card.

I need to order a few more fittings to get the loop how I want it then finally get custom cables.

I will hopefully have the M.2 heatsink posted to me tomorrow.

yO4TB74.jpg

 

qFrFHZU.jpg

 

My German Machine: CPU: AMD 5950x cooled by a Custom Watercooling Loop| CASE: Phantek Evolv X | MOBO: X570 Gigabyte Auros Extreme RAM: 128GB DDR4 Patriot 3600mhz ram | GPU: Nvidia Rtx 2080 PSU: Corsair RM1000x SSD's: 1Tb WD SN850 & 2Tb Adata XPG SX8200 Pro | Monitors: 38" Acer X38P Predator| Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset
   

| Pics of my rig |

My Irish Machine: CPU: AMD Threadripper 1950x cooled by a Custom Watercooling Loop| CASE: Little Devil V10 | MOBO: Asus Zenith Extreme RAM: 32GB DDR4 G.Skill 3200mhz ram | GPU: Nvidia Gtx 1080 PSU: Corsair AX1200 with custom white sleeved Cables  SSD's: 500gb Samsung 970 Pro & 960GB Intel SSD | Monitors: Dual 32" 1440p monitors | Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset

 

| Pics of my rig |

 

Link to post
Share on other sites

Some more Bitspower fittings arrived today so I will tidy up the loop on the weekend. I think I ordered too many but I should have enough for my next system.

1ovWmQT.jpg

 

wJxgzg7.jpg

My German Machine: CPU: AMD 5950x cooled by a Custom Watercooling Loop| CASE: Phantek Evolv X | MOBO: X570 Gigabyte Auros Extreme RAM: 128GB DDR4 Patriot 3600mhz ram | GPU: Nvidia Rtx 2080 PSU: Corsair RM1000x SSD's: 1Tb WD SN850 & 2Tb Adata XPG SX8200 Pro | Monitors: 38" Acer X38P Predator| Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset
   

| Pics of my rig |

My Irish Machine: CPU: AMD Threadripper 1950x cooled by a Custom Watercooling Loop| CASE: Little Devil V10 | MOBO: Asus Zenith Extreme RAM: 32GB DDR4 G.Skill 3200mhz ram | GPU: Nvidia Gtx 1080 PSU: Corsair AX1200 with custom white sleeved Cables  SSD's: 500gb Samsung 970 Pro & 960GB Intel SSD | Monitors: Dual 32" 1440p monitors | Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset

 

| Pics of my rig |

 

Link to post
Share on other sites

Added only a few of the new fittings but I wanted to tidy it as much as I could.

As you can see from the fittings I'm still waiting on the heatsink to arrive from my UK place.

BBvucP3.jpg

 

AuL7qDB.jpg

 

WXxcgoL.jpg

 

XRnLZCK.jpg

My German Machine: CPU: AMD 5950x cooled by a Custom Watercooling Loop| CASE: Phantek Evolv X | MOBO: X570 Gigabyte Auros Extreme RAM: 128GB DDR4 Patriot 3600mhz ram | GPU: Nvidia Rtx 2080 PSU: Corsair RM1000x SSD's: 1Tb WD SN850 & 2Tb Adata XPG SX8200 Pro | Monitors: 38" Acer X38P Predator| Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset
   

| Pics of my rig |

My Irish Machine: CPU: AMD Threadripper 1950x cooled by a Custom Watercooling Loop| CASE: Little Devil V10 | MOBO: Asus Zenith Extreme RAM: 32GB DDR4 G.Skill 3200mhz ram | GPU: Nvidia Gtx 1080 PSU: Corsair AX1200 with custom white sleeved Cables  SSD's: 500gb Samsung 970 Pro & 960GB Intel SSD | Monitors: Dual 32" 1440p monitors | Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset

 

| Pics of my rig |

 

Link to post
Share on other sites

Part arrived to finish the motherboard again:

6vCcRDx.jpg

QKcVcOq.jpg

 

 

My German Machine: CPU: AMD 5950x cooled by a Custom Watercooling Loop| CASE: Phantek Evolv X | MOBO: X570 Gigabyte Auros Extreme RAM: 128GB DDR4 Patriot 3600mhz ram | GPU: Nvidia Rtx 2080 PSU: Corsair RM1000x SSD's: 1Tb WD SN850 & 2Tb Adata XPG SX8200 Pro | Monitors: 38" Acer X38P Predator| Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset
   

| Pics of my rig |

My Irish Machine: CPU: AMD Threadripper 1950x cooled by a Custom Watercooling Loop| CASE: Little Devil V10 | MOBO: Asus Zenith Extreme RAM: 32GB DDR4 G.Skill 3200mhz ram | GPU: Nvidia Gtx 1080 PSU: Corsair AX1200 with custom white sleeved Cables  SSD's: 500gb Samsung 970 Pro & 960GB Intel SSD | Monitors: Dual 32" 1440p monitors | Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset

 

| Pics of my rig |

 

Link to post
Share on other sites

I will fit these this weekend to remove the awful GPU cables.

lHggFIg.jpg

 

My German Machine: CPU: AMD 5950x cooled by a Custom Watercooling Loop| CASE: Phantek Evolv X | MOBO: X570 Gigabyte Auros Extreme RAM: 128GB DDR4 Patriot 3600mhz ram | GPU: Nvidia Rtx 2080 PSU: Corsair RM1000x SSD's: 1Tb WD SN850 & 2Tb Adata XPG SX8200 Pro | Monitors: 38" Acer X38P Predator| Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset
   

| Pics of my rig |

My Irish Machine: CPU: AMD Threadripper 1950x cooled by a Custom Watercooling Loop| CASE: Little Devil V10 | MOBO: Asus Zenith Extreme RAM: 32GB DDR4 G.Skill 3200mhz ram | GPU: Nvidia Gtx 1080 PSU: Corsair AX1200 with custom white sleeved Cables  SSD's: 500gb Samsung 970 Pro & 960GB Intel SSD | Monitors: Dual 32" 1440p monitors | Mouse: Logitech G903 and Powerplay matt | KEYBOARD: Logitech G610 | HEADSET: Logitech G935 Wireless Headset

 

| Pics of my rig |

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Newegg

×