Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Logitech G-hub is trash

Been using Logitech mice for 15 years or so. Always liked the hardware, its been sturdy, motion smooth for my gaming style, the g600 has more buttons than i know what to do with. But G-hub software absolute crap, for no reason at all it decides it doesn't need to detect the presence of the mouse even though the OS sees it just fine, that happens way to often. Up dates generally brake any custom profiles you have might have created, and now the Installer doesn't even work which is problematic when you have to completely reinstall the software to fix the problem with soft detect. And mice aren't the only G-hub issue, apparently every piece of hardware that relies on g-hub to function has issues. I have always felt Logitech had their shit together as far hardware goes but G-hub is ruining what in my opinion an excellent gaming controller.

Link to post
Share on other sites

Ive never had an issue with it mytself.

MAIN PC (Beast) - Asus ROG Crosshair Hero VII WIFI , AMD Ryzen 7 2700x + Corsair H115i Pro RGB Cooling, 32GB G.Skill 3200Mhz 16,18,18,38 1.35v DDR4, Inno3d HerculeZ Design Nvidia GTX 1080 X2 8GB GDDR5,  2 x Samsung U28E590D 3840 x 2160 4K, 1 x Samsung Evo 970 Evo Plus NVME PCI-E 1TB, 1 x Samsung Evo 850 250GB, 1 X Sandisk Ultra II SSD 240GB + 2 X 3TB Seagate Baracuda SATA III, 1 x LG BH16NS40 16x BR\DVDRW, ICYBOX IB3740-C31 & ICYBOX IB3640-03, Corsair Obsidian 750D Windforce Edition Case + 5 Corsair ML140 140mm Case Fans, EVGA 750 g3 750w Gold 80+ PSU, Logitech MX Vertical Mouse, Corsair K55 RGB Gaming Keyboard, Windows 10 Pro x64 Retail, Synology ds215j NAS + 2x3TB WD Reds connected to a 6TB Seagate USB 3.0 Backup Plus Hub, Blue Yeti Microphone, Logitech C922 Pro HD,  Logitech C920 Pro HD, Kaspersky Internet Security 2020.

 

Second PC (Cyclops) - MSI 990FXA Gaming, AMD FX 8370 4Ghz, Corsair 16GB Venegence Red 9-9-9-24 1600Mhz, Arctic Cooling Freezer 13, Asus Strix 1050TI 4GB, 1 X Acer 27" Full HD Monitor, 1 X Sandisk Ultra II SSD 240GB, 1 x Samsung Evo 850 250GB, 2 X Seagate Baracuda 2TB, 1 X WD Black 2TB, 1 x ASUS 16x DVDRW, X-Case Eagle III Case, 3 X Corsair AF 120 Case Fans, EVGA 850 G2 80+ Gold + PSU, Logitech MX Master Mouse, Corsair K30 Keyboard, Logitech C920 Webcam, R0DE NT1-A Microphone, Scarlet 212 Audio Interface (Revision 2), Windows 10 Pro X64 Retail, Kaspersky Internet Security 2020, 2TB Seagate Expansion USB Hard Drive.

 

Third PC (Old Trustie) - Acer Aspire M3400, OEM Mainboard, AMD FX Athlon II X3 425 2.7Ghz, 16GB Corsair Value 1600Mhz Ram, OEM CPU Cooler, AMD R7 260 2GB GPU, 1 X Acer 27" Full HD Monitor, 1 X Sandisk Ultra II SSD 240GB, 2TB Samsung SATA III, 1 X OEM 16X DVDRW, 1 X Acer OEM Case, 1 X Corsair AF120 Case Can, Corsair CX500 Bronze+ CPU, Logitech MX Master Mouse, Corsair K30 Keyboard, Windows 10 Home X64 OEM, Logitech C920 Webcam, Kaspersky Internet Security 2020.

 

Icybox 3640SU3

Icybox 3740-C31

Printers Include - Canon MG5750, Canon, IP8750, 2 X Samsung C410W.

 

Netgear Nighthawk R6 R8000 Cable Router with DD-WRT Using a Virgin Media Hub 3.0.

 

Samsung Galaxy S10 Mobile Phone.

 

Internet Speed.....

https://www.speedtest.net/result/9935039193

Link to post
Share on other sites
48 minutes ago, Sleeper0013 said:

Been using Logitech mice for 15 years or so. Always liked the hardware, its been sturdy, motion smooth for my gaming style, the g600 has more buttons than i know what to do with. But G-hub software absolute crap, for no reason at all it decides it doesn't need to detect the presence of the mouse even though the OS sees it just fine, that happens way to often. Up dates generally brake any custom profiles you have might have created, and now the Installer doesn't even work which is problematic when you have to completely reinstall the software to fix the problem with soft detect. And mice aren't the only G-hub issue, apparently every piece of hardware that relies on g-hub to function has issues. I have always felt Logitech had their shit together as far hardware goes but G-hub is ruining what in my opinion an excellent gaming controller.

If it is not being detected then it doesn't have support for it  You need to use LGS.

Asus Sabertooth x79 / 4930k @ 4500 @ 1.408v / Gigabyte WF 2080 RTX / Corsair VG 64GB @ 1866 & AX1600i & H115i Pro @ 2x Noctua NF-A14 / Carbide 330r Blackout

Scarlett 2i2 Audio Interface / KRK Rokits 10" / Sennheiser HD 650 / Logitech G Pro Wireless Mouse & G915 Linear & G935 & C920 / SL 88 Grand / Cakewalk / NF-A14 Int P12 Ex
AOC 40" 4k Curved / LG 55" OLED C9 120hz / LaCie Porsche Design 2TB & 500GB / Samsung 950 Pro 500GB / 850 Pro 500GB / Crucial m4 500GB / Asus M.2 Card

Link to post
Share on other sites

I recently got a MX518. When G-hub is installed it creates a virtual mouse in device manager that enhances input lag and give slight acceleration (haven't tested if this is true, but surely feels like it) - when uninstalled, everything works perfect!

CPU: i7 9700K@5.3, 5.3, 5.2, 5.2, 5.1, 5.1, 5.1, 5.1

cache x47, AVX offset 0

Motherboard: Asus Maximus XI Hero

RAM: Patriot Viper Steel 2x8gb@4000, Default CL17, testing new timings

PSU: EVGA SuperNova 750 G3

Mon: Samsung C27HG70 27" 144Hz Freesync

GPU: EVGA 1080ti SC Black Edition w/ G12 bracket

Sound: Odac + Fiio E09K

Case: Fractal Design R6 TG Blackout

Storage: MP510 960gb and 860 Evo 500gb

Cooling: CPU: Kraken X62 - GPU: Kraken X42 - both with Noctua NF-A14's

BIOS SETTINGS: https://www.overclock.net/threads/xtu-oc-help-on-i7-9700k.1773955/post-28649779

Link to post
Share on other sites

my mouse (g703) doesn't show up in lgs but only in g-hub + I can't store my dpi on the mouse itself; wtf

Link to post
Share on other sites
  • 2 months later...

Created an account to just chime it.. Logitech G Hub is a piece of shit software. I can confirm that it sometimes does not detect the mouse.. crashes for no reason, and the profiles are just a mess. I can set it to have no LED on the profile that is either default, or used in an particular game.. and when in the game, it will have the LED on..and the wrong mouse-sensitivity..

Link to post
Share on other sites

G Hub is garbage, LGS is still garbage but not nearly as bad as G Hub is.

Specs

OS: Arch Linux

CPU: Ryzen 5 3600x

MOBO: Asus ROG STRIX B450-F

RAM: G.SKILL TridentZ RGB 16GB DDR4 3200

STORAGE: Samsung 860 EVO 500GB SSD - WD Blue 1TB 7200RPM - Seagate Barracuda 1TB 7200RPM

GPU: EVGA RTX 2070 Super XC

PSU: Corsair TXM Gold 550W 80+

 

Audio

Headphones: Sennheiser HD6XX

Amp: Schiit Magni 3

DAC: Schiit Modi 3
Microphone: AT 2035

Mixer: Focusrite Scarlett Solo

 

Peripherals

Mouse: Logitech G Pro Wireless

Keyboard: Ducky One Two Mini Pure White w/ Kailh Box White Switches

VR Headset: Valve Index

 

 

 

i use arch btw

Link to post
Share on other sites

I used it for 2 seconds to setup a profile on my mouse, as I had to install it on my moms computer. My machine runs Linux. I got what I needed set, set and thats about my expirence on using it. I know it was not easy to navigate, took me a while to figure out how to get the mouses memory enabled. 

Was there dairy in that? ***30 min later**** Yep..... You might want to let it air out for a bit.....😂😂😂😂😂😂

Link to post
Share on other sites
  • 6 months later...

made an account to talk about this also. Software shit what can i say ? i start my pc and launch shit-hub it forces default settings because it isn't seeing the mouse. G502 btwlol restart the app and it loads forever restart it 4-5 more times and never detects my mouse i just have to keep closing the app until it picks it up.

Sometimes i do get lucky and it works first try but that shit is rare.

hardware good. software shit. 💩

Link to post
Share on other sites

G HUB is garbage. The only reason I use it is for the music RGB visualizer.

The Workhorse

R7 3700X | RTX 2070 Super | 32GB DDR4-3200 | 512GB SX8200P + 2TB 7200RPM Barracuda Compute | Windows 10 Pro

 

The Portable Station

Core i7 7700H | GTX 1060 | 8GB DDR4-2400 | 128GB SSD + 1TB HGST | Windows 10

 

Samsung Galaxy Note8 SM-N950F

Exynos 8895 ARM Mali G71 MP20 | 6GB LPDDR4 | 64GB internal + 128GB microSD | 6.3" 1440p "Infinity Display" AMOLED | Android Pie 9.0 w/ OneUI

Link to post
Share on other sites

I have a logitech mouse (g300s) and g29 wheel, neither show up in G-hub. The only logitech software they work in is the logicool software which is in Japanese (I think), kind of annoying but whatever. 

Current:
Eluktronics THICC-17 (Clevo X170SM-G):
CPU: i9-10900k @ 5.0GHz/(~4.7GHz) all cores 
GPU: RTX 2080 Super (Max P 200W) @ 1995MHz/(~1900MHz)
RAM: 16GB (2x8GB) @ 3200Mhz

Storage: 512GB PRO-X-G2R NVMe SSD, 4TB WD Passport USB-C
Displays: IPS 1080p@240Hz (G-Sync), Asus VG248QE 1080p @144hz, 2x Dell SE2417HGR 1080p @60Hz

Dell Poweredge R720 (Server):
CPUs: 2x Xeon E5-2667v2 @ 3.6Ghz all cores
RAM: 64GB (8x8GB) @ 1333Mhz

Storage: 1x Intel 160GB SATA III SSD, 15x Seagate SAS Enterprise 1TB HDD in RAID 6

 

Old:

Eluktronics Mech-17 G1Rx:
CPU: i7-9750h @ 4.0GHz all cores
GPU: RTX 2070 @ 2004Mhz/(~1650Mhz)
RAM: 16GB (2x8GB) @ 2666Mhz
Storage: 512GB HP SX920, 4TB WD Passport USB-C
Displays: BOE NV173FHM-N44 1080p@144Hz, Asus VG248QE 1080p @144hz, 2x Dell SE2417HGR 1080p @60Hz
Custom SFF AMD Sleeper (Parted out and sold/sent to friends)
Dell Precision M6700 (both GPUs died, among other issues, officially shelved for now...)

Link to post
Share on other sites
  • 3 months later...

As others, I created an account just to comment on how bad G-Hub is.  I am used to Logitech Gaming Software for setting up my G903 mouse.  When I launched the Gaming Software, it forced me to the G-Hub where I promptly accidently defaulted my mouse setup.  I could not get it back and trying to program it was a nightmare.  You program it in Software mode so you can used it in on-board mode (What!?!).  I then uninstalled the G-Hub and tried my Gaming Software again.  This time it did not force me into G-Hub.  Never will install G-Hub.  Try again Logitech....

Link to post
Share on other sites

I like how this thread turned to support group for people who had to use G-hub, lmao.

Main Rig :

Ryzen 7 2700X | Powercolor Red Devil RX 580 8 GB | Gigabyte AB350M Gaming 3 | 16 GB TeamGroup Elite 2400MHz | Samsung 750 EVO 240 GB | HGST 7200 RPM 1 TB | Seasonic M12II EVO | CoolerMaster Q300L | Dell U2518D | Dell P2217H | 

 

Laptop :

Thinkpad X230 | i5 3320M | 8 GB DDR3 | V-Gen 128 GB SSD |

Link to post
Share on other sites
  • 1 month later...

I had 3 previous Logitech Wireless mice, 2 of which ran on the LGS software, which was simple, intuitive, and even old farts like me could operate it easily. So my G602 was nearly dead, 3 of its 12 prog' buttons had failed, so I thought "I'll get another Logitech, I like them", and so I bought a G604, which runs on Ghub.

  The $135.00 mouse I purchased 2 days ago, now resides on the road at the end of my driveway, in 30+ pieces. The RMB and LMB buttons stopped working in any application, and I could not ressurect them, no mater what i did. Ghub would have been bad in 2005. I Ordered a new mouse. Fuck Ghub, For as long as that trainwreck governs any Logi products, I'm buying other brands. Congrats Logitech, on pissing off what was a loyal customer.

 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×