Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

LG G3 LineageOS Tutorial

Assuming your LG G3 is on the latest version of Android available for the device, there likely isn’t a root that is compatible with it. So, to achieve the root, and then custom ROM, we’ll need to downgrade the device (back to Kitkat in this case) first.


Before you start that however, you’ll want to ensure there is an active LineageOS build for your specific LG G3 version, as not all devices might be supported. https://wiki.lineageos.org/devices/


1 - Downgrade:

  1. Download and Install the LG Mobile Drivers. Click “Software & Firmware” on the following page

    1. https://www.lg.com/ca_en/support/support-mobile/lg-LGD852

  2. Download and Extract the LG Up Files

    1. https://oceanhost.eu/545euinlq0hw/LGUP_LG_G3.zip.htm

  3. Install “LGUP_8974_DLL_Ver_0_5_CODEFIRE.MSI” followed by “LGUP_Install_Ver_1_14_3.msi

  4. Download and extract the respective KitKat file for your device. Our phone is a D852, and we will be using the Bell version specifically. Ensure you select the appropriate ROM for your device.

    1. https://storagecow.eu/index.php?dir=Xda%2FLG+G3%2FStock%2F

    2. Canada D852 > BELL D852AT-01-V10b-302-610.zip

  5. On the device, go into Settings > General > About phone – and tap “Build Number” until it says “You are now a developer”

  6. Go back, then into Developer Options, and Enable USB Debugging

    1. Note: USB Debugging will be greyed out if the device is plugged in, so make sure it’s not.

  7. Plug the phone into a USB 2.0 port, then swipe down to open the notification tray and change your USB mode to MTP Mode.

  8. On the PC, open LGUP as Administrator, select the .tot file, Refurbish mode and then hit start.

    1. If it doesn’t detect your device on open, try a different USB port, or a different PC.

  9. Congrats, you should now be back on KitKat.


2 - Rooting / Flashing LineageOS:

  1. If you’ve just downgraded, quickly setup the phone, and reenable USB Debugging. (Repeat Steps 5 to 7 in part one)

  2. Download the PurpleDrake root

    1. https://forum.xda-developers.com/lg-g3/development/root-root-lg-g3-easily-purpledrake-lite-t2821000

    2. Check the following compatibility chart to see if you’re support, and to see what other root you might use if you’re not.

      1. https://docs.google.com/spreadsheets/d/1hs0qlcGP80gl9wC0r9bs0AWMD-1D9iGgC9ulCG9roMs/edit#gid=0

  3. Plug in the phone, if it’s not already, and run PurpleDrake as admin.

    1. You might have to re-plug the phone, or restart the root program if it doesn’t detect the device.

    2. Select Yes to allow USB debugging with this Computer when prompted on the device

    3. Select Yes to permanently rooting with PurpleDrake.

  4. Download the new version of TWRP and copy it over to your device

    1. https://forum.xda-developers.com/lg-g3/development/recovery-teamwin-recovery-project-lg-g3-t3813552

  5. Download the TWRP App onto the device from the Play Store and open it.

  6. Backup your recovery if you wish via the TWRP app, and then copy it over to your PC

  7. Select the TWRP file we copied over earlier in the app, flash it to recovery, and then reboot to recovery

  8. Once in the TWRP recovery, select Backup, and swipe to backup your install of KitKat with TWRP incase anything goes wrong later in the process. Copy that over to your PC from the TWRP folder.

  9. Back in the main TWRP menu, select Wipe>Advanced Wipe, and select Dalvik / ART Cache, Cache, Data, Internal Storage, and System – then swipe to wipe.

  10. Download the latest build of LineageOS, selecting the correct version for your device. Copy it to your device.

    1. https://wiki.lineageos.org/devices/#lg

  11. Download the latest Open Google Apps – ARM, Android 8.1, and Nano. Copy it to your device.

    1. https://opengapps.org/

  12. Back on the device, select Install in TWRP, select the LineageOS zip and swipe to Install. Then select the OpenGoogleApps zip, and swipe to Install that.

  13. After 5-10 minute it will complete and reboot the phone into LineageOS. Hurrah!

    1. Setup the phone and install any missing Google Apps as necessary from the Play Store.

    2. *Optional* Download the install the Magisk root in TWRP


Helpful Side Notes:


How to Flash an LG G3 Back to Stock (2015 method from this post: https://forum.xda-developers.com/showthread.php?t=2785089?

  • There are a couple different methods, but I found the most consistent was to use LG FlashTool V1.8.1

  1. Download and extract the KitKat .tot file, and the DLL file, for your respective device (assuming you don’t already have it)

    1. https://storagecow.eu/index.php?dir=Xda%2FLG+G3%2FStock%2F

  2. Download and install LG FlashTool V1.8.1 (don’t run it yet)

    1. https://oceanhost.eu/nskpvk76ezvp/Setup_LGFlashTool_1.8.1.1023.exe.htm

  3. Download the Megalock DLL file, and copy it to C:\LG\LGFlashtool, replacing the existing Megalock file (this might be a hidden folder, so enable viewing of those)

    1. http://oceanhost.eu/o9n2mef5f2no/MegaLock.dll.htm

  4. Power off the phone

  5. Press and hold the Volume Up key and then plug the phone in, it should now be in “Download mode”

  6. Open up Device Manager on your PC, navigate to “Ports (COM & LPT), select the one related to LG or “LGEModem”, navigate to the Port Settings tab, click Advanced, and change the COM port to COM41, and then click “Okay”.

  7. Run LG FlashTool as Admin, click “Select Manual Mode”, select the DLL file for the DLL slot, select the .tot file for the “S/W” slot, and click “OK”.

  8. Select the big yellow right arrow in the top left. The COM41 box should change to say “READY!!”. It should say something along the lines of “Waiting for connection” below that. If it doesn’t, try replugging the device.

  9. Once it’s done (it might show as failed in the software), you should be presented with a screen on the phone saying “LG Factory Reset Status” with a big number 3. Pull the battery and the phone should restart as normal.

  10. Now you can update the device back up to Marshmallow with OTA updates, or with the LG Mobile Support Tool.


Gaming Rig3900X, 32GB 3600MHz TridentZ, ROG 2080 Ti, 2*4TB Black, 1TB MP600

NAS: E5-2670v3, 48GB ECC, 76TB of HDD's: 3*4TB + 2*8TB + 4*12TB, 500GB 850 Evo Cache


Link to post
Share on other sites

Cool stuff, I'm programming those Custom OS since 2013. I even still maintain my beloved S3Neo from 2013. The topic really needs to get more coverage i think, to let customers know they don't need to buy a new phone every two years (even though manufacturers want them). But there are some things I've to complain about.

In Android the process of how a image is being Processed (be it post processing or ore processing) is not done in the App that takes the picture. The app really just takes the photo with sometimes some settings like raw pictures or manual exposure, denoise, zsl u name it being enabled when the app switches to manual mode. But all the processing is being done in the Camera HAL or hardware abstraction layer. That one does (actually it doesnt but to simplify assume it does) post processing and image corrections. It also converts it to jpeg which is a edited type as the camera normally outputs in YUV in Android. That's why there are camera mods which replace those camera HALs. Check the Oneplus 3 which has one such replacement. It works pretty well and those guys even had 4k video enabled on a non 4k supported phone.

The other thing is the developer who maintains the device. That's one of the issues like the screen. As a developer one has the option to simply change the individual color strength or turn the brightness up more than on stock. But there are some features enabled by default like anti display degradation routines that lower the brightness. But its good that phones in general are being supported by lineageos (even though the lead devs there are total garbage and toxic). If any Lineage Dev reads this then finally read my ticket (Mi Pad 4 Clover device bringup) and answer :)

Link to post
Share on other sites

well i messed something up because my phone's hard bricked now




update - yep, totally gone. guess I'll go 5 days without a phone while i wait for a new one


edit 2 - I'm an idiot and my phone was connected to the ac adapter and not my pc when i was trying to recover. trying to fix it now.

Specs: CPU: AMD Ryzen R7 3700X @4.4Ghz, GPU: Gigabyte RX 5700 XT, RAM: 32 GB (2x 8GB Trident Z Royal + 2x 8GB TForce Vulkan Z) @3000Mhz, Motherboard: ASRock B550m Steel Legend, Storage: 1x WD Black 1Tb NVMe (boot) + 1x Samsung 860 QVO 1Tb SSD (storage), Case: Thermaltake Core V21, Cooler: Noctua NH-D15

Link to post
Share on other sites

If u need any help ask me I can probably help you. But be aware that LG phones are pretty easy to brick. It often involves flashing a different bootloader which if u choose the wrong one hard bricks everything.

Link to post
Share on other sites

i have a lg g3 cat6 (f460s) it s really similar to the lg g3. will it work if i just use the f400-A/B's ?


Link to post
Share on other sites

Hahahaha, I got LGUP to flash the device, but it just sits there on the flashing screen forever. At this point, I can't get anything to re-flash it. I've tried LGUP and LGFlashTool.

Link to post
Share on other sites
  • 2 weeks later...

I got all the way to the part where you install Lineage OS. But TWRP gives me an error 7. Which according to TWRP, it says this version of Lineage OS is for D582, this phone is ,



Link to post
Share on other sites
12 minutes ago, Assassin423 said:

I got all the way to the part where you install Lineage OS. But TWRP gives me an error 7. Which according to TWRP, it says this version of Lineage OS is for D582, this phone is ,




Link to post
Share on other sites

it sort of worked on mine but some of the steps were wrong @jakkuh_t. i didn't have a .tot file anywhere so i had to click the middle option in LGUP according to a google search and that did work. 


i have a d855 by the way. 

Phone: iPhone SE 2020 | 64GB iOS
Main Laptop: MacBook Pro 15" Late 2011 | Core i7 2675QM | 16GB RAM | 250GB SSD | Ubuntu

PC: Supermicro X8DT3 | 2x Xeon X5650 | R9 290X | 32GB RAM500GB SSD | Bitfenix Whisper 850W | Ubuntu/Windows

Link to post
Share on other sites
  • 2 weeks later...

Hey guys, got a question on this. 
I've got the D855K version (Australia), there doesn't seem to be a KitKat version for that specific model in the StorageCow directory, though plenty of other D855 versions. Would any of those work instead, or am I out of luck? 



Link to post
Share on other sites
  • 3 months later...
On 5/8/2019 at 6:32 AM, Twilight said:

it sort of worked on mine but some of the steps were wrong @jakkuh_t. i didn't have a .tot file anywhere so i had to click the middle option in LGUP according to a google search and that did work. 


i have a d855 by the way. 

You used the .kdz file right? I've used the .kdz but it is not supported by the rooting tools (its says the version is patched if you try) so I was stuck after this method.

After that I've found out that .tot files for D855 are located in this folder:



I do not require glory, only results.

Link to post
Share on other sites
  • 1 month later...

So first of, love this guide. I've successfully turned a D852 into a Lineage OS 16 Phone, and its the best experience I've ever had with a phone, thanks so much.

I've not been able to get it working with a D850 (that is using a global rom apparently) its an AT&T variant from "China", and it kinda sucks but it still works for my partner. I'm the only one that needed all the newer apps.

But I've been having an issue I cant seem to fix with the D852. How do you install the custom recovery after installing the OS? because its needed even for small updates,and I'd have to revert the phone back everytime. other than that the phone works perfectly. Sorry if Its a simple answer, but I've been using this guide to get into the Android environment.

Assuming that a Root relates more to the hardware and not the software there would be no way to install Lineage OS with root, but If I'm mistaken I'd love to know how to do that on the LG G3 for the updated versions of Lieage OS. I've not found a clear answer or well described method.

Edit: I didn't check the dev settings, Advanced reeboot solved my issue, so I could throw it into Recovery. Now I'm able to continue the updates without having to worry about the phone bricking because there is no recovery installed. (Was trying to use the Vol Dwn + Power to get to recovery but it doesnt work anymore.) We also replaced the D850 with another D852, and our issues are solved, and we have reserve parts to fix the phones.

Thank you so much for bringing attention to this method for me, It has made our life so much easier and convenient, pursuit of knowledge simpler and constant, Merci and keep up the amazing work!

We both Upgraded the Phones with Cases to protect them in the future from clumsy drops and such. as well as 64GB SDXC cards, YEEET!
Big upgrades from Iphone4s's (Left most right most)


Edited by ElenaLeffelZXC4

Processor: Intel Core i7-5700HQ (Quad Core - Octo Thread) {2.70GHz - 3.40GHz}

Graphics: Nvidia GTX 970m 3GB GDDR5 (MXM Series) + Intel Integrated (Off)

Ram: 2x 1366Mhz 8GB + 2 1366Mhz 4GB

Steam https://steamcommunity.com/id/ElenaLeffelZXC4/

Link to post
Share on other sites
  • 2 months later...

If you have a different G3 model, link here for other KitKat versions


Engineering Student, electronics enthusiast, maker.

My tech:


Desktop (Main Gaming/Workstation): (Custom) i7-7700k/GTX1060 6GB Strix/32" Curved QLED monitor/3M MicroTouch Display

Laptop: (HP) Ryzen 7-2700U/Vega Mobile GFX (Integrated)/15.6" 1080p Pen+Touch Display

Phone (EDC, Casual Photography): (Samsung) Galaxy S10

Sound: (Sony) WH-1000XM4/(Blue) Yeti

Desktop 2 (Couch Gaming): (Custom) Ryzen 3-3200G/RX 580 Red Devil/1080p TV

Phone 2 (Emulation/Mobile Gaming/Other): (Lenovo) Moto Z3 w/ gamepad/projector/qi wireless charging battery/360 camera mods

Camera (Main Photography): (Sony) a6300 w/ 18-135mm kit lens

Dev Boards: Arduino Uno/Raspberry Pi 4/esp32


Link to post
Share on other sites
  • 3 months later...

Hi, I was on lollipop.
I initially downgraded to kitkat (V10e) using LG UP and then rooted with purple drake.

In the following reboots, "kernel error" has occurred.
So I tried to reflash the kitkat stock version again but without success.
I'm stuck in download mode and tried to flash both the kitkat version, the lollipop and the marshmallow, through .tot and .kdz, I tried both with LG UP, LG Flash tools v 1.8 and with LG flash Tools 2014 but in all cases unsuccessful because the phone reboots before it ends.
Now I don't know what to try anymore. Do you have any solution please?

Thanks in advance.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now