Jump to content

Sades A60 microphone not working

ShazzoBazzo

I've just got my new USB Sades A60 headset today, been liking it so far but I've been trying to fix this one major bug for hours. The microphone just doesn't work at all.

 

Everything else works perfectly but no matter what port I plug the USB into, the microphone doesn't pick up my voice. I've tried all the ports on the back panel of my pc case, the front panel, and even the one on my Razer keyboard. Restarting my pc, looking through all the sound properties to see any errors, and downloading the drivers (couldn't even install it because it said that it didn't detect the headset even though it was plugged in) hasn't worked for me either. I know that the mic works because I've plugged it into different computers and it started to pick up my voice and work nicely. It just doesn't work on my main pc for some reason.

 

A difference that I noticed between my pc and the ones that the headset worked on is that those computers had USB ports on their monitor while my GN246HL monitor does not. The ports on the monitor made the microphone work.

 

Any help would be appreciated.

 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×