Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Volta Charger Cables - Slowly Charging Troubles

gtgreen
 Share

Hi all.  I bought several original Volta Charger cables, but I've had some trouble.  I've been emailing with a nice Volta representative, but I wanted to make sure of a couple of things before following up further.

 

Many times the cables work well - the phones report "rapidly charging" and I can tell the phones charge at the expected rates.  If I double check with the app Ampere, it also confirms the faster rates.  However there are a noticeable number of times that the phones will charge very slowly.  When I check in those instances, the phones will display "slowly charging," and when I check Ampere, it shows slow charging stats.  If I disconnect and reconnect the cables , sometimes that's enough to correct the problem.

 

Here are my questions:

1) My understanding is that the Original cables (not the XL) can charge at rates up to 2.4 amps - is that correct?

2) Even If the phone supports faster charging rates, is it true that the original cables should still be able to charge up to 2.4 amps without trouble?

3) If the above are both true, but I'm still encountering the issues described, would it be likely the cables are not working correctly? 

 

Thanks in advance.

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

47 minutes ago, gtgreen said:

Hi all.  I bought several original Volta Charger cables, but I've had some trouble.  I've been emailing with a nice Volta representative, but I wanted to make sure of a couple of things before following up further.

 

Many times the cables work well - the phones report "rapidly charging" and I can tell the phones charge at the expected rates.  If I double check with the app Ampere, it also confirms the faster rates.  However there are a noticeable number of times that the phones will charge very slowly.  When I check in those instances, the phones will display "slowly charging," and when I check Ampere, it shows slow charging stats.  If I disconnect and reconnect the cables , sometimes that's enough to correct the problem.

 

Here are my questions:

1) My understanding is that the Original cables (not the XL) can charge at rates up to 2.4 amps - is that correct?

2) Even If the phone supports faster charging rates, is it true that the original cables should still be able to charge up to 2.4 amps without trouble?

3) If the above are both true, but I'm still encountering the issues described, would it be likely the cables are not working correctly? 

 

Thanks in advance.

Um... without you providing your make and model of phone, it's impossible to answer this questions accurately.

 

Volta does indicate on their site that their cables should support the standard Qualcomm QuickCharge 2.0 and 3.0, but not Oppo/OnePlus Dash Charge. However, as with ANY third party cable, you can have inconsistencies compared to using the original cable. Samsung phones went through a similar issue back in the days of the Note 3 where the original Samsung cables would always provide fast charging, but some third party cables were intermittent. https://voltacharger.com/pages/help

Desktop: KRySTaLoGi-PC Build Log (i7-4790K, RTX2060) Mobile: OnePlus 5T | Koodo - Unlimited Calls & Texts + 12GB Data
Laptop: Dell XPS 15 9560 (the real 15" MacBook Pro that Apple didn't make) Tablet: iPad Mini 5 | Lenovo IdeaPad Duet 10.1
Camera: Canon M6 Mark II | Canon Rebel T1i (500D) | Canon SX280 | Panasonic TS20D Music: Spotify Premium (CIRCA '08)

Link to comment
Share on other sites

Link to post
Share on other sites

36 minutes ago, kirashi said:

Um... without you providing your make and model of phone, it's impossible to answer this questions accurately.

 

Volta does indicate on their site that their cables should support the standard Qualcomm QuickCharge 2.0 and 3.0, but not Oppo/OnePlus Dash Charge. However, as with ANY third party cable, you can have inconsistencies compared to using the original cable. Samsung phones went through a similar issue back in the days of the Note 3 where the original Samsung cables would always provide fast charging, but some third party cables were intermittent. https://voltacharger.com/pages/help

My mistake:

* So far the phones used are a Moto G6 (USA 3GB/32GB) and a Nextbit Robin. Both use the USB-C tips.

* The chargers I have used are the the one included with the Moto G6, and a Anker PowerPort 4 (AK-A2142111).

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×