Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Unraid wont boot from my Nvidia gpu (ryzen build)

Hi,

 

Its my first time here posting a query, i dont even know if its the right place to post but since i tried to make an unraid system by watching linus video here i am.

 

First of all , this is my build,

 

CPU - amd ryzen 1600 

Mobo - asus rog strix b450 f-gaming

RAM - corsair vengence 2x8gb ram

GPU 1 - zotac 1060 amp! edition 6gb

GPU 2 - msi r7 240 2gb

NVMe SSD 1 - samsung 970evo 250gb

NVMe SSD 2 - samsung 970evo 250gb

SATA HDD 1 - Seagate ironwolf 4tb

SATA HDD 2 - Seagate ironwolf 4tb

SATA HDD 3 - Seagate compute 6tb

SATA HDD 4 - Seagate Desktop 4tb

PSU - Cooler Master 650M 80+ Bronze 

Case - Cooler Master HAF 922 Full atx

 

i am using unraid version 6.6.6 on a sandisk ultra 16gb usb3.0 . pendrive.

 

The setup is configured like this,

 

SATA HDD 1-4 - Array devices 

NVMe SSD 1-2 - Cache Devices

No parity (yes i know but i have ordered a 10tb hdd and it will become the parity so waiting for it)

 

I have setup the shares, docker and VM.

 

Here is the problem part, initially i had only one gpu ( 1060) and the unraid would work but as soon as i setup vm and assign the gpu everything would go blank while the vm is still running in the background. knowing that unraid needs two gpu i bought a r7 240 and the problem solved! nope

 

First of all the motherboard has 3 PCIe x16 slots with first and second slot run at x8 and x4 respectively.

 

The thing is no matter where i put both the GPU the bios and the unraid console would boot straight from the NVIDIA gpu.

And when this happens i cannot assign the GPU to a vm without me staring at a blank screen. But it will work if i assign it to the AMD gpu.

 

I tried to set the default PCI bus in the motherboard BIOS to the AMD card but no matter where i put it, it will always boot from the NVIDIA card.

 

As of now i am stuck with AMD gpu in slot 1 with x8 speed and Nvidia gpu in slot 2 with x4 speed and VM running from the AMD card (using seabios and i44fx-3.0)

 

 

I am tired to use Vbios , flash and edit the xml file and install fresh copy of windows. 

 

Can anyone help me with this (sorry for this long post dont know i just want to solve this problem).

 

TL;DR - amd ryzen build with no igpu , using dual gpu setup (nvidia 1060 and amd r7 240) but system would boot from nvidia card and vm would only boot from amd. Need it the other way around.

THANKS.

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×