Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

PC Trying To Pull Files From Disconnected HDD

 Share

System Specs:

 

PSU: Corsair VS 650W

MOBO: Gigabyte GA-B350M-Gaming 3

CPU: AMD Ryzen 1700 8c/16t @3.45ghz

RAM: 20gb Hyperx Fury DDR4 @2500mhz

GPU: ASUS GTX 1060 6gb @1949mhz

STORAGE: 120gb Kingston SATA ssd, 2tb Seagate Firecuda SSHD

 

The context and My Issue:

 

I had an old WD Black 2tb HDD that was a pass down of a pass down from somewhere in the ball park of ten years ago. It ran like a champ up until two years ago, when it decided to go and I failed to recognize the obvious signs it was giving off. After two years of operating as an effectively dead HDD (upon boot the HDD would stay pinned at 100% usage for upwards of 10 minutes, and there were 0 reads or writes happening; AND it sounded like a coffee machine brewing coffee), I realized that the HDD had died, and it was causing serious dropped frames in games, recordings to become corrupted, and overall just taxation on my system as a whole. So I decided to unplug it (safely, of course) and see if that would help my system, knowing I would instantly lose all the data and shortcuts to that data. The result? Butter smooth gameplay and recordings look crisp. HOWEVER, I tried to launch any game that requires the EPIC launcher, and since it was on the old drive that I tore out, it goes looking for that connection to no avail. I also attempted to "uninstall" the launcher via "Add or Remove Programs" in Windows; nothing. Finally, I tried to install the launcher onto one of my current drives, however it gives me the error "Invalid Drive: D:\" (The Old Drive). Screenshot #1 shows when I try to launch Squad (since it's based on the Unreal Engine, I assume it's the issue), and how it won't allow me to proceed. Any help regarding this matter would be greatly appreciated. I don't have the option of reconnecting the old drive, either; it's long gone.

 

I have essentially two issues, but I believe one stems from the other. How can I redirect my system to the new drive, if that's what I need to do? I believe the Squad crash is based around the prior issue. I apologize for the confusion.

Capture.PNG

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×