Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Ryzen 2200G Runs A Lot Worse Than Expected

SakibC17
 Share

I bought this Ryzen 2200G about 6 months ago and ever since then, I have noticed that I wasn't getting the same performance as people do on youtube with the same processor/igpu. I always have stutters no matter the game and usually 30 fps lower than what I see on benchmarks on youtube. I can't tell if it is my RAM (shows 2134mhz most of the time) that is causing the problems or that I have Ryzen Master which always shows my cpu at 1600mhz and gfx clock at 400 mhz. I have tried putting the bar up for my clock speeds in Ryzen Master, but it doesn't affect my performance at all. Can anyone please tell me what is causing my problems and how to fix it? Thanks.

CPU : RYZEN 2200G

RAM : G.SKILL Ripjaws V Series 8GB (2 x 4GB) 288-Pin DDR4 2800 (PC4 22400)

Timing 16-16-16-36

CAS Latency 16

Voltage 1.2V
MOTHERBOARD : ASROCK AB350M PRO4

EDIT: I also found in the task manager and after using Speccy that my ram speed only indicates 2134mhz even though I bought 2800mhz ram. 

This is a picture of Ryzen Master when I manually raised the GFX and CPU clocks. I also noticed that i can't raise the memory clock past 2100mhz too.

https://plus.google.com/photos/photo/114665116463254246...[/img]

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, SakibC17 said:

I bought this Ryzen 2200G about 6 months ago and ever since then, I have noticed that I wasn't getting the same performance as people do on youtube with the same processor/igpu. I always have stutters no matter the game and usually 30 fps lower than what I see on benchmarks on youtube. I can't tell if it is my RAM (shows 2134mhz most of the time) that is causing the problems or that I have Ryzen Master which always shows my cpu at 1600mhz and gfx clock at 400 mhz. I have tried putting the bar up for my clock speeds in Ryzen Master, but it doesn't affect my performance at all. Can anyone please tell me what is causing my problems and how to fix it? Thanks.

CPU : RYZEN 2200G

RAM : G.SKILL Ripjaws V Series 8GB (2 x 4GB) 288-Pin DDR4 2800 (PC4 22400)

Timing 16-16-16-36

CAS Latency 16

Voltage 1.2V
MOTHERBOARD : ASROCK AB350M PRO4

EDIT: I also found in the task manager and after using Speccy that my ram speed only indicates 2134mhz even though I bought 2800mhz ram. 

This is a picture of Ryzen Master when I manually raised the GFX and CPU clocks. I also noticed that i can't raise the memory clock past 2100mhz too.

https://plus.google.com/photos/photo/114665116463254246...[/img]

Have you enabled DOCP/XMP for the RAM, or are you just manually raising the speed?

 

What games, resolution and settings? Vega 8 isn't exactly a powerhouse. It's on par with something like a GTX 550 or GTX 260, IIRC.

Sincerely,

 

me

Link to comment
Share on other sites

Link to post
Share on other sites

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, aisle9 said:

Have you enabled DOCP/XMP for the RAM, or are you just manually raising the speed?

 

What games, resolution and settings? Vega 8 isn't exactly a powerhouse. It's on par with something like a GTX 550 or GTX 260, IIRC.

I'm not sure what DCOP or XMP are, but I manually raised the speed to 2100mhz (doesn't allow me to go higher) in Ryzen Master. Also, I understand that Vega 8 isn't that strong but I know for sure it's not running as it should because in Payday 2 and Metro 2033 (original) I get only 20-35 fps on abosultely lowest settings and 720p.

Link to comment
Share on other sites

Link to post
Share on other sites

6 minutes ago, SakibC17 said:

I'm not sure what DCOP or XMP are, but I manually raised the speed to 2100mhz (doesn't allow me to go higher) in Ryzen Master. Also, I understand that Vega 8 isn't that strong but I know for sure it's not running as it should because in Payday 2 and Metro 2033 (original) I get only 20-35 fps on abosultely lowest settings and 720p.

Go into your BIOS and enable XMP or DOCP (whichever it shows) for your RAM. That will get you to the rated speed without needing to use Ryzen Master. BIOS-level overclocking is always, always better than OS-based software. Make sure you have all of your drivers, including the drivers for the 2200G downloaded directly from AMD's site. The drivers you get from Windows Update are usually ancient.

Sincerely,

 

me

Link to comment
Share on other sites

Link to post
Share on other sites

Thanks you guys so much for telling me about this. I'll make sure to try it out soon. 

Link to comment
Share on other sites

Link to post
Share on other sites

31 minutes ago, aisle9 said:

Go into your BIOS and enable XMP or DOCP (whichever it shows) for your RAM. That will get you to the rated speed without needing to use Ryzen Master. BIOS-level overclocking is always, always better than OS-based software. Make sure you have all of your drivers, including the drivers for the 2200G downloaded directly from AMD's site. The drivers you get from Windows Update are usually ancient.

Should I also change the timings of the RAM if they are not the same as the one's listed on Newegg's website (can't find this RAM on G SKILL's website).

https://www.newegg.ca/Product/Product.aspx?Item=N82E16820231947

 

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, SakibC17 said:

Should I also change the timings of the RAM if they are not the same as the one's listed on Newegg's website (can't find this RAM on G SKILL's website).

https://www.newegg.ca/Product/Product.aspx?Item=N82E16820231947

 

When you enable XMP/DOCP, that will take care of all the configuration chances, including timings and voltage.

Sincerely,

 

me

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, aisle9 said:

When you enable XMP/DOCP, that will take care of all the configuration chances, including timings and voltage.

Oh, okay. Thank you so much for helping me out. 

Link to comment
Share on other sites

Link to post
Share on other sites

11 hours ago, aisle9 said:

Go into your BIOS and enable XMP or DOCP (whichever it shows) for your RAM. That will get you to the rated speed without needing to use Ryzen Master. BIOS-level overclocking is always, always better than OS-based software. Make sure you have all of your drivers, including the drivers for the 2200G downloaded directly from AMD's site. The drivers you get from Windows Update are usually ancient.

So I tried out what you said and it definitely worked (thank you so much), but not to how it should have. I enabled XMP and in the task manager it finally showed my ram speed as 2800mhz, but when I went into a game to test performance the mhz just capped off at 1400mhz. Then I went to see if Ryzen Master was the issue and it definitely is because over there it locks the memory clock at 1400mhz and still doesn't let me slide it to 2800mhz, but rather only to 2100mhz. Can you please tell me a way fix this problem and have my memory run at 2800mhz?

 

Also, here is a picture of what Ryzen Master shows for me if this helps. (ignore the gfx and cpu clock speeds because those change when I open games and what is shown is inaccurate)

 

And again thank you so much. 

 

Capture.thumb.PNG.ecc0ce82b51765f674d6c8ed8b63e7aa.PNG

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

15 minutes ago, SakibC17 said:

So I tried out what you said and it definitely worked (thank you so much), but not to how it should have. I enabled XMP and in the task manager it finally showed my ram speed as 2800mhz, but when I went into a game to test performance the mhz just capped off at 1400mhz. Then I went to see if Ryzen Master was the issue and it definitely is because over there it locks the memory clock at 1400mhz and still doesn't let me slide it to 2800mhz, but rather only to 2100mhz. Can you please tell me a way fix this problem and have my memory run at 2800mhz?

 

Also, here is a picture of what Ryzen Master shows for me if this helps. (ignore the gfx and cpu clock speeds because those change when I open games and what is shown is inaccurate)

 

And again thank you so much. 

 

Capture.thumb.PNG.ecc0ce82b51765f674d6c8ed8b63e7aa.PNG

 

 

 

If its saying 1400, but it's saved in the BIOS as 2800, then one of two things is probably happening. 

 

1-You should be running dual channel memory, so when it says 1400, it might mean per channel

2-If you are, for some reason, running single channel memory, then 1400 would be its max speed. 

 

I don't know enough exactly about this topic to tell you for sure, but I do know that the way Dual channel works can cause confusion on how speeds are represented. 

Link to comment
Share on other sites

Link to post
Share on other sites

5 hours ago, SakibC17 said:

So I tried out what you said and it definitely worked (thank you so much), but not to how it should have. I enabled XMP and in the task manager it finally showed my ram speed as 2800mhz, but when I went into a game to test performance the mhz just capped off at 1400mhz.

I believe it's OK, as the real bare frequency is actually half of what you'd expect: it's 1400Mhz x 2 (DDR = Double Data Rate) so it's indeed 2800Mhz. ?

Just to say, my 3200 kit is reported by CPUZ as running at 1600 so that makes sense.

Of course, as pstarlord pointed out, you should check if you're using dual channel, as it dramatically improves performance.

  

MAIN PC: CPU: AMD Ryzen 5 2400G | Motherboard: Gigabyte GA-AB350-Gaming | RAM: 16Gb DDR4 Patriot Viper 4 3200 | GPU: XFX RX580 4Gb GTS | Case: Sharkoon S25-W | Storage: M.2 NVME Adata Gammix S10 128Gb + SATA SSD WD Blue 1Tb | ODD: LG GH24NSD1 | PSU: Seasonic Core GM-500 | Display: AOC I2490PXQU | Cooler: Wraith Stealth | Keyboard: Logitech K120 | Mouse: Logitech B100 | Sound: the usual integrated Realtek | OS: Windows 10 Pro 64bit

RETRO PC: CPU: AMD Athlon 64 2800+ | Motherboard: Gigabyte GA-K8VM800M | RAM: 2Gb DDR 800 | GPU: ATi Radeon 9600 Pro 128Mb | Case: Tacens Anima AC4500 | Storage: IDE WD Blue 80Gb + IDE DVD-RW drive + floppy drive | Sound: Terratec 128i ESS Solo-1 PCI | OS: Windows 98 SE + Windows XP SP3 + Linux Bionic Pup 32
HTPC: CPU: AMD Athlon 3000G | Motherboard: AsRock B450M-HDV R4.0 | RAM: 16Gb DDR4 G.Skill Aegis 3200 | Case: Aerocool CS-101 | Storage: SATA SSD Silicon Power A55 256Gb | ODD: LG blu-ray WH14NS40 | OS: Windows 10 Pro 64bit

Link to comment
Share on other sites

Link to post
Share on other sites

10 hours ago, pstarlord said:

 

If its saying 1400, but it's saved in the BIOS as 2800, then one of two things is probably happening. 

 

1-You should be running dual channel memory, so when it says 1400, it might mean per channel

2-If you are, for some reason, running single channel memory, then 1400 would be its max speed. 

 

I don't know enough exactly about this topic to tell you for sure, but I do know that the way Dual channel works can cause confusion on how speeds are represented. 

 

4 hours ago, DeadnightWarrior said:

I believe it's OK, as the real bare frequency is actually half of what you'd expect: it's 1400Mhz x 2 (DDR = Double Data Rate) so it's indeed 2800Mhz. ?

Just to say, my 3200 kit is reported by CPUZ as running at 1600 so that makes sense.

Of course, as pstarlord pointed out, you should check if you're using dual channel, as it dramatically improves performance.

I do have dual channel ram and yeah, this is all making a lot more sense now. Thank you guys so much for helping me out.

Link to comment
Share on other sites

Link to post
Share on other sites

So when I thought all my problems would be over, it turns out they aren't. Although the fps has increased a bit, the stutters still remain. After a bit of searching, I found out that AMD brought out a fix to the stutters with an AGESA 1002.a bios update, but the problem is I can't find that update on my motherboard support page (https://www.asrock.com/mb/AMD/AB350M%20Pro4/index.asp#B...). Also, after looking at this page (http://forum.asrock.com/forum_posts.asp?TID=8985&PN=1&t...), I noticed not all BIOS updates will fix my issue, but I should try the PinnaclePI-AM4_1.0.0.3b. update since it worked for that guy. But I don't how to update my BIOS or that specific update will even fix my issue. So can someone tell me what I should do?  And once again, thank you all so much. 

Link to comment
Share on other sites

Link to post
Share on other sites

Looking at the bios list, it seems that any version newer than 4.70 (version 4.90 updates AGESA to 1.0.0.4) should be fine.
I'm not familiar with AsRock boards but it should be enough to just download the new bios to a USB stick, enter bios at reboot and follow these instructions: https://www.asrock.com/support/BIOSIG.asp?cat=BIOS8

  

MAIN PC: CPU: AMD Ryzen 5 2400G | Motherboard: Gigabyte GA-AB350-Gaming | RAM: 16Gb DDR4 Patriot Viper 4 3200 | GPU: XFX RX580 4Gb GTS | Case: Sharkoon S25-W | Storage: M.2 NVME Adata Gammix S10 128Gb + SATA SSD WD Blue 1Tb | ODD: LG GH24NSD1 | PSU: Seasonic Core GM-500 | Display: AOC I2490PXQU | Cooler: Wraith Stealth | Keyboard: Logitech K120 | Mouse: Logitech B100 | Sound: the usual integrated Realtek | OS: Windows 10 Pro 64bit

RETRO PC: CPU: AMD Athlon 64 2800+ | Motherboard: Gigabyte GA-K8VM800M | RAM: 2Gb DDR 800 | GPU: ATi Radeon 9600 Pro 128Mb | Case: Tacens Anima AC4500 | Storage: IDE WD Blue 80Gb + IDE DVD-RW drive + floppy drive | Sound: Terratec 128i ESS Solo-1 PCI | OS: Windows 98 SE + Windows XP SP3 + Linux Bionic Pup 32
HTPC: CPU: AMD Athlon 3000G | Motherboard: AsRock B450M-HDV R4.0 | RAM: 16Gb DDR4 G.Skill Aegis 3200 | Case: Aerocool CS-101 | Storage: SATA SSD Silicon Power A55 256Gb | ODD: LG blu-ray WH14NS40 | OS: Windows 10 Pro 64bit

Link to comment
Share on other sites

Link to post
Share on other sites

On 1/2/2019 at 2:00 AM, DeadnightWarrior said:

Looking at the bios list, it seems that any version newer than 4.70 (version 4.90 updates AGESA to 1.0.0.4) should be fine.
I'm not familiar with AsRock boards but it should be enough to just download the new bios to a USB stick, enter bios at reboot and follow these instructions: https://www.asrock.com/support/BIOSIG.asp?cat=BIOS8

Sorry for the late reply. I'm still kind of scared of messing with the BIOS, but I'll try it anyway. Hopefully it's works. Thanks for helping me out. 

Link to comment
Share on other sites

Link to post
Share on other sites

I was right about to update my BIOS today, but then I noticed in almost all the BIOS descriptions it states this "If the current BIOS version is older than P3.40, please update BIOS to P3.40(Bridge BIOS) before updating this version." When i checked my BIOS, it says it is version P4.70. So in order to update my BIOS should I downgrade to that version then update to a newer one or just update to a newer version of my BIOS from my current version? Thanks.

Link to comment
Share on other sites

Link to post
Share on other sites

33 minutes ago, SakibC17 said:

I was right about to update my BIOS today, but then I noticed in almost all the BIOS descriptions it states this "If the current BIOS version is older than P3.40, please update BIOS to P3.40(Bridge BIOS) before updating this version." When i checked my BIOS, it says it is version P4.70. So in order to update my BIOS should I downgrade to that version then update to a newer one or just update to a newer version of my BIOS from my current version? Thanks.

Nevermind, I got my answer.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×