Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

This hz thing is pissing me off

Turtle Rig
 Share

I made a custom resolution / refresh rate to 75hz from 60hz.  It works, however I don't use that resolution on the desktop.  Anyhow when I launch the game with vsync on,, its at 60fps when it should be 75hz ..... I have a feeling when I put the resolution in the game it picks up on the default 1080p profile and not using the custom profile one.  Is there any way to inject or force to use that custom res @ 75hz.  60hz is too laggy,, any help would be appreciated.  Thank you in advance.

Asus Sabertooth x79 / 4930k @ 4500 @ 1.408v / Gigabyte WF 2080 RTX / Corsair VG 64GB @ 1866 & AX1600i & H115i Pro @ 2x Noctua NF-A14 / Carbide 330r Blackout

Scarlett 2i2 Audio Interface / KRK Rokits 10" / Sennheiser HD 650 / Logitech G Pro Wireless Mouse & G915 Linear & G935 & C920 / SL 88 Grand / Cakewalk / NF-A14 Int P12 Ex
AOC 40" 4k Curved / LG 55" OLED C9 120hz / LaCie Porsche Design 2TB & 500GB / Samsung 950 Pro 500GB / 850 Pro 500GB / Crucial m4 500GB / Asus M.2 Card

Link to comment
Share on other sites

Link to post
Share on other sites

15 minutes ago, Turtle Rig said:

I made a custom resolution / refresh rate to 75hz from 60hz.  It works, however I don't use that resolution on the desktop.  Anyhow when I launch the game with vsync on,, its at 60fps when it should be 75hz ..... I have a feeling when I put the resolution in the game it picks up on the default 1080p profile and not using the custom profile one.  Is there any way to inject or force to use that custom res @ 75hz.  60hz is too laggy,, any help would be appreciated.  Thank you in advance.

Just an idea but maybe your monitor does not support 75Hz.

Link to comment
Share on other sites

Link to post
Share on other sites

Vsync always autolocks the fps cap to 60 no matter what. Changing the monitor's settings will not change that. You must turn off vsync to achieve a framerate greater than 60 fps.

CPU: i7 4790k @ 4.7 GHz

GPU: XFX GTS RX580 4GB

Cooling: Corsair h100i

Mobo: Asus z97-A 

RAM: 4x8 GB 1600 MHz Corsair Vengence

PSU: Corsair HX850

Case: NZXT S340 Elite Tempered glass edition

Display: LG 29UM68-P

Keyboard: Roccat Ryos MK FX RGB

Mouse: Logitech g900 Chaos Spectrum

Headphones: Sennheiser HD6XX

OS: Windows 10 Home

Link to comment
Share on other sites

Link to post
Share on other sites

23 minutes ago, kb5zue said:

Just an idea but maybe your monitor does not support 75Hz.

Often times you can change a monitors settings refresh faster than spec.

CPU: i7 4790k @ 4.7 GHz

GPU: XFX GTS RX580 4GB

Cooling: Corsair h100i

Mobo: Asus z97-A 

RAM: 4x8 GB 1600 MHz Corsair Vengence

PSU: Corsair HX850

Case: NZXT S340 Elite Tempered glass edition

Display: LG 29UM68-P

Keyboard: Roccat Ryos MK FX RGB

Mouse: Logitech g900 Chaos Spectrum

Headphones: Sennheiser HD6XX

OS: Windows 10 Home

Link to comment
Share on other sites

Link to post
Share on other sites

7 hours ago, ATFink said:

Often times you can change a monitors settings refresh faster than spec.

Right.  And just because the speedometer in my truck maxes out at 140mph doesn't mean the truck will go that fast.  What I'm trying to say is, just because you can doesn't necessarily mean you should.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×