Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

CPU stays at max clock speed even when idle.

Crymn
 Share

So my CPU core clock stays at max speed, even when idle.

I had it overclocked to 5 GHz, but for some troubleshooting I had to reset my BIOS, applied OC again and my clock speed stayed at max.

I already checked my power plan, its on balanced with a min CPU usage of 5%, cleared my BIOS again (running stock now), enabled EIST, disabled Hyper-V.

I hoped some of you might have clue about what to try.

 

Specs:

GPU - Asus strix GTX 1080

CPU - I7 7700K

Mobo - Asus strix Z270F 

RAM - 16GB DDR4 2666 MHz

Link to comment
Share on other sites

Link to post
Share on other sites

Enable C-states?

CPU: i7-2600K 4751MHz 1.44V (software) --> 1.47V at the back of the socket Motherboard: Asrock Z77 Extreme4 (BCLK: 103.3MHz) CPU Cooler: Noctua NH-D15 RAM: Adata XPG 2x8GB DDR3 (XMP: 2133MHz 10-11-11-30 CR2, custom: 2203MHz 10-11-10-26 CR1 tRFC:230 tREFI:14000) GPU: Asus GTX 1070 Dual (Super Jetstream vbios, +70(2025-2088MHz)/+400(8.8Gbps)) SSD: Samsung 840 Pro 256GB (main boot drive), Transcend SSD370 128GB PSU: Seasonic X-660 80+ Gold Case: Antec P110 Silent, 5 intakes 1 exhaust Monitor: AOC G2460PF 1080p 144Hz (150Hz max w/ DP, 121Hz max w/ HDMI) TN panel Keyboard: Logitech G610 Orion (Cherry MX Blue) with SteelSeries Apex M260 keycaps Mouse: BenQ Zowie FK1

 

Model: HP Omen 17 17-an110ca CPU: i7-8750H (0.125V core & cache, 50mV SA undervolt) GPU: GTX 1060 6GB Mobile (+80/+450, 1650MHz~1750MHz 0.78V~0.85V) RAM: 8+8GB DDR4-2400 18-17-17-39 2T Storage: 1TB HP EX920 PCIe x4 M.2 SSD + 1TB Seagate 7200RPM 2.5" HDD (ST1000LM049-2GH172), 128GB Toshiba PCIe x2 M.2 SSD (KBG30ZMV128G) gone cooking externally Monitor: 1080p 126Hz IPS G-sync

 

Desktop benching:

Cinebench R15 Single thread:168 Multi-thread: 833 

SuperPi (v1.5 from Techpowerup, PI value output) 16K: 0.100s 1M: 8.255s 32M: 7m 45.93s

Link to comment
Share on other sites

Link to post
Share on other sites

6 minutes ago, Jurrunio said:

Enable C-states?

Just checked, they're on.

Link to comment
Share on other sites

Link to post
Share on other sites

What program are you using to see CPU frequency?

Personal Desktop":

CPU: Intel Core i7 8700 @4.45ghz |~| Cooling: Cooler Master Hyper 212X |~| MOBO: Gigabyte Z370M D3H mATX|~| RAM: 16gb DDR4 3333mhzCL16 G.Skill Trident Z |~| GPU: nVidia Founders Edition GTX 1080 Ti |~| PSU: Corsair TX650M 80Plus Gold |~| Boot:  SSD WD Green M.2 2280 240GB |~| Storage: 1x3TB HDD 7200rpm Seagate Barracuda + SanDisk Ultra 3D 1TB |~| Case: Fractal Design Meshify C Mini |~| Display: Toshiba UL7A 4K/60hz |~| OS: Windows 10 Pro.

Luna, the temporary Desktop:

CPU: Intel Core i7 10700KF @ 5.0Ghz (5.1Ghz 4-core) |~| Cooling: bq! Dark Rock 4 Pro |~| MOBO: Gigabyte Z490 UD |~| RAM: 32G Kingston HyperX @ 2666Mhz CL13 |~| GPU: AMD Radeon RX 6800 (Reference) |~| PSU: Corsair HX1000 80+ Platinum |~| Windows Boot Drive: 2x 512GB (1TB total) Plextor SATA SSD (RAID0 volume) |~| Linux Boot Drive: 500GB Kingston A2000 |~| Storage: 4TB WD Black HDD |~| Case: Cooler Master Silencio S600 |~| Display 1 (leftmost): Eizo (unknown model) 1920x1080 IPS @ 60Hz|~| Display 2 (center): BenQ ZOWIE XL2540 1920x1080 TN @ 240Hz |~| Display 3 (rightmost): Wacom Cintiq Pro 24 3840x2160 IPS @ 60Hz 10-bit |~| OS: Windows 10 Pro (games / art) + Linux (distro: NixOS; programming and daily driver)
Link to comment
Share on other sites

Link to post
Share on other sites

9 minutes ago, Princess Cadence said:

What program are you using to see CPU frequency?

HW Monitor and Task Manager 

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, Crymn said:

HW Monitor and Task Manager 

I'd use CPU-z (run as adm) just to make sure.

 

Task Manager and nothing is about the same thing, it's the most inaccurate of all and I have seen HW Monitor derp out time to time too.

Personal Desktop":

CPU: Intel Core i7 8700 @4.45ghz |~| Cooling: Cooler Master Hyper 212X |~| MOBO: Gigabyte Z370M D3H mATX|~| RAM: 16gb DDR4 3333mhzCL16 G.Skill Trident Z |~| GPU: nVidia Founders Edition GTX 1080 Ti |~| PSU: Corsair TX650M 80Plus Gold |~| Boot:  SSD WD Green M.2 2280 240GB |~| Storage: 1x3TB HDD 7200rpm Seagate Barracuda + SanDisk Ultra 3D 1TB |~| Case: Fractal Design Meshify C Mini |~| Display: Toshiba UL7A 4K/60hz |~| OS: Windows 10 Pro.

Luna, the temporary Desktop:

CPU: Intel Core i7 10700KF @ 5.0Ghz (5.1Ghz 4-core) |~| Cooling: bq! Dark Rock 4 Pro |~| MOBO: Gigabyte Z490 UD |~| RAM: 32G Kingston HyperX @ 2666Mhz CL13 |~| GPU: AMD Radeon RX 6800 (Reference) |~| PSU: Corsair HX1000 80+ Platinum |~| Windows Boot Drive: 2x 512GB (1TB total) Plextor SATA SSD (RAID0 volume) |~| Linux Boot Drive: 500GB Kingston A2000 |~| Storage: 4TB WD Black HDD |~| Case: Cooler Master Silencio S600 |~| Display 1 (leftmost): Eizo (unknown model) 1920x1080 IPS @ 60Hz|~| Display 2 (center): BenQ ZOWIE XL2540 1920x1080 TN @ 240Hz |~| Display 3 (rightmost): Wacom Cintiq Pro 24 3840x2160 IPS @ 60Hz 10-bit |~| OS: Windows 10 Pro (games / art) + Linux (distro: NixOS; programming and daily driver)
Link to comment
Share on other sites

Link to post
Share on other sites

4 minutes ago, Princess Cadence said:

I'd use CPU-z (run as adm) just to make sure.

 

Task Manager and nothing is about the same thing, it's the most inaccurate of all and I have seen HW Monitor derp out time to time too.

CPU-Z gives the same results.

Link to comment
Share on other sites

Link to post
Share on other sites

Try running ThrottleStop and post a few screenshots.  

 

https://www.techpowerup.com/download/techpowerup-throttlestop/

 

It will show you if SpeedStep or Speed Shift is enabled, how much load is on your CPU when your think it is idle and what C States your CPU is really using.  It also gives you access to the Non Turbo Ratio variable.  This can interfere with your CPU idling down when it is not set correctly.  Make sure this is set to 0 in the FIVR window.

 

Some popular monitoring apps will report the max CPU speed when there is a slight load on the CPU.  ThrottleStop tells it like it is for each thread without any rounding of the data.  Post a screenshot of ThrottleStop as well as the C State window when idle.

Link to comment
Share on other sites

Link to post
Share on other sites

17 hours ago, unclewebb said:

Try running ThrottleStop and post a few screenshots.  

 

https://www.techpowerup.com/download/techpowerup-throttlestop/

 

It will show you if SpeedStep or Speed Shift is enabled, how much load is on your CPU when your think it is idle and what C States your CPU is really using.  It also gives you access to the Non Turbo Ratio variable.  This can interfere with your CPU idling down when it is not set correctly.  Make sure this is set to 0 in the FIVR window.

 

Some popular monitoring apps will report the max CPU speed when there is a slight load on the CPU.  ThrottleStop tells it like it is for each thread without any rounding of the data.  Post a screenshot of ThrottleStop as well as the C State window when idle.

SpeedStep is on and the Non Turbo Ratio variable is set to 0.

 

1311321399_unknown(1).png.796ad6eff3dbc36c7ed091b8689ba9f9.png387630575_unknown(2).png.8f988fbc2f530268249bfdb475fbe46b.png

SpeedShift seems to be disabled tho, I've enabled it in the BIOS but it doesn't have any effects untill I turn it on using ThrottleStop. After enabling it in ThrottleStop my clock speed varies again so that dope. But is there any way to enable this by default or do I have to launch ThrottleStop at startup from now on. Btw, in the meantime I've also tried booting from another systems boot drive (that has a clean windows install), on that drive SpeedShift seems to work just fine without having to enable it manually. Could it be a problem with my with the current windows insiders preview that I'm running on, although I haven't seen any reports of this issue on the insiders forum or known issues list, plus the issue was also happening in the previous build. So I guess I kinda answered myself there...

Anyway.. I hope these screenshots might help a bit.

 

unknown.png.eeb0fb31a00d488e3f20aa00f60483ff.png

Link to comment
Share on other sites

Link to post
Share on other sites

I've figured it out! It seems SpeedShift only gets enalbled when using the Balanced or Power Saver power plan. I was using the High performance power plan and set the min CPU usage to 5%. Turns out that the High performance power plan doesn't enable SST, so I just went back to Balanced and now all is fine. Thanks for all the help.

Link to comment
Share on other sites

Link to post
Share on other sites

Glad you got this figured out.  Looks like Microsoft is using Speed Shift on the desktop CPUs that support it.

 

Not that you need to but if you ever want to, you can use ThrottleStop to enable Speed Shift in the High Performance profile.  After that you can adjust the Speed Shift - EPP value on the main screen.  0 for maximum performance and somewhere between 80 and 128 is similar to the Windows Balanced power profile.  An EPP value of 255 is the slow and sluggish econo setting.  You can set up different profiles with different EPP values in ThrottleStop and then easily switch profiles and EPP values on the fly by using a keyboard shortcut.

 

Thanks for posting some pics. 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×