Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

M.2 disappears after plugging in a 2nd M.2

Axehat
 Share

Hopefully I can explain this well enough. 

 

Picked up a Samsung 860 evo 1tb m.2 to install into my laptop, Sager NP 8152. I've already got an Intel 600p 500gb pcie m.2 in there for boot drive and programs, and a Crucial MX300 750gb 2.5" ssd as additional storage. I popped the Samsung in and then get an error that there's no Windows install. Take it out, everything's back to normal. 

 

Did some googling, found that I might not have configured to UEFI (?) but then I've been running everything just fine up until now. Though one thing that hints to that, maybe, is that the Crucial drive seems to be targeted at boot, but then loads Windows from the Intel drive since the Crucial doesn't have an OS on it. Not sure how I swung that, and could be my problem. 

 

Pt. 2: cloned/copied/mirrored the Intel. Wiped it (so scary). Removed all other drives, but the Intel and tried a Windows install off a USB. It remade the proper partitions, recognized in BIOS, everything's good. Put the Samsung back in, thinking I'll install Windows onto that, then reimage the Intel so I've got all my stuff back (which might not work anyway, but let me dream), and the Intel disappears again...

 

Why? Any ideas? 

 

I'll admit I haven't updated the bios, though I did think that might work, but I can't find an update through the Sager site, and I'm intimidated by the American Megatrends website. 

 

The whole issue is getting the two M.2 drives to work with each other (Samsung and Intel). Installing Windows with all three drives installed, both M.2s clean, and partitions already created only shows the Samsung and Crucial drives. The Intel is nowhere to be found (also missing in the bios). 

 

Any help would be greatly appreciated. If I'm missing any info please let me know and I'll add it asap. 

 

- Paul 

 

Addendum: I can't swap the M.2s as there is one m key slot and one b key slot. The Intel is a b key and the Samsung is a b+m key. 

Link to comment
Share on other sites

Link to post
Share on other sites

Ah, thanks a lot! Kept trying to find this info and completely ignored the manual. Tried to check it out just before I posted but the download was an .exe and I'm on my phone lol. 

 

Guess RTFM still rings true... 

 

Argh, stupid port 3 has the labelling "3G/LTE + M.2 SATA" on it too, which didn't help my understanding at all. 

Edited by Axehat
Additional info
Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×