Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

New Graphics Card messed up my resolution?

ZoiDoi
 Share

Hello! So I just installed the RX 580 and when I started up my pc, the resolution is all wacky. Right now it is at 1280 x 1024 and it should be at 1280 x 720 Any help?

 

Thanks!

Link to comment
Share on other sites

Link to post
Share on other sites

right click desktop -> Display settings

and/or download the drivers for your card and adjust desktop resolution through AMD's software (is it still called Catalyst?)

~Remember to quote posts to continue support on your thread~
-Don't be this kind of person-

CPU:  AMD Ryzen 7 5800x | RAM: 2x16GB Crucial Ripjaws Z | Cooling: XSPC/EK/Bitspower loop | MOBO: Gigabyte x570 Aorus Master | PSU: Seasonic Prime 750 Titanium  

SSD: 250GB Samsung 980 PRO (OS) | 1TB Crucial MX500| 2TB Crucial P2 | Case: Phanteks Evolv X | GPU: EVGA GTX 1080 Ti FTW3 (with EK Block) | HDD: 1x Seagate Barracuda 2TB

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Semper said:

right click desktop -> Display settings

and/or download the drivers for your card and adjust desktop resolution through AMD's software (is it still called Catalyst?)

So I tried installing the drivers and it said components installed

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, ZoiDoi said:

So I tried installing the drivers and it said components installed

In which case, you may need to reboot and then find your display settings through AMD's software.

~Remember to quote posts to continue support on your thread~
-Don't be this kind of person-

CPU:  AMD Ryzen 7 5800x | RAM: 2x16GB Crucial Ripjaws Z | Cooling: XSPC/EK/Bitspower loop | MOBO: Gigabyte x570 Aorus Master | PSU: Seasonic Prime 750 Titanium  

SSD: 250GB Samsung 980 PRO (OS) | 1TB Crucial MX500| 2TB Crucial P2 | Case: Phanteks Evolv X | GPU: EVGA GTX 1080 Ti FTW3 (with EK Block) | HDD: 1x Seagate Barracuda 2TB

Link to comment
Share on other sites

Link to post
Share on other sites

Are you using Windows? Right click on your desktop and select display settings

I WILL find your ITX build thread, and I WILL recommend the SIlverstone Sugo SG13B

 

Primary PC:

i7 8086k (won) - EVGA Z370 Classified K - G.Skill Trident Z RGB - WD SN750 - Jedi Order Titan Xp - Hyper 212 Black (with RGB Riing flair) - EVGA G3 650W - dual booting Windows 10 and Linux - Black and green theme, Razer brainwashed me.

Draws 400 watts under max load, for reference.

 

Linux Proliant ML150 G6:

Dual Xeon X5560 - 24GB ECC DDR3 - GTX 750 TI - old Seagate 1.5TB HDD - dark mode Ubuntu (and Win7, cuz why not)

 

How many watts do I need? Seasonic Focus thread, PSU misconceptions, protections explainedgroup reg is bad

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×