Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Random Visual Glitches on New 4K Monitor

avrona
 Share

So I've upgraded to a new 4k monitor back in October, and for a few weeks now I've been getting strange visual glitches, primarily my monitor has been going randomly black from time to time. It doesn't turn on or anything, as the light is still on, and it remains as a white light, meaning it's still receiving a signal from my PC. As far as I can tell there is no pattern to it or anything that makes this appear more frequently. It can go 20 minutes without doing it, and then I could have 2, one right after the other one. Other visual glitches include red, horizontal lines randomly appearing, and the screen flashing white sometimes. I've never had a problem like this, so I haven't mentioned any necessary info just let me know.

 

Specs:

CPU: fx-8350

Graphics Card: GTX 1080Ti

Motherboard: ASUS M5A97

Monitor: ASUS MG28U (4k, 60 Hz)

RAM: 16GB DDR3

PSU: XFX 550

Sound Card: Sound Blaster Z

OS: Windows 10

Link to comment
Share on other sites

Link to post
Share on other sites

Could be something wrong with your HDMI or displayport cable. Maybe try another one?

 

print "Hello World!" ("Hello World!")

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×