Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Razer Blade Stealth 2016 shuts down a few seconds after starting to boot

DialNForNerder
 Share

The problem is with an early 2016 Razer Blade Stealth, the skylake one (rz09-01682e22-r3u1).  This started when I reinstalled/reset windows 10 from the option in settings, walked away while it reset, came back to it being off.  when i tried turning it on, the razer logo boot screen popped up for a few seconds, then it shut down.  Laptop was bought on ebay about a month ago, so no warranty to void/fall back on.  

 

What i've tried:

 

disconnecting battery for a bit.

unplugging cmos battery for a bit.

removing m.2 drive, which allowed me to get into the bios, but only for a few seconds still.

f9 recovery mode

 

I also tried Razer's live chat tech support twice, I told them all of this (except for the part where I opened the laptop), first time they told me to send it in because it's probably motherboard damage, the seconds one though told me that i would be disconnected from the chat when I shut down the computer to try to enter recovery mode... as if I was chatting to them... from a laptop that won't boot...  Any help is welcome, i can't see a windows reset causing board damage.    

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×