Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

How to disable iGPU on Z77 board?

bigPPchad
 Share

So for years the way disabling the iGPU has worked on my ASUS P8Z77-M Pro is under system agent selecting the primary GPU from iGPU to either PCIE or auto. Normally that disables the iGPU. I can't adjust the clock speed in AI Tweaker and plugging in a display does nothing but now for some reason my iGPU is stuck on and nothing will turn it off. Its eating up nearly 1GB of my system memory at all times and when I change the primary display from iGPU to anything else my Windows 10 refuses to boot. I can see the Windows boot animation and when it's done and is about to go to the login page I get nothing but a black screen and my keyboard doesn't power up. Honestly ever since I upgraded to Windows 10 i've been having these issues but going back really isn't an option for obvious reasons.

Any ideas?

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×