Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

PCI-e slots not working on my new Asus Z170-E

Hey,

 

I recently upgraded my old Asus Prime B150 to an Asus Z170-E. The problem Im having is that my GTX 1070 is not been recognized by the motherboard.

 

I tried my card on a different motherboard and it works fine. And it was working fine on my old mobo as well. I tried instally installing new drivers from nvidia as well but it doesn't detect an nvdia card on my system so doesn't allow me to download it. Do I have to update BIOS or drivers or anything like that on my new mobo? Or is the mobo faulty?

 

Any help is appreciated. Thanks.

Untitled.png

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×