Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Just broke pins on intel Stock Cooler

POWER_ID
 Share

I Just Want To Clean The Cooler And Done Cleaning it And Try To Reinstalled,Unfortunately The Pin Just Snap

 

Anyone Have A Suggest Fixing It Without Buy New One? 

Gigabyte A320M-S2h Rev 1.2
Ryzen 5 1600 w/ Stock Wraith Spire

Micron 8GB 2666MHz From HP Prebuilt @ 3533MHz CL18 (Single Channel)

MSI RX 460 4GB OC w/ RX 560 Bios for couple months

WD Green 240GB m.2 SATA III 
WD Blue 7200RPM 1TB
WD Blue 5400RPM 1TB
Seagate Pipeline 5900RPM 500GB
Zalman ZM600-HP (Heatpipe Utilized PSU) 600W 

Link to comment
Share on other sites

Link to post
Share on other sites

6 minutes ago, Prius Is Suck said:

I Just Want To Clean The Cooler And Done Cleaning it And Try To Reinstalled,Unfortunately The Pin Just Snap

 

Anyone Have A Suggest Fixing It Without Buy New One? 

Just pick a screw and drive it into the broken pin through the hole on the back side of mobo. It should cut itself well into the plastic. But you should get a proper size and don't break the pcb.

Link to comment
Share on other sites

Link to post
Share on other sites

  • 1 year later...

Yeah That Maybe Help If I Careful But Somehow My friend Being Jerk And Push The Screwdriver To Hard And You Know

Gigabyte A320M-S2h Rev 1.2
Ryzen 5 1600 w/ Stock Wraith Spire

Micron 8GB 2666MHz From HP Prebuilt @ 3533MHz CL18 (Single Channel)

MSI RX 460 4GB OC w/ RX 560 Bios for couple months

WD Green 240GB m.2 SATA III 
WD Blue 7200RPM 1TB
WD Blue 5400RPM 1TB
Seagate Pipeline 5900RPM 500GB
Zalman ZM600-HP (Heatpipe Utilized PSU) 600W 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×