Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

144hz Screen limited to 60HZ

Glenn S
 Share

Hello, just found out that my centre screen, an AOC G2460PF, has no longer been displaying at 144hz. (shown here:http://prntscr.com/lt844j) Any ideas?

 

Thanks in advance

Link to comment
Share on other sites

Link to post
Share on other sites

What cable are you using from what GPU? 

Intel HEDT and Server platform enthusiasts: Intel HEDT Xeon/i7 Megathread 

 

Current Rig - i7 6950X - EVGA X99 Classified - 4x8GB 3200Mhz CL16 DDR4 - 2060 Super FE - 1TB 970 Evo + 500GB WD Blue SSD + 1TB MX500 - LG WH14NS40 BluRay Drive - EVGA 1000W G3 - Corsair Air 540 - Noctua iPPC NF-A14 3000 (rear) + 3x Noctua NF-P12 redux-1700 PWM (radiator) - LG 27UK650-W (27" 4K60hz) - Custom CPU/GPU Loop w/single 360mm rad - Windows 10

 

Project Rig (WIP) - Xeon I forgot the name of - NH-L12S - EVGA X99 Micro 2 - 4x4GB 2800MHz DDR4 - WX2100 2GB - 256GB 960 Evo - Flex-ATX PSU - Old Dell OEM case - Noctua 80mm fans - probably will be windows

 

Daily Devices:

(work laptop) MacBook Pro 15,4 - i7 4980HQ - 16GB DDR3L - Iris Pro/Radeon R9 M370X 2GB - 1TB SSD - macOS 12.3 Monterey   

iPhone 13 Pro Max 128GB - iOS 15.4

Link to comment
Share on other sites

Link to post
Share on other sites

check nvidia control panel and set it back to 144hz if it is on 60. sometimes the nvidia control panel does that unfortunately

~i5-7600k @5GHz ~Be Quiet! Dark rock 3 ~MSI GTX 1070 Gaming X 8G ~Gigabyte GA-Z270-gaming K3 ~Corsair Vengeance Red led ~NZXT S340 Elite

Link to comment
Share on other sites

Link to post
Share on other sites

Are you using HDMI or DisplayPort? Avoid HDMI for 144hz, go DisplayPort if possible. 

Link to comment
Share on other sites

Link to post
Share on other sites

I had a similar problem, the fix was in "advanced display settings" within Windows 10.  There you can set the maximum resolution. 

Link to comment
Share on other sites

Link to post
Share on other sites

20 hours ago, pstarlord said:

I had a similar problem, the fix was in "advanced display settings" within Windows 10.  There you can set the maximum resolution. 

Ahh, Thanks that sorted it. Will provide screenshots for anyone else wondering how this works. 
1: http://prntscr.com/ltmnix

2:http://prntscr.com/ltmoca

3:http://prntscr.com/ltmp4l

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×