Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Is my pc going to work ?

 Share

Hello guys. Over the cyber week and black friday i started buying pc parts for my first ever build. I never had the money for it. As said its my first build and im scared. I am building this pc for gaming. No streaming or what ever, just gaming. I got myself folowing:

 

Cpu - ryzen 5 2600

Gpu - sapphire vega 56 pulse

Ram - g.skill aegis 2x8gb 3000mhz

Mobo - b450 tomahawk msi

Psu - be quiet 600w bronze

Ssd - kingston 480gb

 

Thw last part im missing is the mobo and its comming tomorrow. I am scared that its not gonna work good  because i saw that ryzen works rly good with their licensed ram and on a high freq. Also idk if my psu is enough. My first build ever and i am scared like a little kid. I would kill myself if i would have to send the parts back and the wait again for new ones...

Link to comment
Share on other sites

Link to post
Share on other sites

Looks good! I would swap out ram but it's not really a big deal. 

CPU:R9 3900x@4.5Ghz RAM:Vengeance Pro LPX @ 3200mhz MOBO:MSI Tomohawk B350 GPU:PNY GTX 1080 XLR8

DRIVES:500GB Samsung 970 Pro + Patriot Blast 480GB x2 + 12tb RAID10 NAS

MONITORS:Pixio PX329 32inch 1440p 165hz, LG 34UM68-p 1080p 75hz

 

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

Don't see why not, nice choice of parts! :D 

Good luck with your build!

Current Project: Xbox 360 Ryzen Sleeper Budget Build

Daily Driver: Asus ROG Flow X13 - 5900HS/3050Ti

Gaming Desktop: NCase M1 - 5800X/3060Ti

 

Past Devices:

Razer Book 13 - i7-1165G7, 16/256GB

Gigabyte Aero 15x - i7-8750H, GTX 1070MQ, 32/512+512GB

Dell XPS 13 9360 - i5-8250u, 8/256GB

Mi Notebook Air - i5-8250u, MX150, 8/512GB

Ideapad S500 Touch - i5-3337u, GT720M, 8/256GB

Macbook A1181 (Late 2006) - C2D T7200, 4/512GB

 

Link to comment
Share on other sites

Link to post
Share on other sites

Small update for everyone. Pc is runing awesome. Without activating XMP in my bios, my ram was on 2133mhz. With xmp i run on 2933mhz. 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×