Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Newly built PC doesnt see my monitor

icth
 Share

Hi ive Just built my new PC and when i start it up it Goes on everything works the fans the pump, GPU, ram, psu and my monitor/tv wont detect the PC, after like 15 seconds the PC resets and its on a loop doing that over and over again, please help, the specs are

I7 9700k

Msi gaming x trio 2080

Corsair Vengance rgb pro 3000 2x8

Corsair rmx750w psu

Crucial mx500 1tb ssd

Corsair 100i rgb pro aio

Gigabyte z390 aorus pro mb

Samsung 960 Evo 500gb m2 ssd

The monitor/tv ive tried So far were LG 22LD320 Za and JVC LT-32VF52K both via HDMI. Im suspecting theyre Too Old. 

Link to comment
Share on other sites

Link to post
Share on other sites

15 minutes ago, icth said:

Hi ive Just built my new PC and when i start it up it Goes on everything works the fans the pump, GPU, ram, psu and my monitor/tv wont detect the PC, after like 15 seconds the PC resets and its on a loop doing that over and over again, please help, the specs are

 I7 9700k

Msi gaming x trio 2080

Corsair Vengance rgb pro 3000 2x8

Corsair rmx750w psu

Crucial mx500 1tb ssd

Corsair 100i rgb pro aio

Gigabyte z390 aorus pro mb

Samsung 960 Evo 500gb m2 ssd

The monitor/tv ive tried So far were LG 22LD320 Za and JVC LT-32VF52K both via HDMI. Im suspecting theyre Too Old. 

Are you connecting using the port on Motherboard or the Graphic card?

CPU i7 8700k MB  Asrock Z370 Killer SLI/ac GPU EVGA GTX1060 6 GB RAM 16GB DDR4 Gskill Ripjaw 3200 Mhz PSU EVGA SuperNova 750 G1+Storage 1x1TB WD Blue + 250GB WD Blue M.2 CASE Fractal design define C

Link to comment
Share on other sites

Link to post
Share on other sites

Have you tried going through this list?

Fan Comparisons          F@H          PCPartPicker         Analysis of Market Trends (Coming soon? Never? Who knows!)

Designing a mITX case. Working on aluminum prototypes.

Open for intern / part-time. Good at maths, CAD and airflow stuff. Dabbled with Python.

Please fill out this form! It helps a ton! https://linustechtips.com/main/topic/841400-the-poll-to-end-all-polls-poll/

Link to comment
Share on other sites

Link to post
Share on other sites

Any code on the Mobo or beeps when it restarts? 

Current Build:

CPU: AMD Ryzen 5 2600 // Mobo: Ryzen AM4 B350 GAMING PLUS ATX // RAM: 16GB Corsair Vengeance LPX DDR4 3000MHz // GPU: Gigabyte AMD Radeon RX 580 Gaming 8GB // SSD: Kingston A400 120GB // HDD: 3 x WD Blue 1TB // PSUCorsair 650M // Case: Corsair 450D // Monitor: LG Ultrawide 29" IPS

 

Plex Server:

CPU: AMD FX 8350 Black Edition // Mobo: Gigabyte - GA-78LMT-USB3 R2 Micro ATX // RAM: 16GB Corsair Vengeance DDR3 1600 MHz // GPU: GeForce GTX 670 // HDD: Seagate BarraCuda 2TB // PSU: Kolink Core Series 500W 80 Plus Certified // Case: AVP Viper Mini Tower

 

Other:

PS4 Pro // PS3 // Nintendo Switch (Pokemon edition) // Nintendo 3DS // Xbox 360 // iPhone 8 Plus // Macbook Retina 2013

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×