Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Run XP game on VM or old XP tower

Eastman51
 Share

Go to solution Solved by demonix00,

I would suggest getting some slightly newer hardware as C2D prebuilds should be available for cheap and would be compatible with windows XP which would also allow for the use of PCI-e graphics cards.

Not sure if this is the right place for this?

So I've had this old XP era gaming rig (was a prebuilt) lying around. I know it works and I've played around with it before (though Steam doesn't download games for some reason). I found my old copy of a game I used to play a lot as a kid. It only runs on XP, because DRM; and you can't run it on a VM. I tried it in VirtualBox, where on the DRM check it locks up the VM and then errors out after a while. I managed to find some Nvidia drivers for the AGP 4x GPU I have, but the game runs poorly. The thermal paste on the CPU is most likely in dire need of replacement, so I may try that and see if I can get any improvement with just that. I could also try running it on my CRT and see if the lower resolution would be beneficial as well (I did run tests at various resolutions on a 1080p display).

 

The PC is a Compaq Presario 5000 (more specifically the 5423US version: https://www.cnet.com/products/presario-5423us-p4-1-6ghz-80gb-512mb-16x-dvd-rom-16x-cdrw-56k/specs/)

It has a Pentium 4 (I'm guessing its Socket 478 based off Intel ARK, but I'm not sure).

I found a Turtle Beach sound card and put it in, found some drivers and its actually pretty good for its age. 

The PC has a GeForce2 Mx 400 (the OEM GPU). I have a GeForce 256 that I know works in the PC, but it has half the VRAM so idk if it would be any better or not.

It had a 75GB HDD when I started with it, but I added a 35GB HDD I found lying around.

Its running XP x86 SP3

The game is TrackMania Sunrise, disk is 100% scratch free.

I need to check Task Manager while the game is running to see CPU and RAM usage, not sure about checking GPU usage in XP. Not sure about checking temps for thermal throttling either, I think I tried HWmonitor and it didn't show any thermal sensors.

 

I'd like to be able to run the game, either in a VM or on an actual PC. I could try to install XP on newer hardware, or try and get the old tower to run it decently. Don't care about much else, especially with Steam ending support for XP soon.

 

I could upgrade the GPU on the old tower, but obv I would like to try and avoid that.

I found an Asus MX4000 for sale on Amazon: https://www.amazon.com/V9400-X-TD-128M-NVIDIA-GeForce/dp/B015U7OHXS/

The Asus card has 128MB of VRAM vs the 64MB of the MX 400. However, the MX 400 has a 350MHz clock vs the Asus card's 250MHz clock. VRAM or clock speed?

*note* I did all this testing a month or so ago, none of it is recent. Just found the disk again and wanted to play it, but remembered what happened last time I tried. Ideas and/or help is appreciated

Primary PC: - https://pcpartpicker.com/list/8G3tXv (Windows 10 Home)

HTPC: - https://pcpartpicker.com/list/KdBb4n (Windows 10 Home)
Server: Dell Precision T7500 - Dual Xeon X5660's, 44GB ECC DDR3, Dell Nvidia GTX 645 (Windows Server 2019 Standard)      

*SLI Rig* - i7-920, MSI-X58 Platinum SLI, 12GB DDR3, Dual EVGA GTX 260 Core 216 in SLI - https://pcpartpicker.com/list/GHw6vW (Windows 7 Pro)

HP DC7900 - Core 2 Duo E8400, 4GB DDR2, Nvidia GeForce 8600 GT (Windows Vista)

Compaq Presario 5000 - Pentium 4 1.7Ghz, 1.7GB SDR, PowerColor Radeon 9600 Pro (Windows XP x86 Pro)
Compaq Presario 8772 - Pentium MMX 200Mhz, 48MB PC66, 6GB Quantum HDD, "8GB" HP SATA SSD adapted to IDE (Windows 98 SE)

Asus M32AD - Intel i3-4170, 8GB DDR3, 250GB Seagate 2.5" HDD (converting to SSD soon), EVGA GeForce GTS 250, OEM 350W PSU (Windows 10 Core)

*Haswell Tower* https://pcpartpicker.com/list/3vw6vW (Windows 10 Home)

*ITX Box* - https://pcpartpicker.com/list/r36s6R (Windows 10 Education)

Dell Dimension XPS B800 - Pentium 3 800Mhz, RDRAM

In progress projects:

*Skylake Tower* - Pentium G4400, Asus H110

*Trash Can* - AMD A4-6300

*GPU Test Bench*

*Pfsense router* - Pentium G3220, Asrock H97m Pro A4, 4GB DDR3

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, LukeSavenije said:

well, tried windows xp on vmware yet? should work for that. if you have any other tower at least

I did try XP on VirtualBox.

2 minutes ago, KuJoe said:

I've never heard of this game but apparently there's still a community for it, people have got it working on Windows 7 here: http://www.tm-forum.com/viewtopic.php?t=24517

I think I've seen this thread before. I don't have a Windows 7 product key, so I'm not sure if I could make that work. I wonder if that trick would work in Vista or Win10?

Primary PC: - https://pcpartpicker.com/list/8G3tXv (Windows 10 Home)

HTPC: - https://pcpartpicker.com/list/KdBb4n (Windows 10 Home)
Server: Dell Precision T7500 - Dual Xeon X5660's, 44GB ECC DDR3, Dell Nvidia GTX 645 (Windows Server 2019 Standard)      

*SLI Rig* - i7-920, MSI-X58 Platinum SLI, 12GB DDR3, Dual EVGA GTX 260 Core 216 in SLI - https://pcpartpicker.com/list/GHw6vW (Windows 7 Pro)

HP DC7900 - Core 2 Duo E8400, 4GB DDR2, Nvidia GeForce 8600 GT (Windows Vista)

Compaq Presario 5000 - Pentium 4 1.7Ghz, 1.7GB SDR, PowerColor Radeon 9600 Pro (Windows XP x86 Pro)
Compaq Presario 8772 - Pentium MMX 200Mhz, 48MB PC66, 6GB Quantum HDD, "8GB" HP SATA SSD adapted to IDE (Windows 98 SE)

Asus M32AD - Intel i3-4170, 8GB DDR3, 250GB Seagate 2.5" HDD (converting to SSD soon), EVGA GeForce GTS 250, OEM 350W PSU (Windows 10 Core)

*Haswell Tower* https://pcpartpicker.com/list/3vw6vW (Windows 10 Home)

*ITX Box* - https://pcpartpicker.com/list/r36s6R (Windows 10 Education)

Dell Dimension XPS B800 - Pentium 3 800Mhz, RDRAM

In progress projects:

*Skylake Tower* - Pentium G4400, Asus H110

*Trash Can* - AMD A4-6300

*GPU Test Bench*

*Pfsense router* - Pentium G3220, Asrock H97m Pro A4, 4GB DDR3

Link to comment
Share on other sites

Link to post
Share on other sites

4 minutes ago, LukeSavenije said:

well, then I suggest you try vmware

Well, in recent developments, its partially working in VirtualBox right now. I gave the VM 1 more CPU core and it actually did the DRM check. But once the game loads it has a blank screen, there is sound.

Primary PC: - https://pcpartpicker.com/list/8G3tXv (Windows 10 Home)

HTPC: - https://pcpartpicker.com/list/KdBb4n (Windows 10 Home)
Server: Dell Precision T7500 - Dual Xeon X5660's, 44GB ECC DDR3, Dell Nvidia GTX 645 (Windows Server 2019 Standard)      

*SLI Rig* - i7-920, MSI-X58 Platinum SLI, 12GB DDR3, Dual EVGA GTX 260 Core 216 in SLI - https://pcpartpicker.com/list/GHw6vW (Windows 7 Pro)

HP DC7900 - Core 2 Duo E8400, 4GB DDR2, Nvidia GeForce 8600 GT (Windows Vista)

Compaq Presario 5000 - Pentium 4 1.7Ghz, 1.7GB SDR, PowerColor Radeon 9600 Pro (Windows XP x86 Pro)
Compaq Presario 8772 - Pentium MMX 200Mhz, 48MB PC66, 6GB Quantum HDD, "8GB" HP SATA SSD adapted to IDE (Windows 98 SE)

Asus M32AD - Intel i3-4170, 8GB DDR3, 250GB Seagate 2.5" HDD (converting to SSD soon), EVGA GeForce GTS 250, OEM 350W PSU (Windows 10 Core)

*Haswell Tower* https://pcpartpicker.com/list/3vw6vW (Windows 10 Home)

*ITX Box* - https://pcpartpicker.com/list/r36s6R (Windows 10 Education)

Dell Dimension XPS B800 - Pentium 3 800Mhz, RDRAM

In progress projects:

*Skylake Tower* - Pentium G4400, Asus H110

*Trash Can* - AMD A4-6300

*GPU Test Bench*

*Pfsense router* - Pentium G3220, Asrock H97m Pro A4, 4GB DDR3

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Eastman51 said:

Well, in recent developments, its partially working in VirtualBox right now. I gave the VM 1 more CPU core and it actually did the DRM check. But once the game loads it has a blank screen, there is sound.

yeah, sounds like virtualbox is trying to run a gpu that it doesn't know. once again, just try it. it's free software

Link to comment
Share on other sites

Link to post
Share on other sites

8 minutes ago, LukeSavenije said:

yeah, sounds like virtualbox is trying to run a gpu that it doesn't know. once again, just try it. it's free software

*groans* gotta find my XP disk. At least I bookmarked the online activation site

Primary PC: - https://pcpartpicker.com/list/8G3tXv (Windows 10 Home)

HTPC: - https://pcpartpicker.com/list/KdBb4n (Windows 10 Home)
Server: Dell Precision T7500 - Dual Xeon X5660's, 44GB ECC DDR3, Dell Nvidia GTX 645 (Windows Server 2019 Standard)      

*SLI Rig* - i7-920, MSI-X58 Platinum SLI, 12GB DDR3, Dual EVGA GTX 260 Core 216 in SLI - https://pcpartpicker.com/list/GHw6vW (Windows 7 Pro)

HP DC7900 - Core 2 Duo E8400, 4GB DDR2, Nvidia GeForce 8600 GT (Windows Vista)

Compaq Presario 5000 - Pentium 4 1.7Ghz, 1.7GB SDR, PowerColor Radeon 9600 Pro (Windows XP x86 Pro)
Compaq Presario 8772 - Pentium MMX 200Mhz, 48MB PC66, 6GB Quantum HDD, "8GB" HP SATA SSD adapted to IDE (Windows 98 SE)

Asus M32AD - Intel i3-4170, 8GB DDR3, 250GB Seagate 2.5" HDD (converting to SSD soon), EVGA GeForce GTS 250, OEM 350W PSU (Windows 10 Core)

*Haswell Tower* https://pcpartpicker.com/list/3vw6vW (Windows 10 Home)

*ITX Box* - https://pcpartpicker.com/list/r36s6R (Windows 10 Education)

Dell Dimension XPS B800 - Pentium 3 800Mhz, RDRAM

In progress projects:

*Skylake Tower* - Pentium G4400, Asus H110

*Trash Can* - AMD A4-6300

*GPU Test Bench*

*Pfsense router* - Pentium G3220, Asrock H97m Pro A4, 4GB DDR3

Link to comment
Share on other sites

Link to post
Share on other sites

29 minutes ago, KuJoe said:

Making headway with VMs, so we'll see

Primary PC: - https://pcpartpicker.com/list/8G3tXv (Windows 10 Home)

HTPC: - https://pcpartpicker.com/list/KdBb4n (Windows 10 Home)
Server: Dell Precision T7500 - Dual Xeon X5660's, 44GB ECC DDR3, Dell Nvidia GTX 645 (Windows Server 2019 Standard)      

*SLI Rig* - i7-920, MSI-X58 Platinum SLI, 12GB DDR3, Dual EVGA GTX 260 Core 216 in SLI - https://pcpartpicker.com/list/GHw6vW (Windows 7 Pro)

HP DC7900 - Core 2 Duo E8400, 4GB DDR2, Nvidia GeForce 8600 GT (Windows Vista)

Compaq Presario 5000 - Pentium 4 1.7Ghz, 1.7GB SDR, PowerColor Radeon 9600 Pro (Windows XP x86 Pro)
Compaq Presario 8772 - Pentium MMX 200Mhz, 48MB PC66, 6GB Quantum HDD, "8GB" HP SATA SSD adapted to IDE (Windows 98 SE)

Asus M32AD - Intel i3-4170, 8GB DDR3, 250GB Seagate 2.5" HDD (converting to SSD soon), EVGA GeForce GTS 250, OEM 350W PSU (Windows 10 Core)

*Haswell Tower* https://pcpartpicker.com/list/3vw6vW (Windows 10 Home)

*ITX Box* - https://pcpartpicker.com/list/r36s6R (Windows 10 Education)

Dell Dimension XPS B800 - Pentium 3 800Mhz, RDRAM

In progress projects:

*Skylake Tower* - Pentium G4400, Asus H110

*Trash Can* - AMD A4-6300

*GPU Test Bench*

*Pfsense router* - Pentium G3220, Asrock H97m Pro A4, 4GB DDR3

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, LukeSavenije said:

yeah, sounds like virtualbox is trying to run a gpu that it doesn't know. once again, just try it. it's free software

On vmware the game thinks its not even running XP. VirtualBox doesn't pass DRM checks anymore either. idk what happened

Primary PC: - https://pcpartpicker.com/list/8G3tXv (Windows 10 Home)

HTPC: - https://pcpartpicker.com/list/KdBb4n (Windows 10 Home)
Server: Dell Precision T7500 - Dual Xeon X5660's, 44GB ECC DDR3, Dell Nvidia GTX 645 (Windows Server 2019 Standard)      

*SLI Rig* - i7-920, MSI-X58 Platinum SLI, 12GB DDR3, Dual EVGA GTX 260 Core 216 in SLI - https://pcpartpicker.com/list/GHw6vW (Windows 7 Pro)

HP DC7900 - Core 2 Duo E8400, 4GB DDR2, Nvidia GeForce 8600 GT (Windows Vista)

Compaq Presario 5000 - Pentium 4 1.7Ghz, 1.7GB SDR, PowerColor Radeon 9600 Pro (Windows XP x86 Pro)
Compaq Presario 8772 - Pentium MMX 200Mhz, 48MB PC66, 6GB Quantum HDD, "8GB" HP SATA SSD adapted to IDE (Windows 98 SE)

Asus M32AD - Intel i3-4170, 8GB DDR3, 250GB Seagate 2.5" HDD (converting to SSD soon), EVGA GeForce GTS 250, OEM 350W PSU (Windows 10 Core)

*Haswell Tower* https://pcpartpicker.com/list/3vw6vW (Windows 10 Home)

*ITX Box* - https://pcpartpicker.com/list/r36s6R (Windows 10 Education)

Dell Dimension XPS B800 - Pentium 3 800Mhz, RDRAM

In progress projects:

*Skylake Tower* - Pentium G4400, Asus H110

*Trash Can* - AMD A4-6300

*GPU Test Bench*

*Pfsense router* - Pentium G3220, Asrock H97m Pro A4, 4GB DDR3

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, Eastman51 said:

On vmware the game thinks its not even running XP. VirtualBox doesn't pass DRM checks anymore either. idk what happened

well, then i don't know anymore. maybe @NelizMastr knows?

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, Eastman51 said:

Well, in recent developments, its partially working in VirtualBox right now. I gave the VM 1 more CPU core and it actually did the DRM check. But once the game loads it has a blank screen, there is sound.

Graphics and virtualization don't really mix that well. Games that typically work well on a VM are games running in 2D or DirectDraw (such as Age of Empires 1/2). If 3D acceleration is required, be prepared for a shit show in a lot of games. 

 

Might be better to just go for physical hardware or at least play with the GPU settings in virtual box. I'm not sure XP has the option to toggle 3D acceleration, though.

PC Specs - AMD Ryzen 5 5600X MSI B550M Mortar 16GB Crucial Ballistix DDR4-3600 @ CL15 - RX5700XT 660p 1TBGB & 256GB 600p Fractal Define Mini C CM V550 - Pop!_OS 20.04

 

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, NelizMastr said:

Graphics and virtualization don't really mix that well. Games that typically work well on a VM are games running in 2D or DirectDraw (such as Age of Empires 1/2). If 3D acceleration is required, be prepared for a shit show in a lot of games. 

 

Might be better to just go for physical hardware or at least play with the GPU settings in virtual box. I'm not sure XP has the option to toggle 3D acceleration, though.

3D acceleration is there and enabled. blank screen is a mystery, may be the VM thing. But I can't even clear DRM anymore, so idk what is going on

Primary PC: - https://pcpartpicker.com/list/8G3tXv (Windows 10 Home)

HTPC: - https://pcpartpicker.com/list/KdBb4n (Windows 10 Home)
Server: Dell Precision T7500 - Dual Xeon X5660's, 44GB ECC DDR3, Dell Nvidia GTX 645 (Windows Server 2019 Standard)      

*SLI Rig* - i7-920, MSI-X58 Platinum SLI, 12GB DDR3, Dual EVGA GTX 260 Core 216 in SLI - https://pcpartpicker.com/list/GHw6vW (Windows 7 Pro)

HP DC7900 - Core 2 Duo E8400, 4GB DDR2, Nvidia GeForce 8600 GT (Windows Vista)

Compaq Presario 5000 - Pentium 4 1.7Ghz, 1.7GB SDR, PowerColor Radeon 9600 Pro (Windows XP x86 Pro)
Compaq Presario 8772 - Pentium MMX 200Mhz, 48MB PC66, 6GB Quantum HDD, "8GB" HP SATA SSD adapted to IDE (Windows 98 SE)

Asus M32AD - Intel i3-4170, 8GB DDR3, 250GB Seagate 2.5" HDD (converting to SSD soon), EVGA GeForce GTS 250, OEM 350W PSU (Windows 10 Core)

*Haswell Tower* https://pcpartpicker.com/list/3vw6vW (Windows 10 Home)

*ITX Box* - https://pcpartpicker.com/list/r36s6R (Windows 10 Education)

Dell Dimension XPS B800 - Pentium 3 800Mhz, RDRAM

In progress projects:

*Skylake Tower* - Pentium G4400, Asus H110

*Trash Can* - AMD A4-6300

*GPU Test Bench*

*Pfsense router* - Pentium G3220, Asrock H97m Pro A4, 4GB DDR3

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, Eastman51 said:

3D acceleration is there and enabled. blank screen is a mystery, may be the VM thing. But I can't even clear DRM anymore, so idk what is going on

Weird, indeed. I don't have much experience with this situation myself, so it's hard to pinpoint the issue. Hmm, perhaps I should try it later today or tonight. I have plenty of resources to throw some VMs in the mix haha :) 

PC Specs - AMD Ryzen 5 5600X MSI B550M Mortar 16GB Crucial Ballistix DDR4-3600 @ CL15 - RX5700XT 660p 1TBGB & 256GB 600p Fractal Define Mini C CM V550 - Pop!_OS 20.04

 

Link to comment
Share on other sites

Link to post
Share on other sites

I would suggest getting some slightly newer hardware as C2D prebuilds should be available for cheap and would be compatible with windows XP which would also allow for the use of PCI-e graphics cards.

Link to comment
Share on other sites

Link to post
Share on other sites

28 minutes ago, demonix00 said:

I would suggest getting some slightly newer hardware as C2D prebuilds should be available for cheap and would be compatible with windows XP which would also allow for the use of PCI-e graphics cards.

Thats certainly a possibility. I was planning on heading to my school's e-waste bin tomorrow, so I'll see if I can salvage anything around that era

Primary PC: - https://pcpartpicker.com/list/8G3tXv (Windows 10 Home)

HTPC: - https://pcpartpicker.com/list/KdBb4n (Windows 10 Home)
Server: Dell Precision T7500 - Dual Xeon X5660's, 44GB ECC DDR3, Dell Nvidia GTX 645 (Windows Server 2019 Standard)      

*SLI Rig* - i7-920, MSI-X58 Platinum SLI, 12GB DDR3, Dual EVGA GTX 260 Core 216 in SLI - https://pcpartpicker.com/list/GHw6vW (Windows 7 Pro)

HP DC7900 - Core 2 Duo E8400, 4GB DDR2, Nvidia GeForce 8600 GT (Windows Vista)

Compaq Presario 5000 - Pentium 4 1.7Ghz, 1.7GB SDR, PowerColor Radeon 9600 Pro (Windows XP x86 Pro)
Compaq Presario 8772 - Pentium MMX 200Mhz, 48MB PC66, 6GB Quantum HDD, "8GB" HP SATA SSD adapted to IDE (Windows 98 SE)

Asus M32AD - Intel i3-4170, 8GB DDR3, 250GB Seagate 2.5" HDD (converting to SSD soon), EVGA GeForce GTS 250, OEM 350W PSU (Windows 10 Core)

*Haswell Tower* https://pcpartpicker.com/list/3vw6vW (Windows 10 Home)

*ITX Box* - https://pcpartpicker.com/list/r36s6R (Windows 10 Education)

Dell Dimension XPS B800 - Pentium 3 800Mhz, RDRAM

In progress projects:

*Skylake Tower* - Pentium G4400, Asus H110

*Trash Can* - AMD A4-6300

*GPU Test Bench*

*Pfsense router* - Pentium G3220, Asrock H97m Pro A4, 4GB DDR3

Link to comment
Share on other sites

Link to post
Share on other sites

On 12/4/2018 at 7:16 PM, demonix00 said:

I would suggest getting some slightly newer hardware as C2D prebuilds should be available for cheap and would be compatible with windows XP which would also allow for the use of PCI-e graphics cards.

I got a hold of a C2D machine today and it has a dedicated Radeon card, so I think I'll be set once I find some drivers and install the OS

Primary PC: - https://pcpartpicker.com/list/8G3tXv (Windows 10 Home)

HTPC: - https://pcpartpicker.com/list/KdBb4n (Windows 10 Home)
Server: Dell Precision T7500 - Dual Xeon X5660's, 44GB ECC DDR3, Dell Nvidia GTX 645 (Windows Server 2019 Standard)      

*SLI Rig* - i7-920, MSI-X58 Platinum SLI, 12GB DDR3, Dual EVGA GTX 260 Core 216 in SLI - https://pcpartpicker.com/list/GHw6vW (Windows 7 Pro)

HP DC7900 - Core 2 Duo E8400, 4GB DDR2, Nvidia GeForce 8600 GT (Windows Vista)

Compaq Presario 5000 - Pentium 4 1.7Ghz, 1.7GB SDR, PowerColor Radeon 9600 Pro (Windows XP x86 Pro)
Compaq Presario 8772 - Pentium MMX 200Mhz, 48MB PC66, 6GB Quantum HDD, "8GB" HP SATA SSD adapted to IDE (Windows 98 SE)

Asus M32AD - Intel i3-4170, 8GB DDR3, 250GB Seagate 2.5" HDD (converting to SSD soon), EVGA GeForce GTS 250, OEM 350W PSU (Windows 10 Core)

*Haswell Tower* https://pcpartpicker.com/list/3vw6vW (Windows 10 Home)

*ITX Box* - https://pcpartpicker.com/list/r36s6R (Windows 10 Education)

Dell Dimension XPS B800 - Pentium 3 800Mhz, RDRAM

In progress projects:

*Skylake Tower* - Pentium G4400, Asus H110

*Trash Can* - AMD A4-6300

*GPU Test Bench*

*Pfsense router* - Pentium G3220, Asrock H97m Pro A4, 4GB DDR3

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×