Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Asus ROG G751JL Laptop Battery Problem

Cereal5
 Share

Hey all,

 

I have an Asus ROG G751JL laptop, with an i7-4720HQ, 16GB RAM, 1TB HDD, GTX 965M (link to asus webpage). I've had this problem with my laptop for quite some time now. The battery in my laptop is not "recognized" by the laptop itself, and so it will only work when plugged in. Also, obviously, it will shut down when unplugged. I've done some googling and it seems to unfortunately be a not-so-uncommon issue, but most of the forum threads I've found don't lead to solutions. The laptop was purchased mid 2015, and I've been using it pretty much ever since (not so much recently, but I take it with me when on trips/vacations). There was one thing I haven't tried, and that's to take out the battery, start it up, uninstall all battery related drivers and such from device manager, then plug the battery back in and let it update itself and such. Has anyone had this problem or something similar? The laptop is out of warranty, and was when this problem started, and Asus recently quoted me ~$650, which is over half the price of the laptop when it was new back in 2015 ($1200). I'd rather just get a newer laptop than pay that, but I don't really have the need at the moment for one, so I'd like to get this figured out if possible. Thanks.

My Build, v2.1 --- CPU: i7-8700K @ 5.2GHz/1.288v || MoBo: Asus ROG STRIX Z390-E Gaming || RAM: 4x4GB G.SKILL Ripjaws 4 2666 14-14-14-33 || Cooler: Custom Loop || GPU: EVGA GTX 1080 Ti SC Black, on water || PSU: EVGA G2 850W || Case: Corsair 450D || SSD: 850 Evo 250GB, Intel 660p 2TB || Storage: WD Blue 2TB || G502 & Glorious PCGR Fully Custom 80% Keyboard || MX34VQ, PG278Q, PB278Q

Audio --- Headphones: Massdrop x Sennheiser HD 6XX || Amp: Schiit Audio Magni 3 || DAC: Schiit Audio Modi 3 || Mic: Blue Yeti

 

[Under Construction]

 

My Truck --- 2002 F-350 7.3 Powerstroke || 6-speed

My Car --- 2006 Mustang GT || 5-speed || BBK LTs, O/R X, MBRP Cat-back || BBK Lowering Springs, LCAs || 2007 GT500 wheels w/ 245s/285s

 

The Experiment --- CPU: i5-3570K @ 4.0 GHz || MoBo: Asus P8Z77-V LK || RAM: 16GB Corsair 1600 4x4 || Cooler: CM Hyper 212 Evo || GPUs: Asus GTX 750 Ti, || PSU: Corsair TX750M Gold || Case: Thermaltake Core G21 TG || SSD: 840 Pro 128GB || HDD: Seagate Barracuda 2TB

 

R.I.P. Asus X99-A motherboard, April 2016 - October 2018, may you rest in peace. 5820K, if I ever buy you a new board, it'll be a good one.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×