Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Built my first computer. Somethings wrong! HELP!

Just built my first computer today and on my first boot I knew something wasn’t right. My RAM was displayed at 2133mHz I have 2666mHz. My graphics card 1070 ti was no where to be seen. Same with my 500gb m.2 ssd. Everything in my computer is NEW except 2 drives that I took from my old PC. One 128gb SSD with windows on it and one 1tb harddrive. I ignored the problems and moved on, booting up from my windows drive. Windows starts and I log in but internet connection is displayed with an X. I check and it says that it cant find a properly installed NIC? 

 

If anyone knows how to fix one or all of these problems it would be appreciated.

 

I dont know if I plugged something in the wrong spot which Im pretty sure I didn’t or if I broke the motherboard somehow. I’ve also done a cleaninstall on windows!

 

spex: i7 8700

motherboard: asus rog strix b 360f gaming

RAM: corsair vengeance 2x8gb 2666mHz

graphics card: msi 1070ti gaming 8gb

ssd: samsung 970 evo nvme M.2 500gb

ssd: lenovo 128 gb 

harddrive: wd blue 1tb

PSU: corsair cx650M

cooler: corsair H100x

 

Thanks you!! 

 

Link to comment
Share on other sites

Link to post
Share on other sites

1) enable xmp

2) connect the drives to different sata ports, they disable some sata ports when using m.2

3) download the intel drivers on their website

Link to comment
Share on other sites

Link to post
Share on other sites

Often RAM won't boots by default. That's an easy fix, but we'll leave that for last.

M.2s can also have problems on boot, but the problem to fix first is the GPU.

 

Have you tried connecting the monitor to both the GPU and the integrated graphics?

Are all the power connectors connect (Most likly 2)?

Fan Comparisons          F@H          PCPartPicker         Analysis of Market Trends (Coming soon? Never? Who knows!)

Designing a mITX case. Working on aluminum prototypes.

Open for intern / part-time. Good at maths, CAD and airflow stuff. Dabbled with Python.

Please fill out this form! It helps a ton! https://linustechtips.com/main/topic/841400-the-poll-to-end-all-polls-poll/

Link to comment
Share on other sites

Link to post
Share on other sites

Thanks for the respone! 

 

I can’t download drivers because I can’t connect to the internet... 

 

I think RAM and GPU problems are solved now thanks

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×