Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

SSD shows on BIOS and device manager, but not on disk manager or diskpart

Go to solution Solved by martin1592,

Solution here

I've been at this for hours... halp

 

I'm trying to install a Samsung 860, my PC already has a Samsung 960 M.2 (with Windows) and a random 4TB HDD.

 

The SSD appears on BIOS and device manager, but it does NOT appear on disk manager or diskpart or other software like speccy.

 

I've tried:

- Different SATA cables and connectors (even with the ones the current HDD is using which I know work fine).

- Updating BIOS, any related drivers, reinstalling Windows (it didn't show up on the windows installation software either).

- Completed a memory diagnostic test (someone said it worked for him but didnt for me)

- Clear cmos

 

I dont know what to do anymore... what am I missing?

 

Specs:

i7 8700K 

1080Ti 

32GB RAM

AORUS Z370 Ultra Gaming

Windows 10 Education

 

Any ideas? I'll provide any extra information if needed.

 

Thanks in advance!

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×