Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

spyder

Member
  • Content Count

    446
  • Joined

  • Last visited

Awards

This user doesn't have any awards

1 Follower

About spyder

  • Title
    Member

Profile Information

  • Location
    London, United Kingdom
  • Gender
    Male
  • Interests
    Technology, system building, PC gaming.
  • Biography
    The average gamer.
  • Occupation
    Student

System

  • CPU
    Intel core i5 4690K
  • Motherboard
    Gigabyte GA-Z97PD3
  • RAM
    16GB HyperX Fury 1600Mhz
  • GPU
    Asus Strix Geforce GTX 970
  • Case
    Corsair 200R with Window side panel
  • Storage
    1TB Seagate SSHD
  • PSU
    EVGA 650W G1
  • Display(s)
    Samsung S24D590L
  • Cooling
    Cooler master Hyper 212 Evo
  • Keyboard
    Logitech K750
  • Mouse
    Logitech MX Performance
  • Sound
    Logitech Z200
  • Operating System
    Windows 10 Pro

Recent Profile Visitors

802 profile views
  1. Unfortunately that's going to be a bit difficult. I was thinking along those lines too, you see the graphics card has a little indicator light which turns on and stays on as soon as I switch the psu power on. That means power must be flowing in some way.
  2. Would like to try but need to be 100 percent sure and I don't want to end up spending money on unnecessary parts in the event something else is causing the fault.
  3. No overclock was ever set. Cant boot at all therefore go into bios, no post codes hard drive doesn't spin either. I was thinking along those lines too, possibly dead psu but don't have a spare on site, might have to order a new one or even rma it. System has been running fine up until now. It has adequate cooling solution, everything was running at stock, no overclcok was ever applied. All parts look physically fine and no obvious signs of damage.
  4. Hello All, Little background: I built my own gaming rig back in the summer of 2015. Some specs: i5-4690k hyper 212 evo 16gb hyperx ram gtx 970 strix gigabyte z97p-d3 mobo evga 650 g1 psu 1tb hybrid drive. Problem: Whilst my brother was playing games on the machine, it suddenly switched off completely. When I hit the power button, the cpu fan and gpu fan spin briefly for one second and then turn off. Solutions I have tried so far: - Double checked all the power cables from t
  5. The last bit is 100% true, its god awful around here especially either during the morning rush hour or early evening especially right after school finishes (surrounded in my area) I have experienced being in traffic, yeah it does sort of become a pain when all your doing is creeping forward for like half an hour.
  6. In the next couple of months I will be obtaining my first car. It's going to be a hatchback with a small engine size. My only question is whether it should be an automatic or manual? I have driven a manual when I was learning how to drive, also driven my sibling's BMW which is a manual under temporary insurance cover. I only had less than 2 mins experience in an automatic (friend's car) but it did feel kind of weird that I don't need to change gears or use my left foot. I'm slightly leaning towards an auto based on the fact that its easier to move along a hill rather t
  7. I hate living in London, car insurance is sky high, like almost quadruple the price of the cars I'm looking at, why can't we just insure the car and let anyone drive it like most countries, instead companies get gready and want to insure every single driver
  8. @LinusTech @Slick @nicklmg Seems someone downloaded the vessel exclusive and uploaded it to a file sharing site, followed by leaking the link to the comment section of the latest YT video.
  9. It is a HDMI splitter, they receive power by connecting to the HDMI port of your TV/monitor.
  10. I upgraded a Samsung laptop from Windows 8.1 to 10 through downloading the Windows 10 tool from Microsoft's website. After the update was done, it appears the start menu doesn't work at all. If I click it or enter the Windows key, nothing happens, I can't even use the search either. I tried through powershell running the sfc /scannow command. It freezes at 23% verification. Shall I just revert it back to Windows 8 and call it a day?
  11. thanks, it says wear level is 6% and the charge level is 4%
  12. Just been told a year so the battery has gone to hell.
  13. I think the battery is completely gone since I took the charger off, the percentage fell from 19, 18, 6, 5% within the space of 2 or 3 mins,
  14. I have a Dell Latitude E5430 on the desk which has just been given to me. The laptop was completely dead for some time since it has been in storage. I had a dell charger on hand luckily, plugged it in, booted it up, the laptop was charging until it reached 19%. Now it says "Plugged in, not charging" - Any solutions?
×