Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

ChickenLittle1917

Member
  • Content Count

    12
  • Joined

  • Last visited

Awards

This user doesn't have any awards

About ChickenLittle1917

  • Title
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. My old PSU was an EVGA 600w 80+ bronze and a couple of days before it died the power went out. So I'm assuming that's was killed it but I'm not sure.
  2. So I recently had a PSU die and after a lot of trouble I got my PC turning on again, but now I'm getting no display and a white VGA light on my motherboard. The fans on the GPU are spinning just no display. I have cleared the bios and can't find anything about my gpu in the bios. I have tried swapping the cable connecting the gpu to the power supply. I've tried using different pcie slot. If it is in fact dead how do I go about contacting Nvidia about it there website isn't the best. My specs CPU - Ryzen 5 3600 GPU - RTX 3070 FE
  3. So I found the issue something in my case was shorting the motherboard and forcing it to turn off. Still don't know what it was but it is turning on now. Thanks for all the help.
  4. That's the only thing left I have to do, unfortunately I don't want to spend $1000 to get a new one. That's what I think it is but I'm hoping someone else has a different answer that works.
  5. No it only turns on for half a second.
  6. No video output it turns on for half a second then dies again.
  7. I am once again asking for help from this forum. My original problem was that my PC was not turning on so I tested my PSU and found that it was dead so I replaced that, tried again to the same results, it would turn on for a split second then off again, but with the new PSU the keyboard lights up and stays lit up. So this time I got a new motherboard set everything up and the same thing is happening. I am extremely frustrated and $300 down I would love it if someone who knows a thing or two helps me. Specs CPU - Ryzen 5 3600 GPU - Geforce RTX 3070 FE RAM - 16 Gb G.
  8. It handled it fine for about 6 months or how ever long the 3070 has been out. So I don't know why it would chose now to give up.
  9. Thanks for your reply! Im starting to think it took the motherboard with it, I contacted EVGA and told them the situation hopefully they can replace the motherboard if it is the case.
  10. Thank You! I was thinking it might be the motherboard but I wasnt sure Specs are CPU - Ryzen 5 3600 GPU - RTX 3070 Motherboard - MSI B450 Gaming plus max RAM - G.Skill Aegis (2x8) 3000 DDR4 Old PSU - EVGA 600W 80+ bronze New PSU - EVGA 850W 80+ gold and a few different types of storage.
  11. My old power supply was an EVGA 600w 80+ bronze, the new one is an EVGA 850w 80+ gold Other specs are CPU - Ryzen 5 3600 GPU - RTX 3070 Motherboard - MSI B450 Gaming plus max RAM - G.Skill Aegis (2x8) 3000 DDR4 and a few different types of storage.
  12. So a couple days ago while I was playing a game on my PC, and it just shut off randomly and when I would do a reset it would turn on for a split second then off again. I tested the power supply and it was shot so I just replaced it and I having the same issue it's just this time the keyboard lights up and stays lit up. Does anyone know what could be wrong? Other specs are CPU - Ryzen 5 3600 GPU - RTX 3070 Motherboard - MSI B450 Gaming plus max RAM - G.Skill Aegis (2x8) 3000 DDR4 Old PSU - EVGA 600w 80+ bronze NEW PSU - EVGA 850w 80+ gold and a f
×