Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

NikoBellii

Member
  • Content Count

    7
  • Joined

  • Last visited

Awards

This user doesn't have any awards

About NikoBellii

  • Title
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Have you got any idea on how to fix it or if it's even possible?
  2. I've never seen a blower style RTX card before in my life
  3. I would call that a rip-off. I've put together a better price to preformance build in around 5 minutes even with the insane prices of GPU's. https://pcpartpicker.com/user/NikoBellii/saved/#view=K47dHx Check out my list and maybe wait for some more replies as I am certainly not the best at this but I know something. And let me tell you, that part list is a extreme rip-off.
  4. It should work fine but don't quote me on that as I have never tried it myself.
  5. Or if you're on a REAL budget go for a GT 210. It's a terrific card but for stuff like YouTube it will be fine.
  6. I don't have any other PC. Before I was using a laptop just like my whole family. The friend that borrowed me it was using it for a couple of years until he decided to upgrade pc so he sold his pc along with this GPU. But after the pc got to the new owner he got a call complaining that the pc wasn't working. When he got the computer back it turned out some cable wasn't plugged in properly but he didn't specifically tell me which cable. After plugging in that cable the pc worked fine but it would sometimes boot in a weird resolution so he decided to get a repair shop to fix it. The repair shop
  7. Hi, Recently I've put together my first PC and I have quite a severe problem. If this is any help, these are my specs: - Ryzen 5 1600AF - Gigabyte Aorus Elite B450 V2 - 16GB of DDR4 ram (idk what brand specifically) - A 600W 80+ Bronze PSU from SileniumPC And a MSI TwinFrozer GTX 770 2GB my friend gave to use me untill GPUs are back to their MSRP. But the problem is that it isn't displaying any video. The fans are spinning and the PC works because I'm using it right now to write and post this but I'm using a Geforce GT 210 to do so. I think that I do
×