Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

IneedPchelpASAP

Member
  • Content Count

    8
  • Joined

  • Last visited

Awards

This user doesn't have any awards

About IneedPchelpASAP

  • Title
    Newbie
  • Birthday Sep 13, 2005

Contact Methods

  • Discord
    Chris Peacock#5815
  • PlayStation Network
    Not-_-A-_-Sweat

Profile Information

  • Location
    PA
  • Gender
    Male
  • Biography
    I play R6
  • Occupation
    FastFood

System

  • CPU
    Ryzen 5 3600
  • Motherboard
    MPG X570 Gaming Plus
  • RAM
    2 8GB
  • GPU
    Nvidia 3080
  • Case
    Rosewill ATX midtower
  • Storage
    M.2 240GB and Barracuda 2TB
  • PSU
    Evga 650W
  • Display(s)
    TLC tv
  • Cooling
    4 “120”mm
  • Keyboard
    SteelSeries
  • Mouse
    Razor
  • Sound
    PHOINIKAS External sound card
  • Operating System
    Windows 10
  • Laptop
    School chromebook lol
  • Phone
    iPhone 11

Recent Profile Visitors

61 profile views
  1. I’m not sure if I can reinstall because when I try my screen dims and shows Home Screen then nothing pops up just the install media web page...
  2. It’s a new pc with some games installed and windows is on the ssd with games. I tried to put windows on the m.2 so it would boot faster. I also can’t close anything by hitting the x i have to use task bar.
  3. My windows is really slow and applications don’t close when I hit the x. It might be because I have windows on a ssd and an m.2 but idk how to delete of one .
  4. It will light up the first 10 seconds on every boot then will dim and a fan on the mother board turns off when it dims. It’s not the cpu fan.
  5. I have a 650w Evga power supply, two 8gb of ram, a MPG X570 gaming plus motherboard, ryzen 5 3600 cpu, and my gpu isn’t in yet because I’m waiting on the 30 series. Everything was new in the pc.
  6. It is my first time building a pc and I hooked everything up and started it. Everything was fine but then I shut it of then back on and the fan power and rgb was low/dim. I’m not sure if it’s the power supply or what. Power supply is Evga 650 W. I have no gpu or monitor hooked up yet.
×