Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

bigbadplayer33

Member
  • Content Count

    9
  • Joined

  • Last visited

Awards

This user doesn't have any awards

About bigbadplayer33

  • Title
    Newbie

System

  • CPU
    i7 5820k @ 4.4Ghz
  • RAM
    16GB @ 2666MHz
  • GPU
    GTX 980 MSI

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hello, I have an M65 PRO RGB mouse and since a couple days ago it is constantly lagging, freezing and even disconnecting entirely from my pc (like it stops responding and the lights turn off and i hear the windows sound). Im on windows 10, version 1903 and have so far tried: - Using different usb ports (back mobo ports, front ports and even my keyboard's usb port) - Turning off the power saving setting in device management. - reinstalling the mouse & the drivers and checking for driver updates. - Tried using it on my mac, and the same thing happens m
  2. Sorry, not familiar with that term. Its the corsair vengeance RGB PRO 16gb (2x8gb)
  3. Hello, I am adding some RAM to my system and im asking myself is it worth paying an extra £20 to go from 3200MHz to 3600MHz ?
  4. Anyone got any 29 inch, 21:9 high refresh rate monitors that they'd recommend?
  5. It just appears low resolution, like using watching 720p on a 1080p monitor. When I plug in my windows PC, everything (text, images, literally everything) is so much sharper and nicer. It makes text hard to read and lines which are meant to be sharp appear soft and pixelated. If you must have a pic I can send one later.
  6. Laptop has resolution: 2,560 x 1,600 Res of external monitor: 2560×1080 and the mbp is set to only use the external monitor so it only has to drive that.
  7. Sorry for not including all that info, but here it is: USB-C to HDMI adaptor, with a HDMI to HDMI cable. Its going into a 21:9 LG Ultrawide monitor.
  8. Connected a 2017 MBP (Touchbar, 4x thunderbolt) to an external monitor, everything looks low resolution and blurry. Does anyone know of any fixes? The resolution appears correctly on mac os, and I have 'Default for Display' enabled. EDIT: Heres some information about the setup: USB-C to HDMI adaptor, with a HDMI to HDMI cable. Its going into a 21:9 LG Ultrawide monitor.
×