Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Dancam38

Member
  • Content Count

    280
  • Joined

  • Last visited

Awards

This user doesn't have any awards

About Dancam38

  • Title
    Member

System

  • CPU
    ryzen 5 3600
  • Motherboard
    Mai b450 gaming plus max
  • RAM
    32gb corsair vengeance ddr4 3200mhz ram
  • GPU
    Nvidia rtx 2070 SUPER
  • Case
    cooler master td500
  • Storage
    wd black snd750, wd blue 3tb hdd
  • PSU
    corsair 750watt bronze+
  • Cooling
    Kraken x53 aio

Recent Profile Visitors

599 profile views
  1. hwinfo HWiNFO - Free System Information, Monitoring and Diagnostics
  2. send me a picture so i can see if its fixable
  3. Were does this plug in
  4. the front power butten isint working on the dell xps 400 lllllli think its unplugged do you guys know what the conector for it looks like and were it could be i linked the user guide xps_400.pdf
  5. I just installed a new psu into my dell optiplex and a gtx 650 and I’m getting a front I error plz help
  6. i accidently while the pc was off but plugged into the wall removed the atx 24pin with nrealising it was plugged in it seems fine do u think im ok
  7. i just put a gtx 650 into a dell optiplex and i think its fan is very quietly rattleing the gpu fan is this something i should be concerned about i can barrly hear it
  8. The 6pin connector for the 650 this pc doesent have molex so I can’t use a splitter and a sata to 6pin is a fire hazard
  9. The 790 doesn’t use proprietary connectors it’s all standers atx
×