Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Darknessnite08

Member
  • Content Count

    3
  • Joined

  • Last visited

Awards

This user doesn't have any awards

About Darknessnite08

  • Title
    Newbie
  1. I remembered that we have a wifi adapter, i'll try connecting it to the computer, and test it for a while. If it doesn't disconnect while playing then it could be the motherboard, right ?
  2. As for hardware: Motherboard is GA-970A-DS3P, CPU AMD FX 8350, GPU Nvidia geforce gtx 960 (GV-N960G1 GAMING-4GD), RAM HyperX Kingston Fury 8GB 1866MHz DDR3, POWER SUPPLY EVGA 0600-K1 80 PLUS Bronze, 24-pin ATX, 120mm, 600W. Is that enough ? And by network setup you mean how's my PC connected ? if so, the computer it's connected to a Tp-link 150mbps Tl-wr741nd 1 Antenna which is connected via Ethernet cable to the main router which is an EnGenius Wireless cloud router (2.4 GHz Wireless N300 IoT Cloud Router w/Built-In Switch). It's worth mentioning that my laptop's OS
  3. Hi everyone, I've been having a problem regarding my computer's connection and i don't know how to fix the problem. Sometimes when i launch applications like Steam, Battle net or even League Of Legends, the application says that there is no connection at all, but then i launch google and try looking for something and i do have connection. For example about three days ago i played with some friends LOL while chatting with them via discord, but when the game was about to start, i "lost" the connection to the game, because the launcher said that it was impossible to reconnect, also i
×