Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Premilix

Member
  • Content Count

    115
  • Joined

  • Last visited

Awards

This user doesn't have any awards

1 Follower

About Premilix

  • Title
    Member

System

  • CPU
    Intel i5-7600k
  • Motherboard
    MSI H110M Pro-VD Plus
  • RAM
    8GB 2400mhz (unbranded)
  • GPU
    ZOTAC GTX 1070 Blower Edition (Bulk)
  • Case
    Havana 535i
  • Storage
    HDD: 1TB Toshiba
  • PSU
    XILENCE XN053 600W ATX
  • Display(s)
    Acer Predator XB240H 24” 1080p/144Hz
  • Cooling
    CPU Cooler: XC032 XILENCE ; 120mm case fan
  • Keyboard
    Razer Blackwidow Chroma X
  • Mouse
    Razer Deathadder 2016
  • Sound
    Razer Kraken v2
  • Operating System
    Windows 10

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. The game I was playing was Minecraft and not too long ago, it blackscreened again but this time I had my headphones on so I knew the computer was definitely responsive because the sounds were still playing. The current driver version 20.4.2 is already the recommended one so I guess I have to wait for a new version. However, I still have no idea why it happened only now as I've been using this PC for almost 2 weeks no problem. I don't know, I tried removing the watermark of Activate Windows today and I changed a few things in regedit but after the first blackscreen changed them back, however, s
  2. I checked, my drivers are up to date using Radeon software.
  3. Hey! Today I was playing games on my new computer and randomly my PC display turned black. I pressed alt f4 because I thought it was maybe the game that crashed. Then I looked at what to do on internet and somewhere saw to press the Windows button + ctrl + shift + b and after I pressed those it came back. The game was closed which means my system was still responsive so I have no idea what happened. Could anyone help me explain this? Btw if you're wondering my GPU is a Gigabyte aorus rx 5700 xt.
  4. Well, I tried a lot of things and now it works. I don't really know what caused it but maybe Me installing a 2009 Microsoft driver from the device manager on my Ryzen 7 3700x. I also installed the chipset driver from my mobo's website but it still says 2009 on the CPU (idk maybe the chipset and CPU have different drivers i'm a bit stupid).
  5. Ty. Also why do so many Ryzen 3700x's show up when I expand the processor tab?
  6. Do I uninstall the current drivers straight from the device manager?
  7. I don't plan doing any crazy overclocking, just going to turn on precision boost
  8. Hey. I just built a new Ryzen 3700x system and I tried installing the Ryzen Master utility, however when I try to launch it after installation, it says "Ryzen Master failed to initialize. Kindly reinstall the program." I reinstalled it a few times now but still no result. Does anyone know what's causing this problem? Thank you!
  9. Alright so I decided to wait for either the gigabyte gaming oc, gigabyte aorus, powercolor red devil or sapphire pulse/nitro+ to go in sale and get one of those. Thanks to everyone who helped!
  10. Because there currently aren't any in stock where I live.
  11. I'm in Lithuania and I use kainos.lt to find the lowest prices. All of them but the red devil are in stock so yeah. I guess I'll just get the one with the lowest price.
  12. Well then I'm definitely getting an rx 5700 xt.
  13. Yeah, I know. Video cards in my country are priced pretty high for some reason. Though that is the final price, vat is already included in the prices.
×