Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

NotFestiveOwl

Member
  • Content Count

    49
  • Joined

  • Last visited

Awards

This user doesn't have any awards

About NotFestiveOwl

  • Title
    Member
  • Birthday Sep 02, 2003

Contact Methods

  • Discord
    FestiveOwl#7335
  • Steam
    NotFestiveOwl
  • Origin
    NotFestiveOwl
  • Twitch.tv
    notfestiveowl
  • Twitter
    NotFestiveOwl

Profile Information

  • Location
    Latvia
  • Gender
    Male

System

  • CPU
    INTEL I5-8600K
  • Motherboard
    ASUS PRIME Z370-P
  • RAM
    CORSAIR VENGEANCE LPX (2x4GB)
  • GPU
    ASUS ROG STRIX 1050TI 4GB
  • Case
    NZXT S340 ELITE BLACK
  • Storage
    SSD - SAMSUNG M.2 960 250GB HDD - WD BLUE 2TB
  • PSU
    CORSAIR CX650w
  • Keyboard
    Modecom Volcano Alpha
  • Mouse
    Creative sound Blasterx Siege M04
  • Sound
    Kingston HyperX Alpha
  • Operating System
    WINDOWS 10 PRO

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hello! I bought a Felyby BM-800 microphone, of course, not the best, very cheap, but is there a way to get rid of the hissing, and I know there is, 1 is editing sure, but I don't want to, what about audio interface or some adapters, since I have no idea how these microphones work, I need your help, what is a good, cheap audio interface or a power supply or whatever that can fix and get rid of the hissing on the spot. Thanks
  2. Hello, I'm having issues port forwarding my D-Link, I can't find the option http://prntscr.com/nbpno9 This is how it all looks like, if anybody knows how to achieve that, that'd be great, and why? I need to port forward it for my TS3 server.
  3. Soo... What are you saying? what should I do? did I stick the cables in the tight spot? also when i do my test through pc it says (“Ethernet” has invalid Ip configuration) or something like that
  4. Okay, so I have a slight problem and a crazy idea which should work... So I have a D-Link DIR-825 (the one with 4 antennas) and I have an iPhone 6, now by techincal logisctics I should be good when I stick a USB in the modem and it should be working, but it doesn’t and I don’t know what to do much here anymore. What I have done - I started a hostpot on my phone - Put the internet cable in the main cable
  5. Update Succesfully, thanks lads! Lmao it just shotdown in the middle while I was typing I got scared, haha
  6. I might need You to navigate me, since I have no idea what I’m doing, what do i do, where do i go? step by step lmao please
  7. Hello! I was wondering how to update the BIOS, now I know that You need to download it, I did, and put it on a empty flash, but I have a question, do I put this http://prntscr.com/m8fszi or http://prntscr.com/m8ft2n one of those files, so help also, how to move on afterwards, and should I, and if I do update my BIOS will I have to reinstall my whole PC or anything? Thanks
  8. Hi, so I restarted my PC fully, but while reseting it, I’m stuck on 9% for like 1 hour, already if not longer. It shows this, so help?
  9. I found it! Thanks, I found it by something else, I don’t remeber but thanks It’s easy
  10. On that page there is nothig useful, these are the lights that light up, also where you put GPU in those things light up.
×