Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Rushton

Member
  • Content Count

    59
  • Joined

  • Last visited

Awards

This user doesn't have any awards

About Rushton

  • Title
    Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Thanks guys! I got it.(typing from the Formatted PC) But I found that I have another problem. I have connected a brand new hard drive. it was detected during the installation but now I can't access it. I have tried to make a new partition during the windows 10 installation
  2. I just formatted my PC, It is an OEM key. I had a couple of issues that I could not solve normaly therefoe i decided to have a full format and a clean install. I have succesfuly formated the pc but now I can't connect to the Ethernet at all, and I dont have an wireless adapter. The PC see the network as an Unidentified network and it is stopping me from connecting to the internet. Any help or solutions would be appreciated. Thanks. I already tried to disconect and connect the cable on both ends. I also re formatted the pc.
  3. This one came out abotu 3 year ago, but it is still in production,
  4. I just bought it, it was brand new. Never used before
  5. PCPartPicker part list: https://uk.pcpartpicker.com/list/k4Wjr7 Price breakdown by merchant: https://uk.pcpartpicker.com/list/k4Wjr7/by_merchant/ CPU: AMD - Ryzen 5 1600 3.2GHz 6-Core Processor (£188.92 @ More Computers) CPU Cooler: NZXT - Kraken X31 69.5 CFM Liquid CPU Cooler (£53.98 @ YoYoTech) Motherboard: ASRock - AB350 Pro4 ATX AM4 Motherboard (£88.14 @ More Computers) Memory: G.Skill - Ripjaws V Series 16GB (2 x 8GB) DDR4-3200 Memory (£152.55 @ Amazon UK) Storage: OCZ - TRION 150 480GB 2.5" Solid State Drive Video Card: Palit - GeForce GTX 1080 8GB JetStream Vid
  6. I think i will have to buy a new one. As i have both the latest CPU drivers and the BIOS was reflashed.
  7. I did the re-flash, it didn't help. Now i am trying to install the latest amd ryzen driver.
  8. I didn't do any overclocking at all. i don't even have the inbuilt overclocking on.
  9. In most games I have lower fps than i would expect be it doom or shadow of mordor
  10. This is my set up, when I am playing rust or any game I have unexpectedly low fps for my pc specs. 20-60 fps which is very surprising.I have updated drivers and bios, I can't understand what is happening and I have no idea how can I fix it.I am thinking about changing my motherboard. Because I think it might be causing the problem, but do you guys have any advice CPU: AMD - Ryzen 5 1600 3.2GHz 6-Core Processor (£186.00 @ Amazon UK) CPU Cooler: NZXT - Kraken X31 69.5 CFM Liquid CPU Cooler (£53.98 @ YoYoTech) Motherboard: MSI - B350 PC MATE ATX AM4 Motherboard (£79.95
×