Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

celpas

Member
  • Content Count

    53
  • Joined

  • Last visited

Awards

This user doesn't have any awards

About celpas

  • Title
    Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I am finally able to get my hands on an RTX 3080 FE at MSRP today. It isnt expected to stay in stock for long. Should I get it or is a RTX 3080 Ti release in Jan inevitable. I have a budget of $999
  2. My system: Intel Core i9-9900k @ 4.8GHZ RTX 3080 GPU My current RAM is 2X8GB F4-3200C16D-16GVKB-G.SKILL International Enterprise Co., Ltd. Since I have cash left after this build, can anyone please recommend one of the best 2X8GB RAM for gaming, which would at least slightly increase FPS? I play at 1440p 144hz so want to maximise frame rate. Thanks in advance for helping
  3. I am on a NZXT S340 Elite case. I have a Corsair H100i v2 front mounted as an radiator with its fans for intake. These have SP120L as the stock fans. Which upgrade would be recommended?
  4. I have built a very expensive rig with an RTX 3080 FE and a 10900k and do not want it to be fried due to a desire for better aesthetics. Are Cablemod cables safe to use or is there even a slightest element of risk and I shouldn't bother? The below is my PSU HX Series™ HX1000 — 1000 Watt 80 PLUS® PLATINUM Certified Fully Modular PSU (corsair.com) These are the cables I am planning to get CableMod C-Series ModMesh Classic Cable Kit for Corsair RMi / RMx / RM (Black Label) – CableMod Global Store
  5. I currently have an NZXT FN V2 case fan set as exhaust which came with the case itself and looking to upgrade. I care about cooling performance more than noise. Which one would be a better buy?
  6. Well here's something weird. I disabled Hyper threading on my 9900k and now my CPU utilisation is always between 60-90% in the forests and 90-100% in cities and now my GPU utilisation isn't fluctuating wildly like before and is mostly a constant 90%. It seems this game is unable to utilise all threads properly.
  7. I just checked. When my GPU utilisation drops to 75% and FPS drops to 56 all the cores on my 9900k reach around 80% usage but none of them are pegged at 100%.
  8. I am playing at 1440p and using RTSS frame rate limiter. My FPS ranges from 60-80fps in Athens city in odyssey.
  9. My current rig- I9 9900k at 5ghz Asus Strix Z390E motherboard. RTX 2080 My current ram- https://www.amazon.com/G-SKILL-Ripjaws-PC4-25600-3200MHz-F4-3200C16D-16GVKB/dp/B015FXXBW0/ref=mp_s_a_1_2?keywords=gskill+ripjaws+16gb+ddr4+3200&qid=1578834422&sprefix=g+skill+ripjaws+16&sr=8-2 In Assassins creed odyssey, my gpu utilisation is between 75% to 90% in cities and my CPU is not pegged at 100% (it’s at 50% usage) so I was wondering if my RAM speed is the bottleneck. I am using it with the XMP profile. Will upgrading to a 4133mhz ram like the below help with the is
  10. So should I get it over the 1TB Samsung Evo as I only intend to game on it? With games like modern warfare and red dead requiring 300GB of space I want a bigger drive but if it’s a slower drive in real world usage I am ready to adjust a bit.
  11. My budget only allows for between these 2. I have heard the Intel drive wears out faster but my use case is only gaming. Will the Intel get the job done or should I go Samsung?
  12. I just built a new PC and installed the audio drivers from the manufacturer website and there is still no audio. Did I do something wrong? Please help
  13. I have an RTX 2080 paired with 16GB DDDR4 3200mhz RAM and a 7700k but on Battlefield V, my GPU usage is never really above 90% at any time and fps ranges from 67fps on some maps to 80 on others at 1440p resolution. 67 fps is when GPU usage is around 70%, sometimes even 55%. RTX and DLSS are off. Will upgrading to 9900k make GPU usage above 90% and increase fps? I only use my PC for gaming and mostly Battlefield V.
  14. Replaced the cooler and everything is back to normal. Thanks for your help :)
  15. System specs Intel Core i7 7700k Corsair H100i v2 water cooler Geforce RTX 2080 Seasonic X650 PSU I turned on my PC today and all off a sudden the water cooler radiator fans spun up to maximum and CPU temp reached 100 degrees. Just an hour ago it was working fine. I turned it off and when I turned it back on an hour later this happened. In Corsair Link software the pump is showing 0 RPM but I have never used this software before so I don’t know what it used to show before. All wires are secure as I didn’t even touch the internals. Is my motherboard dead o
×