Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Punisher_

Member
  • Content Count

    11
  • Joined

  • Last visited

Awards

This user doesn't have any awards

About Punisher_

  • Title
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Yes I've used all the recommended steps shown. The PC still drops signal Yes, I've tried all the recommended steps before . The PC still drops signal.
  2. This issue started to happen around Feb 2020, my screen would randomly go black (no signal) when playing games or just browsing on the Internet. The PC still runs but I'm forced to hold the power button and perform a restart. I've used another 1070 to iron out the issue but the issue still remains the same. I've also received another PSU from corsair as they've said it was defective but I highly doubt it's the PSU as they sent a brand new replacement. On event viewer I see "kernel power 41", I've had this before with my previous power supply and also with the new replacement.
  3. This issue started to happen around Feb 2020, my screen would randomly go black (no signal) when playing games or just browsing on the Internet. The PC still runs but I'm forced to hold the power button and perform a restart. I've used another 1070 to iron out the issue but the issue still remains the same. I've also received another PSU from corsair as they've said it was defective but I highly doubt it's the PSU as they sent a brand new replacement. On event viewer I see "kernel power 41", I've had this before with my previous power supply and also with the new replacement.
  4. OK I'll try that but once I do a force restart I get prompted with "overclocking failed" from the bios even though its not my overclock. I don't think it's my monitor but I'll give it a shot.
  5. This issue started to happen around Feb 2020, my screen would randomly go black (no signal) when playing games or just browsing on the Internet. The PC still runs but I'm forced to hold the power button and perform a restart. I've used another 1070 to iron out the issue but the issue still remains the same. I've also received another PSU from corsair as they've said it was defective but I highly doubt it's the PSU as they sent a brand new replacement. On event viewer I see "kernel power 41", I've had this before with my previous power supply and also with the new replacement.
  6. Thanks for the information. A UPS seems to be an expensive solution for me at the moment. I'll probably just sort out my main wall with an electrician or just use a 20m plug extention and connect the plug from another room.
  7. Thanks for the replies everyone. I would hire an electrician but due to covid 19 I'll probably have to wait a while. In regards to the main wall, I've used it for other items such as lamps and phone chargers, they seem to be functioning as normal. Also you guys have mentioned an UPS. I'm not familiar with that, could someone explain the purpose of that item if possible. Thanks again for your input.
  8. I've had two replacements power supplies blow up (AX1200i) and another spare (RM850) from a friend which blew up also. I've been using these on my main wall. I've built my PC around 2014 and never had these issues untill Jan 2020. This was when I received a black screen (no display input) but the PC remained on. I had to perform a hard reset by holding down the power button to use my PC again. Also, prior to receiving my replacement PSU I've always been using an extention plug. Scan UK confirmed that there was an issue with the AX1200i so I presumed everything was res
×