Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Lockon1997

Member
  • Content Count

    76
  • Joined

  • Last visited

Awards

This user doesn't have any awards

About Lockon1997

  • Title
    Member
  • Birthday May 25, 1997

Profile Information

  • Location
    Conroe, TX
  • Gender
    Male
  • Interests
    PC gaming and working on my truck
  • Biography
    Built my first PC when I was 15. I'm almost 19 now and my PC is running as good as when I built it but I figured after almost 4 years I'd give it a little upgrade.
  • Occupation
    Broke white boy

System

  • CPU
    Ryzen 1600x OC'ed 3.9GHz
  • Motherboard
    MSI x370 Gaming Pro Carbon
  • RAM
    Corsair Vengeance DDR4 3000MHz
  • GPU
    Nvidia GeForce GTX 1080 8GB GDDR5X
  • Case
    Corsair Air 540
  • Storage
    2x Samsung 850 EVO 500GB SSD
  • PSU
    Corsair RM750
  • Display(s)
    Insignia 1080p Roku TV
  • Cooling
    Corsair 140mm, Corsair H150i
  • Keyboard
    Corsair Strafe
  • Mouse
    MSI Interceptor
  • Operating System
    Windows 10

Recent Profile Visitors

849 profile views
  1. also in touch with nvidia lets see who can fix it faster LTT forums or Nvidia TS
  2. if you would have read the start of the thread i said its turned off
  3. its wierd though cause its only with my 1080 that ive ever had the problem with fps being locked ive been on these forums probably 3-4 times to try and fix this issue to no avail. even Nvidia tech support is useless. then again they barely have the knowledge to log into there own computers.
  4. i figured out what afaik means.... im kinda a dumbass as well lol
  5. and no. i have a game mode but that does nothing except bring down input lag
  6. "AFAIK"?? not familiar with the term.
  7. im running off a 1080p 60hz TV. i have had readings higher than 60 though on my old r9270x. and yes i know it "doesnt matter cause your TV is only 60hz" but it matters to me. i like to see my overhead and with it not letting me go over 60fps im not seeing that. cant even run proper benchmarks because my gpu isnt being fully utilized. and cant even overclock correctly because it doesnt display any performance over 60fps. all vsync is off in game and in panel
  8. i never had this issue with my old R9 270x on windows 10. help would be appreciated. ive tried most things and even been on these forums a few times so just list stuff off and ill let you know if ive tried it. GTX 1080
  9. still havent got my 1080 to put out more then 60fps
  10. i appreciate yalls help. like i said ive had this problem for a year and by god i miss running benchmarks.
  11. been there done that brother. reinstall and re-default
  12. yes i did. in game settings are always maxed and vsync always turned off first thing i do before i play a game lol. im a graphics whore. i even bumped the in game limiter to 144hz just in case
  13. and specs are on my profile
×