Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

deadmoo5e

Member
  • Content Count

    90
  • Joined

  • Last visited

Awards

This user doesn't have any awards

About deadmoo5e

  • Title
    Member

Profile Information

  • Gender
    Not Telling

System

  • CPU
    intel i7 4770k
  • Motherboard
    Maximus VI Formula
  • RAM
    Corsair Dominator Platinum DDR3 16GB 1866 MHz
  • GPU
    EVGA Geforce GTX 1080 Classified
  • Case
    Fractal Design Define R5
  • Storage
    OCZ Vertex 4 256 GB, Seagate Barracuda 3TB
  • PSU
    Corsair AX 750W
  • Display(s)
    BenQ XL2420Z, BenQ XL2420T
  • Cooling
    Corsair H100i
  • Keyboard
    Logitech G710+
  • Mouse
    Logitech G400
  • Sound
    Bose QC25
  • Operating System
    Windows 10 Home

Recent Profile Visitors

941 profile views
  1. I understand. I can barely read what's on the charger and I wouldn't have known what to look for. But thanks for the info. I just had to make sure. I can't risk breaking my AirPods even if it's unlikely that's Apple's own charger would damage it.
  2. Can I use this kind of charger that came with my iPhone on my AirPods? I realize this might be a stupid question but I couldn't figure it out on google, and I can't afford new AirPods should they get fried.
  3. I will consult the holy manual. Thanks for answering.
  4. I was just wondering if a 970 EVO NVMe M.2 SSD 1TB would be compatible with my Acer Aspire V17 Nitro Black Edition laptop. I tried googling the issue but I'm not entirely certain if I can.
  5. Yeah will do. I thought about reinstalling windows but I'm so sick of doing that. Everything seems to be working just fine.
  6. It does show up in this menu as an SSD. Not a HDD. So it's weird that I'm having this problem.
  7. I recently changed a Western Digital HDD with a Kingston A400 SSD. I used the same SATA cable connected to the same connector on the motherboard. Under 'my computer' it shows up with the correct storage and everything. Seems to be working just fine. Installed and ran a few games from the kingston drive. But in task manager it's listed as my old Western Digital drive. Is this problem something I can ignore or is it gonna cause issues down the line? Any way to fix it?
  8. I'll see what I can find. I don't have much access to extra electronics. Guess I'll have to bump this thread later.
  9. I might have a GTX 550 Ti lying around. I could try that if I can find it.
×