Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

mr.happy

Member
  • Content Count

    215
  • Joined

  • Last visited

Awards

This user doesn't have any awards

About mr.happy

  • Title
    Member

System

  • CPU
    i7-8700K
  • Motherboard
    MSI Z370 PC PRO
  • RAM
    Corsair Vengeance 16GB (2x8GB) cl16 DDR4 3200MHz
  • GPU
    EVGA GeForce GTX 1080 FTW2
  • Case
    Phanteks Eclipse
  • Storage
    Samsung 970 EVO 500GB nvme
    Samsung 970 EVO 1 terabyte nvme
  • PSU
    EVGA SuperNOVA 550 G3
  • Cooling
    Cryorig H5 Ultimate
  • Keyboard
    Corsair Strafe RGB MK.2
  • Mouse
    Logitech G502 Proteus Spectrum
  • Operating System
    Windows 10 Home

Recent Profile Visitors

1,145 profile views
  1. found the main issue, it was my ram, one of them was faulty. I replaced my ram with to 16gb 3200mhz and it improved
  2. My cpu is an 8700k and my psu is a evga 550w g3. I plan on upgrading my gpu from a 1080 to a 3080.
  3. Sorry for wording it weird, I meant updating the bios again, but as you said it has nothing to do with windows so no.
  4. I reinstalled windows 10 and wiped my ssd's. I was wondering if I need to reinstall motherboard drivers including bios.
  5. updated the drivers and didn't fix my issue, Im going to try a fresh install of windows
  6. in the lobby I get below 30 fps frame stutters when I move
  7. they immediately start at the spawning area before a match after I just get random fps drops below 30 as I am playing
  8. I get random fps drops in fornite below 30 fps even on low settings. I did a 3d mark test and my gpu passed. what seem to be the issue? my ping is 10-30
  9. I been wanting to upgrade my ram so I guess I have to upgrade
×