Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

MxZeal

Member
  • Content Count

    538
  • Joined

  • Last visited

Awards

This user doesn't have any awards

1 Follower

About MxZeal

  • Title
    Junior Member
  • Birthday Dec 08, 1994

Contact Methods

  • Steam
    MxZeal
  • Origin
    MxZeal
  • Battle.net
    MxZeal#1928

Profile Information

  • Location
    Toronto Canada
  • Gender
    Male
  • Biography
    New to tech/pc stuff! Go easy on me :P

System

  • CPU
    Intel i7-3930k
  • Motherboard
    Extreme Rampage IV
  • RAM
    16GB
  • GPU
    GTX 960
  • Case
    HAF 922
  • Storage
    850 Pro + 2TB WD Black + 3TB WD BLue
  • PSU
    Corsair 1050Hx
  • Display(s)
    Viewsonix XG2401 x2
  • Cooling
    Corsair H100i
  • Keyboard
    Tada68 With GMK Hydro caps
  • Mouse
    Logitech G502
  • Sound
    Xonar DGF

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I got home today to seeing artifacts on my screen when watching video and gaming..(with NO oc) so... now I'm starting to think it's the actual GPU. Also I will try an OC reinstall sometime this week edit = replugging fixed it...
  2. It's a theme (Warning the site is kind of aids LOL) https://virtualcustoms.net/showthread.php/82449-Windows-Black-Edition-for-Wimdows-10-1809-and-1903 Err not if you don't have integrated graphics lol
  3. Edit = I'm seeing more errors being caused by NVIDIA. I'm fairly certain the cpu usage is caused BY the system inconsistency, because there's nothing that stands out. I just thought either my system was hard bottlenecking, got a bad card, or its just a normal rtx 3000s problem. If anyone has experiences anything like this please let me know because I'm debating going back to my 1060 and selling my 3060 now.
  4. So you're saying its my OS not the GPU? But when I use DDU and uninstall my 3060 then put in my 1060 and install drivers everything is normal then i redo the same process for the rtx 3060 and problems occur
  5. SuperNOVA 650 G3 added to specs This is one of the things I mean about pc instability.. its all over the place jumping from 20% to 60% hitting 100% for half a second and it's just the brwoser, desktop window manager and system in the top 3 usages. What exactly do you mean by refreshing OS? reinstalling when adding new gpu? And yes I used DDU beforehand, I also retried it a couple times trying older drivers no help.
  6. So I managed to get an RTX 3060 and I was worried for a while before buying that my CPU would bottleneck but after research mostly what I found was "nah it'll be okay its not a big deal" but ever since I got my RTX 3060 ti my system OVERALL feels slower, has DPC latency and seems to be struggling and hanging and crashing a lot. Specs : Mobo : Extreme rampage IV cpu : i7 3930k psu : supernova 650 watts g3 gpu before : gtx 1060 6gb // now rtx 3060 ti evga ftw 16gb ram 1600mhz All temps are fine Did I make a mistake getting a GPU first before I upg
  7. Hx1050 an "overkill" psu i got from a friend a while ago Would getting a surge protector help prevent this?
  8. I was just wondering since it seems like the worst has passed, i can go 4-5 hours without it turning off. Also, a few weeks ago Toronto had an ice storm that caused my power to "flicker" (lights would dim but wouldnt turn off etc) Is it possible that the power problems fucked my psu up because it was completely fine before that.
  9. So the past month my PC shut down randomly twice, i thought nothing of it. TODAY my PC shut down like 10 times no error no freezing unexpectedly nothing out of the ordinary. I assume its PSU so I ordered a new one (its about time anyway) my new PSU wont arrive until Wednesday. Can I still use my PC until the new PSU arrives? I notice it shuts down more often when I'm in game. When I have power saver mode on and I'm just browsing or watching videos it only shut down once in 4 hours so far. My buddy told me I should underclock my cpu and gpu if i have to use it or just avoid it entirely because
  10. yes Oh it's a known bug? damn. Can't wait for the fix in 12 years.
  11. I have one monitor that's 60hz and one that goes up to 144hz (I set it to 120hz because it makes these problems Im about to say seem less harsh because of how syncing works) When I have any animation that goes off on my 60 hz monitor my 120hz monitor straight up lags (not the monitor it's self but whatever application I have open) For example, If i have discord open and i get new message or post is added or if someone joins channel (literally any animation) i get a stutter on my main monitor. If I'm on a page that doesn't have any animations (like reddit for example) there's no
  12. This happened to me today! I had everything off for months now I login to my PC today and it saids I have updates waiting to install? I had to manually re-disable everything from event logs to regedit... fucking pathetic nice going microsoft.
  13. I don't want to turn them off because I have useful things like when someone starts livestreaming on twitch, when malwarebytes picks something up etc.. but when I'm playing overwatch and one of these popup i feel like my game cuts to 30 fps (from 144) for a few seconds. Is there any fix to this without disabling them? Thanks.
  14. Guess not it's just really stupid lol
×